[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 379
  • Last Modified:

Hyper-V Time Synchronization : guest sbs2011 always ahead a few minutes

Hi everyone,

This subject has been discussed a million times, and I have spent a few hours reading one site after the next and I think a need new eyes to have a look at this at tell me what to do.

On many sites (http://blogs.msdn.com/b/virtual_pc_guy/archive/2010/11/19/time-synchronization-in-hyper-v.aspx seems to be the most "official"), it is recommended to NOT disable the Time Sychronization.

One has to disable in the guest VM, on the domain controller (sbs 2011 in my case), that the sychronization is made with the parent host (which is a hyper-v core, not connected to the internet, not in the domain).

I did so and if I query the ntp source, I have pool.ntp.org, which is correct.

If I force a sync, the time is set accurately, but a few seconds later, it jumps again a few minutes (4 in my case). This case is also mentioned on many site (and on the link above).

Please help, this is really driving me nuts :)
0
StephRu
Asked:
StephRu
  • 3
1 Solution
 
Peter HutchisonSenior Network Systems SpecialistCommented:
Really the PDC should be synced with a valid and reliable time source such as a NTP server on the internet and from no where else. Other VMs should sync with the PDC using it as the source (using type NT5DS for w32time).
0
 
StephRuAuthor Commented:
That's right and that's what I'm doing.

But the PDC (my sbs2011) is always off 4 minutes. It acts as if I didn't disable the sync with the host. The command that I used is :

reg add HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\VMICTimeProvider /v Enabled /t reg_dword /d 0

And as said, if I query the source, it will indicate pool.ntp.org and if I force a sync, it will be correct.. .but a few seconds later, it will change and jump 4 minutes.
0
 
frankhelkCommented:
Looks like a problem with the W32time service acting as NTP client. From my experience W32time is a constant source of annoyance it it's used that way.

I'd recommend to switch to the "real thing" - disable W32time completely and install a classic NTP service. Easy to install and to configure, and works like a charm. Please see this article for a simple howto and further references.

Be sure that W32time is completely disabled when using a NTP client, because 2 services manipulating the system clock will cause unpredictable ( & wrong) results.
0
 
StephRuAuthor Commented:
I have abandoned the possibility to configure my client independently from the host, as best practices tell to do so.

So I just updated my host clock and connected it again to the internet, but I really don't like this option, as I really like the idea that my Hyper-V Core was not connected to the local lan (and to the internet).
0
 
StephRuAuthor Commented:
I never found how to solve my initial question... so I used another way to fix my problem :(
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now