Internet Explorer partially loads website then 404 Error Code Appears

Up until a couple of days ago the website was working okay but now: Wont load in any Internet Explorer it will load partially then display a Error 404 I've had friends try to load the website on there computers in IE and they say the same things happen. The website loads fine in Chrome, Firefox, Safari and on Android phones.

If you can open IE:
You will be able to see the partial load then 404.

I'm wondering if the problem is through the website code as I have tried the website on 2 different Hosts with the same problem.

Any help will be most appreciated. This is the first job I have logged and if it's resolved I will definetly use this website again !
Who is Participating?
David Johnson, CD, MVPConnect With a Mentor OwnerCommented:
404's on /style.css / & /MyFontsWebFonts.css

If you fix the /MyFontsWebFonts.css it will probably work ok..

Most pages have a invalid character at line1 character 1 (a space maybe?)
Sam Simon NasserCONSULTANT/DIRECTORCommented:
i tried the website from my computer and it opens fine.
IE? still can't believe that people are still using it! get chrome of Firefox and feedback if the website opens or not
Sam Simon NasserCONSULTANT/DIRECTORCommented:
try these steps, they may help usually
open IE, go to tools, internet options, advanced.
press reset and also press restore advanced settings
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to and use offer code ‘EXPERTS’ to get 10% off your first purchase.

RoyalGraphicsAuthor Commented:
I should Stipulate I have designed the website and need the website to be compatible across all browsers. Thanks for your help Samnasser but The last message did not work !

It seems it will work on some internet explorers/ computers but not others :S
RoyalGraphics--The site works fine using my IE10.  This suggests the problem is with your IE and not the website.
Try running IE without Add-ons.
Put the site into Trusted Sites.

However, if you feel coding is the problem you may find help here
David Johnson, CD, MVPOwnerCommented:
if you remove the site from compatibility view it shows properly..  Otherwise it will flash and then you get the 404 error message.
RoyalGraphicsAuthor Commented:
VE3OFA - I'm only using one web font and I have attached a picture with how it is coded in formatting.css - I can't find a file called : MyFontsWebFonts.css

RoyalGraphicsAuthor Commented:
Thankyou very much. I really appreciate your help. Your a champion !!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.