Link to home
Start Free TrialLog in
Avatar of joolzhaines
joolzhainesFlag for United Kingdom of Great Britain and Northern Ireland

asked on

HP-UX add new LUN Disk

Hi,

I am new to HP-UX and I am having an issue adding a new SAN Storage drive, I have the drive visable to HP-UX but need to enable it so I can remotly store ignite backups on it, below is what I have so far.


First create the physical volume on the disk
# pvcreate -f /dev/rdsk/c47t0d1


In /dev create a vg directory
# mkdir -p /dev/vg_backup2
# chown root:root /dev/vg_backup2
# chmod 755 /dev/vg_backup2


in HP-UX each volume group must have a group device special file under its subdirectory in /dev
# /dev/vg_backup2
# ll /dev/*/group
# mknod group c 64 0x040000

Change the ownership to root:sys and the permissions to 640.
# /dev/vg_backup2
# chown root:sys group
# /dev/vg_backup2
# chmod 640 group


Create the new VG
# vgcreate -s 16 vg_backup2 /dev/dsk/c47t0d1
# vgdisplay -v vg_backup2

Create LV
# lvcreate -n lvol_test -L 256 vg_backup2
# lvdisplay /dev/vg_backup2/lvol_test
Avatar of tfewster
tfewster
Flag of United Kingdom of Great Britain and Northern Ireland image

What's the issues? Your procedure looks OK so far, but be aware that the vg device special file must be unique:
in HP-UX each volume group must have a UNIQUE group device special file under its # subdirectory in /dev
# cd /dev/vg_backup2  # Added the missing "cd"
# ll /dev/*/group   # to see what other vg device special files already exist
# mknod group c 64 0x040000  # 128 if this is LVM 2.0

The next steps are to create a filesystem on the test lv:
newfs -F vxfs -o largefiles /dev/vg_backup2/lvol_test

and mount it, e.g :
mkdir /backup2
(Though you probably want it mounted somewhere under /var/opt/ignite)

chmod 700 /backup2  # disable writes to the mount POINT
mount /dev/vg_backup2/lvol_test /backup2
# Assign appropriate ownership/permissions to the MOUNTED filesystem
#  (does not change the permission on the mount POINT, which is now masked by the filesystem mounted on it)
chown backup_user_name /backup2
chmod 755 /backup2
Avatar of joolzhaines

ASKER

Thanks for the great reply just what I needed, as I said I am new to HP-UX and just learning, below is the complete procedure taking into account your comments.


First create the physical volume on the disk
# pvcreate -f /dev/rdsk/c47t0d1

In /dev create a vg directory
# mkdir -p /dev/vg_backup
# chown root:root /dev/vg_backup
# chmod 755 /dev/vg_backup

in HP-UX each volume group must have a group device special file under its subdirectory in /dev
# cd /dev/vg_backup
# ll /dev/*/group
# mknod group c 64 0x040000 (128 if LVM 2.0)

The next steps are to create a filesystem on the test lv:
# newfs -F vxfs -o largefiles /dev/vg_backup/lvol_test


Mount it
# mkdir //var/opt/ignite
Disable writes to the mount POINT
# chmod 700 /backup
# mount /dev/vg_backup/lvol_test /backup

Assign appropriate ownership/permissions to the MOUNTED Filesystem (does not change the permission on the mount POINT, which is now masked by the filesystem mounted on it)
# chown root:sys/backup
# chmod 755 /backup

Create the new VG
# vgcreate -s 16 vg_backup /dev/dsk/c47t0d1
# vgdisplay -v vg_backup

Create LV
# lvcreate -n lvol_test -L 256 vg_backup
# lvdisplay /dev/vg_backup/lvol_test
ASKER CERTIFIED SOLUTION
Avatar of tfewster
tfewster
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial