Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

wfica32.exe faulting module gdi32.dll

Posted on 2013-06-11
5
Medium Priority
?
1,745 Views
Last Modified: 2013-06-13
I have two users running windows XP 32-bit.Both workstations are crashing when running published applications through a web portal. "citrix has stopped working error" and then forces the program to end. This happens like clock work every nine minutes. It will close the app, and when they open it, it starts where they left off.

The report shows Faulting application WFICA32.EXE, and faulting module gdi32.dll.

What I have done,
Checked Drivers,
Replaced the dll.
ran sfc /scannow
Updated ie.
One of the users has a fresh install of XP. no luck.

If there is anymore information needed please tell me.
0
Comment
Question by:NerfBSI
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 19

Expert Comment

by:basraj
ID: 39238606
Whether the user is having any roaming profiles connecting to the local desktop. What if another users logs into that same PC and login from there? Also user can access the application from a different desktop?

Try to recreate the user profile both on the local desktop and on the Citrix servers also.
0
 
LVL 19

Accepted Solution

by:
basraj earned 2000 total points
ID: 39238609
if user has any printers, try stopping printer services or remove printers temporarily to see if you can replicate the problem
0
 

Author Comment

by:NerfBSI
ID: 39240865
I have tired removing a majority of the printers, and problem still occurs. I'll try stopping them all. The user who has a clean install of windows has a new profile as well.  

Did a bit more research on the issue. ( I'm new here at the job and new to Citrix). The users connect to a vpn using juniper connect, then access what I believe a Xen app server.

The WFCIA32 exe is version 12.3.0.8

I do not control the App server.
0
 

Author Comment

by:NerfBSI
ID: 39244165
Stopping the Spool service stopped the error. What would would be the best way to go about  fixing this. I cannot just leave the spool service off.
0
 
LVL 19

Expert Comment

by:basraj
ID: 39244778
Some unsupported printers or corrupted printer drivers would cause this problem. Try adding printer/print driver one by one and find the culprit
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question