Solved

wfica32.exe faulting module gdi32.dll

Posted on 2013-06-11
5
1,686 Views
Last Modified: 2013-06-13
I have two users running windows XP 32-bit.Both workstations are crashing when running published applications through a web portal. "citrix has stopped working error" and then forces the program to end. This happens like clock work every nine minutes. It will close the app, and when they open it, it starts where they left off.

The report shows Faulting application WFICA32.EXE, and faulting module gdi32.dll.

What I have done,
Checked Drivers,
Replaced the dll.
ran sfc /scannow
Updated ie.
One of the users has a fresh install of XP. no luck.

If there is anymore information needed please tell me.
0
Comment
Question by:NerfBSI
  • 3
  • 2
5 Comments
 
LVL 19

Expert Comment

by:basraj
ID: 39238606
Whether the user is having any roaming profiles connecting to the local desktop. What if another users logs into that same PC and login from there? Also user can access the application from a different desktop?

Try to recreate the user profile both on the local desktop and on the Citrix servers also.
0
 
LVL 19

Accepted Solution

by:
basraj earned 500 total points
ID: 39238609
if user has any printers, try stopping printer services or remove printers temporarily to see if you can replicate the problem
0
 

Author Comment

by:NerfBSI
ID: 39240865
I have tired removing a majority of the printers, and problem still occurs. I'll try stopping them all. The user who has a clean install of windows has a new profile as well.  

Did a bit more research on the issue. ( I'm new here at the job and new to Citrix). The users connect to a vpn using juniper connect, then access what I believe a Xen app server.

The WFCIA32 exe is version 12.3.0.8

I do not control the App server.
0
 

Author Comment

by:NerfBSI
ID: 39244165
Stopping the Spool service stopped the error. What would would be the best way to go about  fixing this. I cannot just leave the spool service off.
0
 
LVL 19

Expert Comment

by:basraj
ID: 39244778
Some unsupported printers or corrupted printer drivers would cause this problem. Try adding printer/print driver one by one and find the culprit
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Sonicwall routing between VPNs 5 45
Setting up VPN on a virtual machine for iPhone Users 4 85
Citrix xenapp License server change 4 54
IT Contract Fee 17 127
If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now