Computer Won't Sleep

Hi,

I've got a Windows 7 PC and trying to get it to sleep for longer than a few minutes.

The computer can go to sleep properly using the power options to tell it to go to sleep after being idle.

However, for some reason, it doesn't stay asleep. It wakes up after a minute or two for no reason.

I'd prefer to keep 'Wake Up on Lan' enabled so that I can wake up the computer via Logmein if required. Apart from that, I want it to stay asleep.

Any idea what could be causing it to keep waking up? Is there any way to find out?

Many thanks
Dan
LVL 5
DanJournoAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jcimarronConnect With a Mentor Commented:
DanJourno--
Something running in the background may be the problem.  
Here is a possibly helpful reference
http://www.tomshardware.com/forum/282379-30-computer-wakes-itself-everything

Ded9 beat me by two hundredths of a second.  :(
0
 
ded9Commented:
Run this command from admin command prompt mode...this will tell you why sleep feature is not working.

powercfg -requests



Ded9
0
 
ded9Commented:
@jcimarron :-)


Ded9
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
DanJournoAuthor Commented:
C:\Users\DanJourno>powercfg -requests
DISPLAY:
None.

SYSTEM:
[DRIVER] \FileSystem\srvnet
An active remote client has recently sent requests to this machine.

AWAYMODE:
None.


C:\Users\DanJourno>
0
 
skullnobrainsCommented:
do you trigger wake-on-lan through some manual operation ?

if the wakeup is triggered by an incoming connection to your router, it is likely that any port-scanning robot might trigger it accidentally

btw, if you use regular sleep, you should be able to use the network nevertheless if you configure the network card properly

---

many devices may or may not be aloud to awaken your computer as well

---

sheduled tasks including some antivirus updates may awaken your computer

---

whatever the culprit is, you can determine why your computer last awoke by typing the following command as administrator

powercfg -lastwake
0
 
jcimarronCommented:
0
 
DanJournoAuthor Commented:
Here is the results from lastwake.

C:\Users\DanJourno>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Device
    Instance Path: USB\ROOT_HUB\4&2c1bf672&0
    Friendly Name:
    Description: USB Root Hub
    Manufacturer: (Standard USB Host Controller)
0
 
ded9Commented:
Follow the steps mentioned in this article and make sure your install updated network drivers.


http://mingersoft.com/blog/2011/12/why-wont-windows-automatically-sleep/





Ded9
0
 
skullnobrainsCommented:
meaning the USB stack is reponsible for waking up the computer

normally the device name should be displayed. since you have the id of the usb controller, you probably can use the device manager to determine what is plugged into this specific USB port

if i assume that windows does no do a mess of things and properly displays the device when feasible, a good guess could be that the device powers off automagically after some time, or ditches the USB connection when it receives no electricity from it for a while, the usb controller picks the state changed, and wakes windows up

if i assume that windows does a sh...y job as usual, it may just display the device name some times and not others. in that case, it can be any usb device including your mouse moving by 1/10 mm (ie not at all because optic mice cannot be trusted to be still... ever)

i probably did not cover everything, but i believe that you have a fair chance to find the device that is responsible for this mess in the device manager. you can also do the same by unplugging devices before you send the computer to sleep if you do not have tons of them, or waking the computer up voluntarily with the mouse, keyboard, by unplugging and replugging your digita cam or whatever other devices you use and comparing the output of the previous command

solutions range from device-specific stuff to set one or all usb ports to be unable to wake up the computer. in the device manager, you'll find options relative to keeping them powered up and allow them or not to awaken the computer.
0
 
DanJournoAuthor Commented:
I just retested to ensure I got the correct information.

Heres the results:-

C:\Users\DanJourno>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

Doesnt really help me.
0
 
DanJournoAuthor Commented:
Disabling wake up timers seems to have done the trick.

Thanks
0
 
jcimarronCommented:
DanJourno--
Glad all is well.  You are welcome.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.