Solved

Wordpress Administrator unable to access widgets and forced to re-log in to Dashboard

Posted on 2013-06-11
8
429 Views
Last Modified: 2013-06-11
I just set up a Wordpress site and am the Administrator, however when I attempt to go to the widgets area to edit, I'm forced to relogin to the Dashboard and am unable to access widgets.

This didn't happen yesterday and to my knowledge, nothing substantive has changed on the site to cause this issue.

I logged into PHPMyAdmin and my permissions seem to be okay if I'm reading correctly... under user meta, my capabilities are set at: a:1:{s:13:"administrator";b:1;}

What is causing Wordpress to keep me from accessing widgets and how do I fix it?

I can also provide the wp_user_roles from wp_options in case that's where the problem is.
0
Comment
Question by:Power_Pro
  • 4
  • 4
8 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39238839
Try creating a second Administrator account and see if the problem persists.
0
 

Author Comment

by:Power_Pro
ID: 39238858
Hey Jason... yeah I tried that with the hope that perhaps there was something amiss with that particular User ID.  No joy.

Same problem with both admins.

And it seems I can do everything else.  Add new users, edit theme files and plugins...but clicking on Widgets forces a relogin and won't let me access.  Very frustrating.
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39238896
So much for the easy fix.

Have you tried reinstalling the WordPress Core  (Dashboard | Updates | Reinstall WordPress)?

Is the admin being run through SSL?
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 

Author Comment

by:Power_Pro
ID: 39238959
I'm considering a reinstallation.  Site not being run through ssl.

Here's what I see in the address bar when I click on Widgets. :

http://kenburger.com/wp-login.php?redirect_to=http%3A%2F%2Fkenburger.com%2Fwp-admin%2Fwidgets.php&reauth=1
0
 
LVL 70

Accepted Solution

by:
Jason C. Levine earned 500 total points
ID: 39238985
Yeah, that's what one would expect to see if something is messed up.

So there are two things I can think to try off the top of my head:

1) Do the core reinstall.  This won't affect themes, plugins, content...it just grabs a fresh copy of the WP core and applies it.

2) If that doesn't work and if plugins are installed, disable all plugins and see if you get control back.
0
 

Author Comment

by:Power_Pro
ID: 39239006
I was about to do a reinstall of the core files ,but now all the sudden I can access widgets again.

Should I go ahead and do a core reinstall or should I see if this lasts?  Or is the fact that there was a problem in the first place an indication that I need to reinstall the core files?
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 39239119
If the problem just disappeared, I would reinstall the core anyway.  May have been a transient server connection issue but reinstalling the core never hurts.
0
 

Author Comment

by:Power_Pro
ID: 39239228
Thank you!
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Build an array called $myWeek which will hold the array elements Today, Yesterday and then builds up the rest of the week by the name of the day going back 1 week.   (CODE) (CODE) Then you just need to pass your date to the function. If i…
Load balancing is the method of dividing the total amount of work performed by one computer between two or more computers. Its aim is to get more work done in the same amount of time, ensuring that all the users get served faster.
The purpose of this video is to demonstrate how to update a WordPress Site’s version. WordPress releases new versions of its software frequently and it is important to update frequently in order to keep your site secure, and to get new WordPress…
The purpose of this video is to demonstrate how to Import and export files in WordPress. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Click on Too…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question