Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Secondary 169.254.x.x IPV4 address and routes are added after every reboot.

Posted on 2013-06-11
8
Medium Priority
?
790 Views
Last Modified: 2013-09-17
How can I stop this? It's causing my server to receive emails but not forwarding them to the client's mailbox. I don't know where it goes but I have GFI Mail Essentials installed and in its dashboard I could see the emails are accepted, but they don't show when I open Outlook 2007 or even login via OWA. I've even uninstalled GFI and reboot but the ipv4 & routes keep coming up after a reboot.

The same server is a DC and runs Exchange 2010 (yes I know it's not best practice but it's only my home mail server). This always worked until the last couple of days with nothing being done to the server.

I can get rid of the routes using route -delete and I can remove the ipv4 address with 'netsh interface ip delete address name="WAN" addr=169.254.101.106 but this doesn't resolve the email issue because I need to reboot and when I do that the 169.254.* addresses are back. I even tried adding the registry DWORD IPAutoConfigurationEnabled 0x00 and still it comes back. I noticed it takes a few seconds for the 2nd ipv4 to show up with ipconfig /all because if I do it right after the reboot it's not there.

Oh, and no, there is no 2nd ipv4 ip if I check the ethernet adapter. All settings are static.

I've also done several anti-virus scans using different products but they never find anything. This is running on a VM using Workstation 9.

Two nics are installed which allows me to vpn into the server (the 2nd nic is disabled in the OS).

Any ideas on what's causing it and more importantly how to fix it?
0
Comment
Question by:maservice
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 2

Expert Comment

by:babuse
ID: 39238954
Sounds like you have a second NIC.  This is an APIPA address that is used when a NIC is not configured for an IP or able to contact a DHCP server.

Look to see if you have one and disable it.
0
 
LVL 2

Expert Comment

by:babuse
ID: 39238968
--- Sorry should have read your entire message --- Disregard.  

When you do an ipconfig /all what is showing.  Can you post?
0
 

Author Comment

by:maservice
ID: 39239840
This is how it should look (and after I remove the 2nd ipvr address using netsh):

 Connection-specific DNS Suffix  . : ourdomain..local
 Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
 Physical Address. . . . . . . . . : 00-0C-29-60-67-0B
 DHCP Enabled. . . . . . . . . . . : No
 Autoconfiguration Enabled . . . . : Yes
 Link-local IPv6 Address . . . . . : fe80::3d58:c07e:cc93:64b9%15(Preferred)
 IPv4 Address. . . . . . . . . . . : 192.168.1.101(Preferred)
 Subnet Mask . . . . . . . . . . . : 255.255.255.0
 Default Gateway . . . . . . . . . : 192.168.1.1
 DHCPv6 IAID . . . . . . . . . . . : 268438569
 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-18-42-99-00-0C-29-80-67-

 DNS Servers . . . . . . . . . . . : 192.168.1.101
 NetBIOS over Tcpip. . . . . . . . : Enabled

This is how it looks after I reboot (and waiting about 4 minutes before the above changes. The network adapter icon has the circle over it for about 4 minutes before it's finally active, but then I get two ipv4 address):

Hmm, never mind. This time it wouldn't show the 2nd ipv4 but I'm still unable to receive/send external emails.

What's interesting is that in the GFI Mailessentials dashboard which shows all the incoming emails live, and when I send myself a test msg from hotmail I can see it (via the dashboard) coming in as:

sender: tester@hotmail.com
recipient: myemail@ourdomain.ca

then 1 second later I see:

sender:     postmaster@server03.ourdomain.local
recipient:  tester@hotmail.com

But I don't see the bounce in my hotmail account so it's unable to send external emails.

Something appears to block it from letting exchange push it to my mailbox. Spam filtering? GFI essentials always sent me bounces before and I'd see them in my Outlook but not now so I don't know if it's now blocking it or if the Microsoft antispam is joining the act. I doubt it's gfi because even if I uninstall it the same thing happens. Antispam in EMC I disabled temporarily and still no difference.  Nothing in the queue so I don't know where these emails are ending up since I can't see them anywhere.

I tried checking the logs at: C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\ProtocolLog\SmtpReceive but it's blank. Same for \SmtpSend. Maybe that's not the right path to check? Never checked on 2008 yet, only 2003. I did find many Transport Logs however and this could be the issue too. A couple of months ago I migrated from exchange 2003 to exchange 2010 and for the two months or so it's been running fine. Now I see in the transport logs many references to my old server (which is history now). Public folder store refers to my old server. Public folder database refers to my new server.Mailbox store refers to my old server. Still, I didn't have and I don't have issues accessing my mailbox via OWA or Outlook 2007. I am connected to my exchange server (no cache mode) and I can access all emails including the public folder. I just can't send or receive external emails anymore. Internal is fine although I see the on the gfi dashboard that the sender is postmaster@ourdomain.local instead of myexchangeemail@ourdomain.local. Seems like some routing issue now but I don't know what to do from here. I already went through everything in the EMC for Exchange 2010 and I see no references to my old server anywhere and everything appears to be the same as it was when things were working. I also checked my mx records.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:maservice
ID: 39239845
Strangely, outgoing external mail works now so when I sent a test msg from an external account to my domain email I got a bounceback:

Delivery has failed to these recipients or groups:

andrew@ourdomain.ca

The recipient e-mail system can't process this message now. Please try resending the message later.

Diagnostic information for administrators:

Generating server: server03.ourdomain.local

andrew@ourdomain.ca
#< #5.3.5> #SMTP#

Google isn't helping much with this error.
0
 

Author Comment

by:maservice
ID: 39239992
I've narrowed it down now to the SMTP service on port 25. It's not accessible via telnet from the outside, not even my lan. It only responds from the server itself. But even with the MS Firewall disabled I can't access it remotely. I tried an older snapshot and SMTP from outside works fine. Unfortunately I can't use that snapshot as it would take me back too far and lose some emails.

Why else would port 25 not work from another pc on the same lan with this snapshot?

Btw, the older snapshot also had the 2nd ipv4 169.x.x.x ip but after removing it with netsh and rebooting inbound and outbound emails were working fine. That snapshot is only 2-3 days old so I wonder what would've changed in such a short time that would block port 25 on its own.
0
 

Accepted Solution

by:
maservice earned 0 total points
ID: 39240039
I got it working, finally! Problem? As I said, smtp port 25 wasn't responding to outside of server. I kept digging and after running netstat -a I noticed it was listening for port 25 but not on the local ip, only 0.0.0.0 and the ipv6 address. So I checked the Receive Connector in Exchange 2010 and it was fine, it was set to listen to "All available ipv4" addresses on port 25. But I decided to edit it and change it to listen to only to the specific local ip of the exchange server and when I did a telnet test from another pc to port 25 on the exchange server this time it responded. After this I just sent myself an email from hotmail and bingo.

I then changed it back to All available ipv4 addresses on port 25 and SMTP still responded. Talk about a glitch!

Thanks for trying to help mate. I'm glad I have this over and done with after many frustrating and relentless hours of persistence into this issue.

This can be closed.
0
 
LVL 2

Expert Comment

by:babuse
ID: 39241697
Cool.  Sounds like you got it.
Have a good one.
0
 

Author Closing Comment

by:maservice
ID: 39498820
Found solution on my own.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A safe way to clean winsxs folder from your windows server 2008 R2 editions
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question