Solved

Windows Server 2003 and missing disk space

Posted on 2013-06-11
12
1,169 Views
Last Modified: 2013-06-15
I have an account with a Windows Server 2003 that is running out of disk space yet much of the space in unaccounted for in Windows Explorer making the problem difficult to resolve.

When I right click on the drive icon in My Computer and choose properties I get the following (all of the below numbers are rounded for simplicity):

Total space available on the main hard drive - 434 GB
Total space used - 426 GB
Free space - 7 GB

But if I open up the the drive in Windows Explorer, select all files and folders (yes, I am showing hidden and system files and folders) and choose properties I get:

Size - 131 GB
Size on disk - 131 GB

This is a discrepancy of about 295 GB, which is the majority of the drive.

I ran check disk which showed that my clusters are set to 4096.  The numbers from check disk also showed that 426 GB is used (so check disk agrees with the output from the properties of the drive, not from Windows Explorer)

My suspicion is that somehow permissions have been messed up with many of the files and folders on the drive, so even though I logged on as Administrator Windows Explorer isn't showing me everything.  I've looked at the security tab of of the drive and Administrator is listed as the owner.

Here's my question, there is an option to "Replace owner on subcontainer and objects".  I'm thinking that this may solve my problem, but I am concerned that this may cause other problems.  So, might this solve my problem so Windows Explorer's output is correct?  Could this cause any other problems on this server?
0
Comment
Question by:dcpwebber
12 Comments
 
LVL 24

Accepted Solution

by:
smckeown777 earned 500 total points
ID: 39239009
Run this on the server instead to see if it reports any differences...

Treesize - http://www.jam-software.com/freeware/

Or this one is good
http://windirstat.info/index.html
0
 
LVL 23

Expert Comment

by:Thomas Grassi
ID: 39239034
Has this server crashed in the past? Dump files sometimes can take up a lot of disk space and they are hard to see.

What about paging files check that out also.
0
 
LVL 7

Expert Comment

by:JardaCZ
ID: 39239035
0
 
LVL 4

Expert Comment

by:TechOps07
ID: 39239118
Right-Click My Computer>Manage, select Disk Management. See if this can help you decipher where it is all going.

perhaps the Hard drive was partitioned in some way?
0
 

Author Comment

by:dcpwebber
ID: 39239303
Responding to smckeown777:  Treesize shows what check disk shows, 400+ Gigabyte of data and only 7 GB free. It also shows one of the shared folders has 373 GB in it (Windows Explorer shows the same folder to contain only 97 GB)  So, Treesize (and check disk) can see the data but Windows Explorer can't.  Is there some way to fix this?

Responding to trgrassijr55:  Yes the server has crashed in the past, but I would think if I had viewing of hidden and system files and folders turned on the dump files would be accounted for.  Also, the paging file is visible in the root of the drive and so is part of the Windows Explorer data

Responding to JardaCZ:  Shadow copies are turned off (due to lack of disk space)

Responding to TechOps07: The physical drive is partitioned.  One of the partitions is where the space is missing - it's a 400+ GB partition that has about 300 GB unaccounted for in Windows Explorer.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39239317
Ok, but Treesize allows you to drill into the folders to see which is the largest - can you do this? Not sure why windows isn't reporting the size correctly - possibly you need to run a chkdsk on the drive to clean any potential issues...
0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 

Author Comment

by:dcpwebber
ID: 39239322
I ran a chkdsk /r over the weekend but the problem persists.

Yes I can drill down, but I'm still confused why Windows Explorer isn't seeing things correctly.  Since it's a shared folder with user data and not a system folder, I'm going to go the take ownership route and replace the owner on the subcontainers and objects, I'll update this item with the results.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39239338
The shared folder - does the default Admin not have access to it? Meaning the account that you are viewing the statistics with? Taking ownership is over the top I'd say, well depending on the underlying permissions for the other users...but if its not too much work then ok

Using Treesize is there one folder that appears to be taking a big percentage? I'd check the permissions on that folder first - possibly someone(user) changed something that is blocking windows admin account from seeing it
0
 

Author Comment

by:dcpwebber
ID: 39242354
I went to the shared folder and took ownership, I specified "replace owner on subcontainers and objects" - no change.  

I went to the security tab of the folder, chose advanced, and on the permissions tab I checked both the "Allow inheritable permissions ..." and the "Replace permission entries on all child object ..." options and hit Apply, but still have the same problem.

I check some of the folders within this folder and all of them seem to be larger in Treesize than when I display their properties with Windows Explorer.
0
 
LVL 24

Expert Comment

by:smckeown777
ID: 39242415
In the large folders you found(how many are there?) - within those folders have you found the large files for example?

The angle I'm coming from is - Windows properties isn't showing your size correctly - but at what level? I mean as an example if I have 1 main folder and 4 subfolders - the main folder doesn't show the correct size - but 3 of the 4 sub folders DO show the right size - so the issue is folder 4...can you determine using Treesize if you have a similar issue? So check a few of the subfolders to see if they are reporting size correctly - that way you can narrow this down to the issue folder...that's the way I'd approach it at this point(since everything you've already done is correct)

Are there ANY folders that are displaying the CORRECT size(matching treesize for example)?
How many subfolders are we talking about here? 100+?

Lastly - when you reset permissions - they did take effect yes? You've checked the lower level folders to confirm? Cause from time to time I've seen issues with permissions that did not push down to lower levels...check the permissions on some of the FILES within some of these oversized folders to see if they are reporting the permissions of the folder just in case...
0
 

Author Comment

by:dcpwebber
ID: 39245810
Within the folder there are 27 folders in both Treesize and Windows Explorer.

I've checked each of the folders and only 2 seem to match.  All the others are far bigger in Treesize than in Windows Explorer.

After doing some more detective work with Treesize and Windows Explorer I'm thinking that the problem lies with robocopy and junctions.  When our users log off we have a logoff script that copies their user profile from their PC to this folder on the server for backup.  The script uses robocopy.  The users are running Windows 7 and the server is Windows Server 2003.  I checked the logoff script and it did not have the /XJ switch on the robocopy command, so I added it.  We'll see if anything changes after tonight's round of logoffs.
0
 

Author Comment

by:dcpwebber
ID: 39250667
I booted the server with an Ubuntu live disk and deleted the contents of the shared folder.  The updated logoff script seems to function correctly so I think my problem is solved.  The Treesize utility gave me the data I needed to solve this.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Many of us need to configure DHCP server(s) in their environment. We can do that simply via DHCP console on server or using MMC snap-in on each computer with Administrative Tools installed in a network. But what if we have to configure many DHCP ser…
Scenerio: You have a server running Server 2003 and have applied a retail pack of Terminal Server Licenses.  You want to change servers or your server has crashed and you need to reapply the Terminal Server Licenses. When you enter the 16-digit lic…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now