[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 542
  • Last Modified:

Help! Emails are being delayed both internally and externally after adding new Exchange servers

Hello,

This is an urgent issue... We currently have one Exchange 2010 server doing CAS, Hub, and MBX roles. We decided to integrate a new Exchange servers into our environment, without doing anything to the existing server. We created a CAS Array and assigned a SSL cert to the machines, created a MBX DAG with two more servers and load balanced the traffic via Zen. Suddenly everyone on the original Exchange server is getting "Delivery is delayed to these recipients or groups."

We've had these machines operational for over a week and just began doing the SSL cert addition, load balancing the past day, and autodiscover the past day. We used completely different certs and urls:

Original SSL: email.contoso.com
New SSL: mail.contoso.com

Original redirect: redirect.contoso.com
New redirect: redirect1.contoso.com
0
jmichaelpalermo4
Asked:
jmichaelpalermo4
  • 2
1 Solution
 
jmichaelpalermo4Author Commented:
Getting an error on the CAS / Hub servers:

451 4.4.0 DNS query failed. The error was: SMTPSEND.DNS.NonExistentDomain
0
 
jmichaelpalermo4Author Commented:
Found the issue - I had set an external DNS on the CAS/Hub servers to 8.8.8.8 - We needed to set both DNS to internal
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now