Exchange 2013 Receive Connector for SMTP Enabled internal devices

Hi All,

We are migrating to Exchange 2013 and have hit a problem many on this version have encountered and many not yet resolved.

We have a number of devices that use SMTP to send status reports and scanned docs to our email server.  They have worked fine with Exchange 2010 but 2013 isn't playing the game, and I must be doing something wrong.

In ECP I have created a receive connector
I select Hub Transport as the role
I then select Custom
I leave the adapter bindings at default
I remove the "Remote Network" IP's, and assign the range of our internal ip range
I save this connector then open its properties to set the authentication under Security.  I uncheck all types so that no method of authentication is required.
for permission groups I only select anonymous

Does anyone have a step by step procedure on how to setup an receive connector for devices not capable of authenticating.
Who is Participating?
mbkitmgrConnect With a Mentor Author Commented:
The solution was provided by MS Exchange Support.  The vendor for our Digital Copier paid to have have it provided
Senthil KumarCommented:
Try creating a receive connector for a single device IP address and check whether it works. Give this receive connector permission to anonymous and  check.
mbkitmgrAuthor Commented:
Thanks , while I had tried this, I did do it again and Exchange still does not receive the email from simple devices
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

mbkitmgrAuthor Commented:
Many thanks to the moderator who rightly so pointed out this should have been included.

Like any organisation, I have a number of devices ranging from routers to switches, printers to multi-function centers, and some applications/scripts that send email via SMTP.

Some devices have no authentication mechanism in their software, while others offer windows credentials, and some support TLS.  I have been doing quite a bit of research on this and some suggestions either don't work, or are ill advised.  On one MS forum the "Moderator" confessed they had no idea how or if it could be done.

So what is the best way, and can it be provided as a step by step method.  I've set them up in the past with since Exchange 5.5, 2000, 2003, 2007, 2010 but cant crack it in 2013.  Judging by the number of hits on topics around this I am not in the minority.

I manage many sites that have the same types of devices making migration to Exchange 2013 a risk - so is it possible at all with Exchange 2013 - or do we exercise our downgrade rights to 2010 so that our major devices like the Multifunction centres can work in the way intended.?

To date I have tested Receive Connectors with the following properties

Custom Connector
tried both Hub and Frontend transport roles
With no Security, Basic Security, TLS Security (for those devices that supported it)
Permission group = anonymous
Remote Network settings = All Internal IP Addresses
Left Adapter bindings as defaults (all avail IPV4)
Set security to anonymous and externally secured. What ip scope do you have for your default connector? As your edge device be it firewall or spam appliance etc will be delivering mail on the same subnet, is the default connector being chosen and this rejecting the mail?

You should reduce the scope of the internal connector to the IPs of the devices and turn on logging of the connectors to get some additional information.
Jian An LimSolutions ArchitectCommented:
can you provide your receive connector in exchange 2010 ? (and exchange 2013?)

protocol logging: "verbose"
goto network - make sure receive mail from remote servers have the "right IP"
go to authentication and click "externally secured"
goto permission groups and click "exchange servers"


This should allow any email to sent (if match the IP) from anywhere to everywhere.
mbkitmgrAuthor Commented:
Ran the command ,

Get-ReceiveConnector "[Cust] - Relay Connector" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-recipient"

Open in new window

Restarted the transport service and front end transport.
Jian An LimSolutions ArchitectCommented:
anyway, your way works as well, but it will require powershell.
the way i use exchange server as permission groups will not require so ..
but works well ...
mbkitmgrAuthor Commented:
Resolved by Microsoft Support
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.