Solved

Cisco ASA 5510 & Two Local Networks

Posted on 2013-06-12
57
149 Views
Last Modified: 2015-03-05
I have a Cisco ASA 5510. There are three interfaces

1. Inside security level 100 10.10.x.x  (Local Network)

2. Outside security level 0 69.27.x.x (ISP)

3. Network2 security 100 192.168.x.x (Second Network)


I'd like the inside (Local Network) be able to access Network2 (Second Network) but would not like the Network2 to be able to access Inside. The only reason the inside network needs to access Network2 is so that they have access to a plotter on Network2 that has a static IP of 192.168.x.210

How would I do this? Thank you in advance for all help!
0
Comment
Question by:stevegarri
  • 23
  • 15
  • 15
  • +1
57 Comments
 
LVL 17

Expert Comment

by:Kvistofta
Comment Utility
First you need to allow traffic between 2 interfaces with the same security-levels. Add:

same-security permit inter-interface

Next, make sure that you allow traffic from Local Network to Second Network in any ACL. Like:

access-list inside_access_in permit ip 10.10.0.0 255.255.0.0 192.168.0.0 255.255.255.0
access-group inside_access_in in interface inside

last, you need to deny traffic from Second Network to Local Network:

access-list network2_access_in deny ip 192.168.0.0 255.255.255.0 10.10.0.0 255.255.255.0
access-l network2_access_in permit ip any any
access-group network2_access_in in interface network2

Best regards
Jimmy
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Or just change the security level of Network 2 to 80.  (The difference has to be at lease 20)
0
 

Author Comment

by:stevegarri
Comment Utility
For access-list inside_access_in permit ip 10.10.0.0 255.255.0.0 192.168.0.0 255.255.255.0

Would I use the IP of 10.10.0.0. or the ip of the actual interface 10.10.x.x  same with 192.168.0.0?

Also when I ran the  access-list inside_access_in permit ip 10.10.0.0 255.255.0.0 192.168.0.0 255.255.255.0 command with correct IP address I got the following error:

ERROR: % Invalid input detected at '^' marker.

asavener: I lowered the security on the second network and I still cannot ping any IP address on that network :-(
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Changing the security only works if there is no access list applied to the more-highly-trusted network.  So if you have an access list applied to Local Network, there are other steps that must be taken.
0
 

Author Comment

by:stevegarri
Comment Utility
Too make things easier here are the IPs for the two interfaces:

1. Inside security level 100 10.10.89.254  (Local Network)

3. Network2 security 100 192.168.1.253 (Second Network)

Still confused on how to get this to work. I was able to run the commands as exactly shown below but still couldn't ping 192.168.1.210 from the 10.10.89. network

access-list inside_access_in permit ip 10.10.0.0 255.255.0.0 192.168.0.0 255.255.255.0
access-group inside_access_in in interface inside
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
What NAT rules do you have defined?
0
 

Author Comment

by:stevegarri
Comment Utility
The only rules I have are the ones for the Inside and Outside (ISP) that allow the network internet access.
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
But do the rules match all traffic?  You may have to exclude traffic destined for the other subnet.
0
 

Author Comment

by:stevegarri
Comment Utility
I don't have any rules in place in regards to inside interface and network 2 interface. That is what I'm asking for help on :-(
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
What version of the ASA operating system are you running?
0
 
LVL 17

Expert Comment

by:Kvistofta
Comment Utility
Have you applied this command as described above?
same-security permit inter-interface

Br Kvistofta
0
 

Author Comment

by:stevegarri
Comment Utility
Version 6.4

@Kvistofta: Yes I have but I have zero Nat or Access Rules allowing the two networks to communicate. The commands you recommended do they still apply if the IP addresses for the two interfaces are:

1. Inside security level 100 10.10.89.254  (Local Network)

3. Network2 security 100 192.168.1.253 (Second Network)

I tried with the 10.10.0.0 and 192.168.0.0 . Also each network has a subnet of 255.255.255.0
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
ping isn't always the best test.  on an ASA you either need to modify the global_policy policy map and add an 'inspect icmp' to the class-map inspection-default (i think I'm remembering that right) or you need to apply an acl to the network2 interface that allows icmp back.  This is because icmp isn't stateful and by default ASA's don't try to treat it as stateful.

everything else they've been saying about same-security (if you leave the security level the same) and applying the ACL or simply lowering the network2 security level (without applying an ACL) will work
0
 

Author Comment

by:stevegarri
Comment Utility
So the follow commands below work with the follow IP addresses for each  interface: 10.10.89.254 and 192.168.1.253

access-list inside_access_in permit ip 10.10.0.0 255.255.0.0 192.168.0.0 255.255.255.0
access-group inside_access_in in interface inside

last, you need to deny traffic from Second Network to Local Network:

access-list network2_access_in deny ip 192.168.0.0 255.255.255.0 10.10.0.0 255.255.255.0
access-l network2_access_in permit ip any any
access-group network2_access_in in interface network2

Then I add an 'inspect icmp' to the class-map inspection-default or apply an acl to the network2 interface that allows icmp back?
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
well, if you apply that acl for network2 you'd need to do something like the following to it if you want to the acl way

access-list network2_access_in line 1 permit icmp 192.168.0.0 255.255.255.0 10.10.0.0 255.255.255.0

though I'd check the subnets you're specifying in the acls because they don't match the IPs you're saying are on the interfaces.
0
 
LVL 17

Expert Comment

by:Kvistofta
Comment Utility
You can´t possibly be running ASA code 6.4, really? I think that you mean the ASDM code.

the command same-security permit inter-interface IS needed if you want 2 interfaces with the same security-levels to communicate. No matter acl:s or NAT.

I think you need to post your full config here to get further help. Of course you should sanitize it to remove passwords and other sensitive information.

Br Kvistofta
0
 

Author Comment

by:stevegarri
Comment Utility
How do I get the full config?
0
 
LVL 17

Expert Comment

by:Kvistofta
Comment Utility
show run
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
In the ASDM there should be an option to show the running configuration in a new window.
0
 

Author Comment

by:stevegarri
Comment Utility
Config is below. The ISP IP (Public IP) address is labeled as: *.*.*.* (ISP IP)


ASA Version 8.2(5)
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 12
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.89.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address *.*.*.* (ISP IP) 255.255.255.240
!
interface Vlan12
 nameif Kleinberg
 security-level 100
 ip address 192.168.1.253 255.255.255.0
!
ftp mode passive
same-security-traffic permit inter-interface
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit gre any any
access-list outside_access_in extended permit tcp any any eq pptp
access-list acl-out extended permit gre any host *.*.*.* (ISP IP)
access-list acl-out extended permit tcp any host *.*.*.* (ISP IP) eq pptp
access-list acl-out extended permit tcp any interface outside eq smtp
access-list acl-out extended permit tcp any interface outside eq https
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu Kleinberg 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface pptp 10.10.89.5 pptp netmask 255.255.255.255
static (inside,outside) tcp interface smtp 10.10.89.5 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 10.10.89.5 https netmask 255.255.255.255
static (inside,outside) tcp interface www 10.10.89.5 www netmask 255.255.255.255
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 *.*.*.* (ISP IP) 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
class-map pptp-port
 match port tcp eq pptp
!
!
policy-map global_policy
 class inspection_default
  inspect pptp
policy-map pptp_policy
 class pptp-port
  inspect pptp
!
service-policy global_policy global
service-policy pptp_policy interface outside
prompt hostname context
call-home reporting anonymous
Cryptochecksum:6bb135c63751faa63f2b1da34b891ae2
: end
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
This guy right here is your problem:

nat (inside) 1 0.0.0.0 0.0.0.0

All of the traffic on the inside interface is being caught by the dynamic NAT rule, and it doesn't know what to do with the traffic.

Two options:

One, just add a global rule for the other interface:
global (Kleinberg) 1 interface

Alternately, prevent NAT'ing by adding a NAT 0 rule

access-list no_nat extended  permit ip 10.10.89.0 255.255.255.0 192.168.1.0 255.255.255.0

nat (inside) 0 access-list no_nat
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
the global (Kleinberg) 1 interface isn't required from what I know of.  The reason is because if the interfaces are of the same security level and nat control is disabled (default behavior in this os version) then no translation rules are required.  the nat (inside) 1 only comes into play if the packet is destined to traverse the outside interface as well.

try a packet-tracer to see where its gettings killed

packet-tracer input inside tcp 10 .10.89.10 1024 192.168.1.10 9100 detailed

provide the output of that command
0
 

Author Comment

by:stevegarri
Comment Utility
@asavener After running that command I would then change the security level for the Kleinberg interface to 80 yeah?

@Cyclops3590 Kleinberg interface is the second network I'm trying to connect.

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc96a6530, priority=1, domain=permit, deny=false
        hits=22429055, user_data=0x0, cs_id=0x0, l3_type=0x8
        src mac=0000.0000.0000, mask=0000.0000.0000
        dst mac=0000.0000.0000, mask=0100.0000.0000

Phase: 2
Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in   192.168.1.0     255.255.255.0   Kleinberg

Phase: 3
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc96a7278, priority=2, domain=permit, deny=false
        hits=32438, user_data=0x0, cs_id=0x0, flags=0x3000, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Phase: 4
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc96a8c68, priority=0, domain=inspect-ip-options, deny=true
        hits=111584, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Phase: 5
Type: NAT
Subtype:
Result: DROP
Config:
nat (inside) 1 0.0.0.0 0.0.0.0
  match ip inside any Kleinberg any
    dynamic translation to pool 1 (No matching global)
    translate_hits = 31048, untranslate_hits = 0
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc9e8d338, priority=1, domain=nat, deny=false
        hits=31045, user_data=0xc9311f68, cs_id=0x0, flags=0x0, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Result:
input-interface: inside
input-status: up
input-line-status: up
output-interface: Kleinberg
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
ok, nat control must be on then though I didn't see it in the config, because what I found for 8.2 was that same security level doesn't require translation rule, but if one exists it'll be used.

how you do nat depends on exactly how you want communication to happen.  if you just want inside hosts to talk to Kleinberg and not vice versa ever then add the global like asavener stated.  this does a PAT though so it becomes very difficult to track who is making what requests; not a big deal if its only printer communication like you stated.  if you want to better track who is doing what or you want the ability for kleinberg hosts to initiate communication to inside hosts you need to do an identity nat

static (inside,Kleinberg) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
static (Kleinberg,inside) 10.10.89.0 10.10.89.0 netmask 255.255.255.0
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
oops, no asavener is right.  I'm confusing myself.  if you remove the nat (inside) 1 then  you'd be fine.

default behavior

low security to high security - no translation required
high security to low security - translation required (hence the global needed)
same security - no translation required

once you added the nat 1 it overroad the default behavior.
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
sorry, reversed the IPs.  use this for identity nat

static (inside,Kleinberg) 10.10.89.0 10.10.89.0 netmask 255.255.255.0
static (Kleinberg,inside) 192.168.1.0 192.168.1.0 netmask 255.255.255.0
0
 

Author Comment

by:stevegarri
Comment Utility
I'd like inside to communicate with Kleinberg but I don't want kleinberg to communicate with inside
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
follow asavener's advice and add the global (Kleinberg) 1 interface command then.  that should solve the problem.  no need to change sec level either as you've added the same-security permit inter-interface command.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 28

Expert Comment

by:asavener
Comment Utility
As a best practice, I'd recommend changing the security level of the Kleinberg interface.

(Make sure you change it to 80 or lower.  Despite the range of 0-100, it requires a difference of 20 or more for the ASA to detect it as a different security level.)

The no-nat rule will perform the same function as the identity NAT, but with less overhead and less confusion, IMO.  The source IP addresses will be preserved.

If it were my firewall, I'd go with changing the security level of the Kleinberg interface and adding the nat 0 rule.
0
 

Author Comment

by:stevegarri
Comment Utility
I ran the follow commands below and set the Kleinberg Interface's security level to 80:

access-list no_nat extended  permit ip 10.10.89.0 255.255.255.0 192.168.1.0 255.255.255.0

nat (inside) 0 access-list no_nat

I'll let you guys know what happens. I tried to ping it but no reply but maybe it will print? We'll see
0
 

Author Comment

by:stevegarri
Comment Utility
Yeah that didn't work. Theres still no communication between the two networks :-(
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
run that packet-tracer again.  what does it look like now?
0
 

Author Comment

by:stevegarri
Comment Utility
Here is an updated copy of the config settings after what I applied:

ASA Version 8.2(5)
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 12
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.89.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address (outside IP) 255.255.255.240
!
interface Vlan12
 nameif Kleinberg
 security-level 80
 ip address 192.168.1.253 255.255.255.0
!
ftp mode passive
same-security-traffic permit inter-interface
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit gre any any
access-list outside_access_in extended permit tcp any any eq pptp
access-list acl-out extended permit gre any host (outside IP)
access-list acl-out extended permit tcp any host (outside IP) eq pptp
access-list acl-out extended permit tcp any interface outside eq smtp
access-list acl-out extended permit tcp any interface outside eq https
access-list no_nat extended permit ip 10.10.89.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu Kleinberg 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list no_nat
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface pptp 10.10.89.5 pptp netmask 255.255.255.255
static (inside,outside) tcp interface smtp 10.10.89.5 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 10.10.89.5 https netmask 255.255.255.255
static (inside,outside) tcp interface www 10.10.89.5 www netmask 255.255.255.255
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 (outside IP) 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto ca trustpoint _SmartCallHome_ServerCA
 crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
 certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
  quit
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
class-map pptp-port
 match port tcp eq pptp
!
!
policy-map global_policy
 class inspection_default
  inspect pptp
policy-map pptp_policy
 class pptp-port
  inspect pptp
!
service-policy global_policy global
service-policy pptp_policy interface outside
prompt hostname context
call-home reporting anonymous
Cryptochecksum:81e06d9dc92709a90ac61793c261c47a
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
can you run that packet-tracer command again and post the results.  just makes it easier doing it that way.
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
and run the following to enable icmp inspection

policy-map global_policy
class inspection_default
inspect icmp
0
 

Author Comment

by:stevegarri
Comment Utility
here is the traceroute info:

Phase: 1
Type: ROUTE-LOOKUP
Subtype: input
Result: ALLOW
Config:
Additional Information:
in   192.168.1.0     255.255.255.0   Kleinberg

Phase: 2
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc96a8c68, priority=0, domain=inspect-ip-options, deny=true
        hits=137934, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Phase: 3
Type: NAT-EXEMPT
Subtype:
Result: ALLOW
Config:
  match ip inside 10.10.89.0 255.255.255.0 Kleinberg 192.168.1.0 255.255.255.0
    NAT exempt
    translate_hits = 97, untranslate_hits = 0
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc9ec1b10, priority=6, domain=nat-exempt, deny=false
        hits=97, user_data=0xc9311f68, cs_id=0x0, use_real_addr, flags=0x0, protocol=0
        src ip=10.10.89.0, mask=255.255.255.0, port=0
        dst ip=192.168.1.0, mask=255.255.255.0, port=0, dscp=0x0

Phase: 4
Type: NAT
Subtype:
Result: ALLOW
Config:
nat (inside) 1 0.0.0.0 0.0.0.0
  match ip inside any Kleinberg any
    dynamic translation to pool 1 (No matching global)
    translate_hits = 0, untranslate_hits = 0
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc6b94d20, priority=1, domain=nat, deny=false
        hits=97, user_data=0xc9f74df0, cs_id=0x0, flags=0x0, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Phase: 5
Type: NAT
Subtype: host-limits
Result: ALLOW
Config:
nat (inside) 1 0.0.0.0 0.0.0.0
  match ip inside any inside any
    dynamic translation to pool 1 (No matching global)
    translate_hits = 0, untranslate_hits = 0
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0xc9708b70, priority=1, domain=host, deny=false
        hits=42870, user_data=0xc9708758, cs_id=0x0, reverse, flags=0x0, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Phase: 6
Type: IP-OPTIONS
Subtype:
Result: ALLOW
Config:
Additional Information:
 Reverse Flow based lookup yields rule:
 in  id=0xc9f768f0, priority=0, domain=inspect-ip-options, deny=true
        hits=96, user_data=0x0, cs_id=0x0, reverse, flags=0x0, protocol=0
        src ip=0.0.0.0, mask=0.0.0.0, port=0
        dst ip=0.0.0.0, mask=0.0.0.0, port=0, dscp=0x0

Phase: 7
Type: FLOW-CREATION
Subtype:
Result: ALLOW
Config:
Additional Information:
New flow created with id 136854, packet dispatched to next module
Module information for forward flow ...
snp_fp_tracer_drop
snp_fp_inspect_ip_options
snp_fp_tcp_normalizer
snp_fp_translate
snp_fp_adjacency
snp_fp_fragment
snp_ifc_stat

Module information for reverse flow ...
snp_fp_tracer_drop
snp_fp_inspect_ip_options
snp_fp_translate
snp_fp_tcp_normalizer
snp_fp_adjacency
snp_fp_fragment
snp_ifc_stat

Result:
input-interface: inside
input-status: up
input-line-status: up
output-interface: Kleinberg
output-status: up
output-line-status: up
Action: allow
0
 

Author Comment

by:stevegarri
Comment Utility
Ran:

policy-map global_policy
class inspection_default
inspect icmp

Still can't ping the 192. network
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
can you rerun the packet-tracer but sub in the real client IP and the real ip of the printer?  according to that trace it should be working.  Also, is the printer listening on jet direct 9100 or some other port for communication; e.g. cups, lpr.

packet-tracer input inside tcp **client_ip** 1024 **printer_ip** **printer_port** detailed
0
 

Author Comment

by:stevegarri
Comment Utility
It has it's own network card, I have no idea what port it's on.
0
 

Author Comment

by:stevegarri
Comment Utility
I can't ping anything on the other network
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Most printers use TCP/9100.

Does the other network use 192.168.1.253 for a default gateway?

The weakness of the current config is that it requires devices on that network to have a route back to the 10.10.89.0/24 network.

If you don't want the hosts on 192.168.1.0/24 to need routing info, then issue these commands:

no nat (inside) 0 access-list no_nat

global (Kleinberg) 1 interface
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
can you ping from the asa itself?  can you ping the asa from a client on that subnet?

what kind of network printer is it? HP?  or is a print server like windows server?  

the reason I want to put real addresses/ports to that command is I want to make sure the ASA says everything is good.  from what I see there isn't anything wrong with the asa at this point so I'm wondering if the other devices are configured correctly.
0
 

Author Comment

by:stevegarri
Comment Utility
Its a Xerox Plotter. If we connect a workstation directly through the network cable plugged into the ASA we can print to the plotter as well as ping it. We cannot through the ASA itself. I can ping the ASA itself.
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
ya, chances are its 9100 then.  Also, I do have to wonder if the plotter has its default gateway set to the ASA.

if you're tired of fussing with it, just configure the no nat and global commands that asavener gave.  otherwise please verify the plotter network configuration.  Can any of those hosts get to internet hosts even?  Just curious if anything on that subnet is configured to use the asa as a default gateway.
0
 

Author Comment

by:stevegarri
Comment Utility
I think your getting confused. There are two separate networks. One network has one firewall and our network has our firewall. Plugging a computer directly to the line we can access the network no problem as the line is plugged into their switch and not their firewall. I'm connect that same line into our firewall and give our entire network access to their network so we can access that plotter. By passing our ASA with a computer I have total access to everything on their network. I can remote into servers, workstations, access to all their printers etc. I need that same access through our firewall.
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
yes, I am confused then because your config shows you have an interface on the 192.168.1.0/24 network which is Kleinberg (aka Network2) which is the network you stated the plotter was on.  Is this not so?

Can you please post a picture of you network architecture so we can get a better understanding of what it looks like? Or do an ascii net diagram?  

If the traffic is going thru another firewall then we need to look at that one as well because it could be causing the problem at this point.
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Did you try entering the commands I provided above?

no nat (inside) 0 access-list no_nat

global (Kleinberg) 1 interface


The current issue is that the devices on the Kleinberg network do not route the traffic back through the ASA to the 10.10.89.0/24 network.

There are a few ways to fix this:

1) Add a static route on each device in the Kleinberg network that needs to communicate with your network.  (Just the plotter, but adding a static route on a print device can be a challenge.)

2) Add a static route on the Kleinberg firewall.  This can be a challenge because you presumably don't have administrative access to it.  Also, firewalls are not routers, so it still decide to drop the traffic, since it only sees one half of the connection.

3) Eliminate the need for a static route by NAT'ing your traffic to an address on the Kleinberg network.  That's what I'm suggesting above.
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
i concur with asavener.  go with #3 there and be done with it.  Whether it's the "best" option is a matter of debate.  However it sounds like in your scenario its definitely going to be the simplest.  Which at least in my book is 99 times out of a 100 the best option.  :)
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
so it still decide
Gah.  "So it MAY still decide...."
0
 

Author Comment

by:stevegarri
Comment Utility
So I run: no nat (inside) 0 access-list no_nat global (Kleinberg) 1 interface

And then I'll be able to communicate with the Kleinberg network?
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
you have to add the global command, too.

Both of these commands:

no nat (inside) 0 access-list no_nat

global (Kleinberg) 1 interface
0
 

Author Comment

by:stevegarri
Comment Utility
I still can't ping anything on their network :-(
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Please try this:

Run "clear xlate."

Start a continuous ping.

Provide the output of "show xlate."   (You can remove any output that doesn't have a 192.168.1.x translated address.)

Also, if you could provide the output of the packet tracer again, that'd be great.

Also, can you ping the destination address from the ASA itself?
0
 

Author Comment

by:stevegarri
Comment Utility
There is no output of show xlate
0
 
LVL 28

Expert Comment

by:asavener
Comment Utility
Can you ping anything on the Kleinberg network from the ASA?

What about the output from the packet tracer?
0
 

Author Comment

by:stevegarri
Comment Utility
I can't ping anything on the Kleinberg network :-(
0
 
LVL 28

Accepted Solution

by:
asavener earned 500 total points
Comment Utility
OK.  It sounds like maybe your not connected to the right switch or VLAN.

If you try to ping a device in the 192.168.1.0/24 subnet, does it show up in your ARP table?  (show arp)
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

There is a question posted at http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_28324159.html (http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_28324159.html) and i…
Transferring data across the virtual world became simpler but protecting it is becoming a real security challenge.  How to approach cyber security  in today's business world!
This video discusses moving either the default database or any database to a new volume.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now