You don't currently have permission to access this folder.

Hello,

We recently migrated several shares from our Windows Server 2008 Std to a new Windows Server 2012 storage.  We did this via a Commvault restore in order to keep all of the ACLs.  And it worked just fine.

Here's the issue:  If I navigate to these folders from my workstation (\\servername) I can access them just fine.  However, when I do an RDC to the server and try to access any of the new shares, I receive the attached error.  I don't get it, I am in both Domain and Enterprise Admins groups.  ANd some of the other admins are experiencing the same issue.

If I click Continue, I gain access and my user ID gets added to the Security list but, if I take my name of that list, boom!, I loose access again.

Thanks
Permission01.JPG
IDMAAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Michael MachieConnect With a Mentor Full-time technical multi-taskerCommented:
First off, verify that your credentials for the RDC are the same that you use for logging into your laptop. If they are different, make them the same and then try accessing the folder again - it could be as easy as a simple User account not having permissions.

Also, The migration tool can possibly bring over share permissions from the source folder and I expect you will encounter additional folders with this issue at some point.

One reason may be because the old Server was using Simple File Sharing and shares were set that way and with the new Servers Simple File Sharing should be disabled. When the permissions and Shares were migrated it is possible that the old 'Simple' permissions were applied on top of the recommended (and default) 'Advanced' permissions, which will cause this problem.

If this is indeed the scenario, taking ownership WILL get you through the problem in the short term, but will not resolve the problem as a whole, as you might need to repeat this process on every Share root folder . This happened to me when I built a new Server and set permissions from scratch (due to dirty permissions on the old server). I had asked one of my techs to manually copy all files and folders from the old shares to the new ones (I know, tedious) and he decided to use RoboCopy instead.. RoboCopy, although it is not supposed to do this unless specified, brought over all of the old permissions, which were configured via the 'Simple' method - and caused this issue for me. Once I rebuilt the Share permissions using the 'Advanced' method, these errors went away.

I bet that logging in as the local Admin on that Server will allow you access to the folders without restriction. If the Local Admin succeeds where the Domain Admin login fails, it is probably related to the 'Simple' and 'Advanced' permission types I mentioned above.
0
 
Esteban BlancoPresidentCommented:
This is a new security feature on 2012.  You should be able to add users to that list (or a group I believe).  Also, take ownership of the folders and make the necessary changes.

1. Right-click the file or folder for which you want to set permissions, click Properties, and then click the Security tab.

2. Click Advanced to open the Advanced Security Settings dialog box.

3. Click Owner tab, click Edit. If you are prompted for an administrator password or confirmation, type your password or click Continue.

4. In the new Advanced Security Settings box, in the Change owner to: field, select your User name, and Check the Replace owner on subcontainers and objects. Click OK, repeat for remaining boxes. (If your User name is not listed click the Other users or groups button to add your account).

5. Open the file or folder you wish to access.
0
 
IDMAAuthor Commented:
No luck.  Even after changing the owner, it reverts back to "Unable to Display Current Owner"
0
 
IDMAAuthor Commented:
Machienet,
Yes, I think it is the Commvault restore procedure.  It brings all of the permissions into the new server but it has that glitch.  ANy of our admins will have to click "Continue" and this adds them to the Security ACL.

Logging in as the local admin let me access most of the folders without having to acknowledge the permissions dialog.

If I create a new folder, there's no issue for anybody.

Thank you for the insight.
0
 
Michael MachieFull-time technical multi-taskerCommented:
You are welcome. I am glad it is now identified and resolved so you can focus on more important issues!
0
All Courses

From novice to tech pro — start learning today.