• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1006
  • Last Modified:

Install of both .NET Framework 4.0 Client Profile and .NET Framework 3.5

Today I installed some software that needed .NET Framework 3.5. So before installing .NET Framework 3.5, I uninstalled .NET Framework 4.0 Client Profile, which I probably installed for something I'm no longer using. I thought it might cause problems for me if both were installed.

Well, now I want to install a different program that requires .NET Framework 4.0 Client Profile!

Can both .NET Framework 3.5 and .NET Framework 4.0 Client both be installed and work correctly, ie. will the programs that need one or the other find the correct one and use it?

And by the way, why is the newer version called "Client"? Is it just a name change? It's really just a newer version of the same thing, isn't it?
0
Missus Miss_Sellaneus
Asked:
Missus Miss_Sellaneus
2 Solutions
 
TunerMLSystems EngineerCommented:
I don't see why you should have a problem, I have different software on a XenApp server that requires .Net 2.0 up to 4.0 have them all installed and all is dandy, but this is I.T. so it's probably best to test in non-production evironment first to see if your deployment will be stable.
0
 
Mez4343Commented:
Any version of .NET can run side by side on the same machine without problem. Any .NET version with 'Client' in the name means its a smaller version of .NET containing only the most common functions.

If you install .NET 4.0 Client or the full version .NET 4.0 Framework, you will have support for all programs using .NET 4.0 or below. So I would install 4.0 Client again if that is what you already have downloaded.
0
 
Missus Miss_SellaneusAuthor Commented:
Not a production environment here, my personal system and currently not developing anything, just using other stuff...

Mez, I already had 4.0 Client installed and was unable to install the first application because it told me I didn't have a compatible .NET framework. I checked their website and was told I needed 3.5.  Maybe the full 4.0 would have worked for it, but I'll go ahead and just use both 3.5 full and 4.0 client for now.

Thanks both.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now