Solved

VMserver don't received any IP's

Posted on 2013-06-13
2
144 Views
Last Modified: 2014-01-08
We have 3 VM server (2 nic of 4 ports each) that don't received any IP. Each Port-channel is assign to only Vlan69 who is DHCP. any clue?




Gi7/0/1   R1BESXMED1 NIC3                        connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/2   R1BESXMED1 NIC5                        connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/3   R1BESXMED1 NIC7                        connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/4   R1BESXMED1 NIC9                        connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/5   R1BESXMED1 CONSOLE              connected    69         a-full a-1000 10/100/1000BaseTX
Gi7/0/6   R1BESXMED2 NIC3                        connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/7   R1BESXMED2 NIC5                        connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/8   R1BESXMED2 NIC7                         connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/9   R1BESXMED2 NIC9                         connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/10  R1BESXMED2 CONSOLE             connected    69         a-full a-1000 10/100/1000BaseTX
Gi7/0/11  R1BESXMED3 NIC3                       connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/12  R1BESXMED3 NIC5                       connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/13  R1BESXMED3 NIC7                       connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/14  R1BESXMED3 NIC8                       connected    69         a-full   1000 10/100/1000BaseTX
Gi7/0/15  R1BESXMED3 CONSOLE             connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/1   R1BESXMED1 NIC4                         connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/2   R1BESXMED1 NIC6                        connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/3   R1BESXMED1 NIC8                        connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/4   R1BESXMED1 NIC10                       connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/5   R1BESXMED1 VMKERNE             connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/6   R1BESXMED2 NIC4                        connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/7   R1BESXMED2 NIC6                         connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/8   R1BESXMED2 NIC8                        connected    69         a-full   1000 10/100/1000BaseTX
Gi8/0/9   R1BESXMED2 NIC10                       connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/10  R1BESXMED2 VMKERNE            connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/11  R1BESXMED3 NIC4                       connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/12  R1BESXMED3 NIC6                        connected    69         a-full a-1000 10/100/1000BaseTX
Gi8/0/13  R1BESXMED3 NIC8                       connected    69         a-full   1000 10/100/1000BaseTX
Gi8/0/14  R1BESXMED3 NIC10                    connected    69         a-full   1000 10/100/1000BaseTX
Gi8/0/15  R1BESXMED3 VMKERNE            connected    69         a-full a-1000 10/100/1000BaseTX


each ether-channel is configure like that:

interface Port-channel7
switchport access vlan 69
switchport mode access
spanning-tree portfast



each Interface is configure like that:

interface GigabitEthernet8/0/1
description  NIC4
switchport access vlan 69
switchport mode access
channel-group 7 mode on
spanning-tree portfast
end


ESX3 (PO7 and PO17)

vmnic1  8/0/5     (Console)
vmnic2  7/0/1     (PO7)    
vmnic3  8/0/1     (PO7)
vmnic4  7/0/2     (PO7)
vmnic5  8/0/2     (PO7)
vmnic6  7/0/3     (PO17)
vmnic7  8/0/3     (PO17)
vmnic8  7/0/4     (PO17)
vmnic9  8/0/4     (PO17)


ESX1 (PO8 and PO18)

vmnic1  8/0/10   (Console)
vmnic2  7/0/6     (PO8)
vmnic3  8/0/6     (PO8)
vmnic4  7/0/7     (PO8)
vmnic5  8/0/7     (PO8)
vmnic6  7/0/8     (PO18)
vmnic7  8/0/8     (PO18)
vmnic8  7/0/9     (PO18)
vmnic9  8/0/9     (PO18)


ESX2 (PO9 and PO19)

vmnic1  8/0/15   (Console)
vmnic2  7/0/11   (PO9)
vmnic3  8/0/11   (PO9)
vmnic4  7/0/12   (PO9)
vmnic5  8/0/12   (PO9)
vmnic6  7/0/13   (PO19)
vmnic7  8/0/13   (PO19)
vmnic8  7/0/14   (PO19)
vmnic9  8/0/14   (PO19)
0
Comment
Question by:techbeausejour
2 Comments
 
LVL 20

Expert Comment

by:rauenpc
ID: 39244705
First I would verify that the problem lies within the port channel and not just the connection to the servers.

I would reduce the connections to the servers down to a single connection with no port-channel configuration.
If you cannot get an IP then the port-channel has nothing to do with this. From there I would plug a laptop in to the port to see if you get an address. If you don't get an address start looking further into your network. If you do get an address start looking at the server configuration.
If you do get an IP, then it's time to look further in to your port channel. Commands such as "show logging", "show int port-channel xx", and "show etherchannel summ" can be helpful. Also, you may need to check flow-control settings.
http://communities.vmware.com/people/TimFerguson/blog/2010/07/21/vmware-ip-hash-cisco-6500-etherchannel-just-not-working-perplexed-solution
0
 
LVL 6

Accepted Solution

by:
pgstephan earned 500 total points
ID: 39303459
I don't see a problem with the EtherChannel configuration from the switch side, it alls looks fine.

You probably have a problem with the vswitch configuration in VMware.

YOU SHOULD NOT have any VLAN numbers configured on your vswitch configuration, since all 3 VMs are part of the same VLAN that is going native (untagged) to the switch. So please check that there is no VLAN configured on that trunk as it goes out from the ESX.

Or just post a snapshot of the configuration of your vswitch and we'll tell you.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco Access point 6 55
Forwarding web requests to different web servers 15 75
What are acceptable WiFi signal strengths 6 54
Classlful vs Classless subneting 18 60
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now