Solved

IIS 7 Error

Posted on 2013-06-13
3
348 Views
Last Modified: 2013-06-17
I am trying to open a website on the localhost using IIS7 (Server 2008) and I am getting the message below. I am using .NetFramework v2. Does anyone know what I can do to fix this?
Please let me know if I can provide some more details for you.


Server Error in '/' Application.
--------------------------------------------------------------------------------

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load type 'Simulator._Default'.

Source Error:


Line 1:  <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="Simulator._Default" %>
Line 2:  
Line 3:  <%-- Please do not delete this file. It is used to ensure that ASP.NET MVC is activated by IIS when a user makes a "/" request to the server. --%>
 

Source File: /BuyDesign_Prod/Simulator/default.aspx    Line: 1


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.5466; ASP.NET Version:2.0.50727.5456
0
Comment
Question by:Winsoup
  • 2
3 Comments
 
LVL 29

Expert Comment

by:Randy Downs
ID: 39244921
Maybe something like this?
http://stackoverflow.com/questions/1598829/parser-error-message-could-not-load-type-testmvcapplication-mvcapplication

None of the above answers worked for me. I fixed my error by changing the web project's output path. I had had it set to bin\debug but the web project doesn't work unless the output path is set to simply "bin"
0
 
LVL 3

Author Comment

by:Winsoup
ID: 39245055
I've looked at that. I'm not really sure what it's telling me to do. Is this something I can do in IIS or something I have to manually change a file to do?
0
 
LVL 29

Accepted Solution

by:
Randy Downs earned 500 total points
ID: 39245077
This is something you do in the application. Are you using Visual Studio? If so this might help.

http://msdn.microsoft.com/en-us/library/ms165410(v=vs.80).aspx

Visual C# and Visual J# Projects
To change the build output directory:
On the Project menu, click Properties.
Click the Build tab.
Click the Browse button next to the Output path box and select a new build output directory.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A procedure for exporting installed hotfix details of remote computers using powershell
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question