OWA not working, event id 2307

Hi, new built SBS 2011 Server, owa was working but now receiving the following in the event log when trying to connect :-

Event ID 2307 Source IIS-W3SVC-WP

The worker process for application pool 'MSExchangeOWAAppPool' encountered an error 'Configuration file is not well-formed XML
' trying to read configuration data from file '\\?\C:\inetpub\temp\apppools\MSExchangeOWAAppPool.config', line number '1'.  The data field contains the error code.

This file is 0kb where on other servers it is 153kb, Help !
PeterNairnAsked:
Who is Participating?
 
AmitConnect With a Mentor IT ArchitectCommented:
Rename the file on old server, copy it from another server and check again.
0
 
PeterNairnAuthor Commented:
Hi, done that now receive Event ID 2280

The Module DLL C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll failed to load.  The data is the error.
0
 
PeterNairnAuthor Commented:
Just noticed there isn't a client access directory !
0
 
PeterNairnAuthor Commented:
It's because there is a difference in the directory structure, I copied it off a 2008 server as don't have a 2011 server, shall see if I can get from a 2011 server
0
 
AmitIT ArchitectCommented:
It seems server is not installed properly. You can run the Service pack upgrade and check if that fixes.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.