Solved

QoS over WAN connection for Voice Traffic

Posted on 2013-06-14
3
1,255 Views
Last Modified: 2013-08-27
My Network looks as follows:

ISP------Cisco 2911 Router---------Cisco 3560G Switch-------All IP Phones and workstations.

We signed with a hosted VOIP provider.  I need to configure QoS on the 2911 to guarantee voice traffic over the internet.  I have read a lot of examples online, but am still not quite there.  Can someone send me an example showing/explaining to me how to configure this?  Its a pretty simple network, I just need to get QoS configured so Voice traffic has priority.  Thanks.
0
Comment
Question by:denver218
3 Comments
 
LVL 24

Expert Comment

by:Ken Boone
ID: 39249394
Well you can't!   Once its on the internet there are no guarantees of squat.  The only thing you have the ability to do is configure the router to classify the voice traffic and prioritize it when you send it out on the ISP link.    So you can control how you handle your outbound traffic, putting voice into the priority queue, signaling in a different queue and then the rest of your internet traffic in a default queue.    Unless the ISP is the voice provider as well as ISP, you won't have any guarantees once it leaves your router.  Now some ISP that offer voice service can give some guarantees, but if they are separate no guarantees.  How you do this depends.

If this is an MPLS connection, some ISPs have have a QoS chart specifying the various QoS options they support.  It is usually a service you pay for, and then they tell you in order for them to honor the service you would need to classify the traffic accordingly.  They want high prioirity traffic marked with a specific DSCP value, and when they see that they will put it in the appropriate queues on their network and honor that through their network.  If its not MPLS, then its a matter of just classify and schedule on the router in order to get your voice out first.  

Can you give more specifics to this setup?
0
 
LVL 10

Accepted Solution

by:
mat1458 earned 500 total points
ID: 39250008
You can use the 3560 to mark your traffic and then use the marking to send the traffic to the service provider. Ask the service provider about the DSCP markings he/she expects for voice bearer and voice signaling traffic. I assume DSCP EF for bearer and CS0 for voice signaling, however this might be different in your case (i.e. AF31 for signaling).
Bear in mind that I have done this config out of my old memory, so excuse any syntax mistakes. Also there might be some adjustments that you can to to the queue assignment and the srr-commands. But you might see the principle anyway.

3560:
mls qos map cos-dscp 0 8 16 24 34 46 48 56
mls qos srr-queue input priority-queue 1 bandwidth 10
mls qos
!
class-map match-any CM_Voice
 match access-group name ACLQOS_Voice
class-map match-any CM_Voice_Video_Signaling
 match access-group name ACLQOS_Voice_Video_Signaling
!
policy-map PM_Ingress_Marking
 class CM_Voice
  set dscp ef
 class CM_Voice_Video_Signaling
  set dscp cs3
 class class-default
  set dscp default
  fair-queue
  random-detect
!
ip access-list extended ACLQOS_Voice
 remark VOIP bearer
 permit udp <VOIP-clients-source-ip-mask> any range <voice port range>
ip access-list extended ACLQOS_Voice_Signaling
 remark Signaling Protocols like SIP, H.323, etc.
 permit udp <VOIP-clients-source-ip-mask> any eq 5060
 permit udp <VOIP-clients-source-ip-mask> eq 5060 any
 permit udp <VOIP-clients-source-ip-mask> any eq 1720
 permit udp <VOIP-clients-source-ip-mask> eq 1720 any
!
interface GigabitEthernet0/<to 2911>
 ...
 srr-queue bandwidth share 10 30 30 30
 srr-queue bandwidth shape  10  0  0  0
 mls qos trust dscp
!
interface range GigabitEthernet0/<from VOIP clients> - <to VOIP clients>
 ...
 service-policy input PM_Ingress_Marking
 priority-queue out

2911:
class-map match-any CM_Voice
 match ip dscp ef
class-map match-any CM_Voice_Video_Signaling
 match ip dscp cs3
!
policy-map PM_LLQ
 class CM_Voice
  priority percent 10
 class CM_Voice_Video_Signaling
    bandwidth remaining percent 10
 class class-default
  fair-queue
  random-detect
!
interface g0/<to-LAN>
 service-policy output PM_LLQ
!
interface g0/<to-VOIP-provider>
 service-policy output PM_LLQ
0
 
LVL 4

Author Closing Comment

by:denver218
ID: 39443652
Thanks
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now