Solved

Sbs 2008 backup problem

Posted on 2013-06-14
10
1,354 Views
Last Modified: 2016-06-26
Our Western Digital drives keep failing to run the backup properly.  Having look at the following web page: http://social.technet.microsoft.com/wiki/contents/articles/1780.external-backup-drives-compatibility-list.aspx it states that:

'Note that Microsoft recommend drives are reformatted as NTFS before being used with Windows Server Backup (WSB). Large drives (eg 3TB+) should be reformatted with 512 bytes per cluster as large drives tend to be factory formatted with 4096 bytes per cluster which can cause problems with WSB.'

How on earth do I go about reformatting as 512bytes per cluster? Can't see it specified in the format command, and the Windows formatting tool goes on about an allocation unit size, but nothing about bytes per cluster.
0
Comment
Question by:Techdivision
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
  • 2
  • +1
10 Comments
 
LVL 16

Expert Comment

by:R. Andrew Koffron
ID: 39247908
I'm pretty sure it's got to be done from a elevated command prompt
command would be like {format g: /a:512 }

use fomat /? to get specifics. once in the command prompt.
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39247949
while formatting drive you have change allocation unit size is 512 bytes
0
 

Author Comment

by:Techdivision
ID: 39247990
.I have tried the suggestions above but it presents the message;

The specified cluster size is to small. the minimum value cluster size value for this drive is 4096.
0
 

Author Comment

by:Techdivision
ID: 39248029
Unfortunately, can't do that.  Type the command:

format d: /fs:ntfs /a:512

Get the error:

Formatting 2861408M
The specified cluster size is too small. The minimum valid
cluster size value for this drive is 4096.

Any ideas?
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39248108
okay then try with diskpart

1) format drive from disk management let him take 4096 value
2) Assign drive letter
3) go to command prompt
4) Diskpart
5) type in command list disk
6) select disk which you want to format with 512 bytes
in my case i have used disk 1

select disk 1

7) after that i have selected volume ( in my case its G )

select volume

I have verified allocation unit size

filesysystem  === ( it showed me 4096 )

then i have formated same disk with 512 unit

format fs=ntfs label="data" quick unit=512

again verified file system

this time it showed me 512 allocation unit





7 select volume g
Diskpart.txt
0
 
LVL 11

Expert Comment

by:Pradeep Dubey
ID: 39248119
When you connect the drive, right click on it and select format.

When format window comes up change the allocation unit to 512 see the attached screenshot.
allocation-unit-size.jpg
0
 

Author Comment

by:Techdivision
ID: 39255682
Hi I have tried using diskpart but it is still showing as the cluster size is too small for the drive.
0
 

Author Comment

by:Techdivision
ID: 39277912
Is there any way I can do this using an alternative operating system, such as Linux or Apple? Or Windows NT, perhaps? Or a specialised disk utility? There must be some utility out there that can write out NTFS partitions...
0
 
LVL 11

Accepted Solution

by:
Pradeep Dubey earned 500 total points
ID: 39278299
I found below two link which is saying if you change the sector size to 512, it is not able to use the full capacity of the drive, 3TB due to the limitation of 32 bit. 2 TB is max for 32 bit.

Note:
NTFS is limited to 2^32 clusters, also known as groups of sectors. That means you must format the drive with at least 1024-byte clusters, or you’ll fall prey to the formula I talked about earlier. The default is 4096, which allows up to 16TB;


http://rdwaal.com/2011/11/26/disk-drive-utilities-information/

http://www.pcworld.com/article/235088/everything_you_need_to_know_about_3TB_hard_drives.html
0
 

Author Closing Comment

by:Techdivision
ID: 39335756
Thanks - we solved it in the end by sticking in a 2TB backup drive. According to Microsoft Support Services, SBS 2008 backup can only backup a 2.2TB volume at the most, because you have to have a sector size of 512 for the backup to run.

I've backed up bigger volumes with Windows 7, so I think that's an issue they'd solved by then (Server 2008, which SBS 2008 was based on, is Vista based).
0
Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question