Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 784
  • Last Modified:

wsus not detecting machines

hi i am running a win 2003 domain through gpo on master dc with isa 2006 & file server & wsus domain member server, xp desktop & win 7 laptop for local use

previously i have logged onto each individual machine and connected to windows update site which downloaded and updated on my machines and as a result i have downloaded most of my updates...!! but i wish now for my wsus to take responsibility!!!!!

note: i think my machines have an entry within the registry that needs removing!!

i have now connected a wsus to my network and can see all my machines in there correct gpo on my wsus but not my isa 2006..!!!!!!!

questions 1.  the issue i have is 'not yet reported' ?

reportviewer 2005 installed

wsus server - last status report 15/06/2013 17:07
master dc - not yet reported
file server - not yet reported
xp desktop - not yet reported

isa 2006 not detected via wsus yet..!! ?

note: i can still double click each machine and view via reportviewer!!

followed instructions url but still did not solve problem:

http://technet.microsoft.com/en-us/library/dd939801(WS.10).aspx

1. manipulate registry settings on the wsus client computer
2. to force the wsus client computer to check with the wsus server

note: could not remove below entry as not seen!!!

hkey_local_machine\software\microsoft\windows\currentversion\windowsupdate\auto
update

question 2. why does my win 7 laptop show as:
'windows vista enterprise edn' - ?
0
mikey250
Asked:
mikey250
4 Solutions
 
VirastaRUC Tech Consultant Commented:
Hi,

Step 5: Update and Configure Automatic Updates

Step 5 contains the following procedures:
• Load the WSUS Administrative Template.
• Configure Automatic Updates.
• Point client computers to your WSUS server.
• Manually initiate detection on the client computer

http://technet.microsoft.com/en-us/library/cc720533(v=ws.10).aspx

Hope that helps :)
0
 
Radhakrishnan RSenior Technical LeadCommented:
Hi,

Regarding ISA, the most likely cause for this scenario is that the ISA Server does not have a rule in place granting access to allow the "Local Host" to access the WSUS server.

Open the WSUS port, Sorce-Local Host, Destination-Internal and see whether they are talking each other?
0
 
mikey250Author Commented:
hi virastar,  yes those url instructions have already been carried out at the beginning!!

previously all was ok..!!!!!!!!!!!!!!!!!!!!!!!!!!:)

but due to some (other issue) and my lack of knowledge or stupid mistakes i re-install clean isa and downloaded updates direct from windows update ensuring dns dhcp ok stop start etc (for all below also)

i then removed isa from wsus and isa (will not return) on my wsus...........!

in the end i found myself doing exact same clean install for my file server as isa but (not yet reported).

i then did clean install for master dc but same as all above....!!

i then did same on wsus, but this is ok, but now i have problem:

wsus server - last status report 15/06/2013 17:07
master dc - not yet reported
file server - not yet reported
xp desktop - not yet reported

isa 2006 not detected via wsus yet..!! ?

note: i can still double click each machine and view via reportviewer!!

i believe something is stuck in my gpo's but does not make sense as all machines are new install....!!!!!!!!!!!!but updates all downloaded from windows updates on all physical machines and not wsus.  although all updates detected via wsus (for wsus) successful.

including above is if i remove: nextdetectiontime in registry manually then do:

net stop wuauserv
net start wuauserv

no machine updates time correctly.

note: all machines bios clock and windows clock are correct as checked yesturday

i think i may have to just res-install completely everything from the beginning one by one!!
MACHINE-REGISTRY-SETTINGS.docx
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
VirastaRUC Tech Consultant Commented:
Hi,

Check this out!

WSUS KB2720211 : Common issues encountered and how to fix them
http://blogs.technet.com/b/sus/archive/2012/06/20/wsus-kb272011-common-issues-encountered-and-how-to-fix-them.aspx

Hope that helps :)
0
 
mikey250Author Commented:
hi virastar, i will read that url.

just to let you know, i did not re-install clean my wsus, as all i did was the following:

- removed wsus from domain
- deleted admin profile account
- uninstalled all things in add/remove programs except for sp2
- re-installed over the top of sp2
- then installed wsus 3.0 as normal again

so whether this maybe the issue as all other machines have had clean install im not sure!!
0
 
mikey250Author Commented:
hi virastar, after carrying out the below:

- removing wsus from domain
- deleting admin domain profile
- un-installing all programs from add/remove programs
- not un-installing sp2 but re-installing over the top
- join back domain
- install wsus again

so im thinking re-indexing wsus database is not needed, but thought i would attempt this below, before doing a complete clean install:

qns1.  not sure script location path as run a search on c: & d:\wsus for 'wsusdbmaintenance.sql ' & found nothing ?

so can run the below:

sqlcmd -s np:\\.\pipe\mssql$microsoft##ssee\sql\query -i <scriptlocation>\wsusdbmaintenance.sql

note: most appreciated and will keep this url for future reference!!!!!!!!!!!!
0
 
mikey250Author Commented:
ive just decided to just do a clean wsus install now!!!

much appreciated for help!!:)
0
 
DonNetwork AdministratorCommented:
0
 
mikey250Author Commented:
hi virastar,

master dc/domain member servers:

- re-installed win 2003 clean on all machines with sp2 and after they were all detected via my wsus domain server.

- some updates were also detected/downloaded and installed on each machine

isa 2006:

installed win 2003 clean & sp2
joined isa to domain
installed isa 2006
installed isa 2006 sp1

wsus:

isa 2006 was detected via my wsus showing time/date ie 17/06/2013 14:43 as expected
a small batch of win 2003 updates were also detected on isa 2006 and installed successfully

i then downloaded/installed some isa 2006 updates via wsus successfully

question1.

for some unknown reason my isa has not updated its time as stated above and has not detected anymore updates, although all other machines continue to successfully, so what i have now done is delete from (regedit) windowsupdate & susclientid/susclientidvalidation and rebooted isa..an icon identical to updates ready to download has appeared but when i click it prompts "automatic updates" - in order to select when to install and also my windowsupdate showing gpo entry has not returned so i thought i would leave it for a while and then manually add the windowsupdate back and check later to see if this resolves my issue ...!!  also in the task manager the: wuauclt.exe is showing which did not show before so i assume this means it trying to talk to my wsus server as before the wuauclt.exe only appeared/disappeared for a moment, just like the other machines, but when i run: wuauclt.exe /detectnow or wuauclt.exe /resetauthorization /detectnow..... unless anyone has any advice.. ?
0
 
VirastaRUC Tech Consultant Commented:
Hi mikey250,

Glad that I was able to help!

question1.

Your Question:

for some unknown reason my isa has not updated its time as stated above and has not detected anymore updates, although all other machines continue to successfully, why ?

The Answer is in Your Question itself!

for some unknown reason my isa has not updated its time as stated above and has not detected anymore updates, although all other machines continue to successfully, why ?

Can you relate now?

Server time plays a Important role in WSUS,to understand how read this:

Best Practices with Windows Server Update Services
http://technet.microsoft.com/en-us/library/cc708536(v=ws.10).aspx

Hope that helps :)
0
 
mikey250Author Commented:
morning virastar,

my gpo settings appear ok compared to the( url) you sent, although currently changed win update from 22hr to every 1 hour and once upto date will change back to 22hrs..!

i have attached 3 x screenshots after completing below steps which brings me upto date almost...!!!!!!!

outstanding gpo issue:

just so you know previous to my issue below, for some reason my wsus gpo had (not completed in full) as my internet proxy details had still not appeared, providing no internet access.  i then opened gpmc and selected 'settings' tab that confirms my gpo settings and my proxy settings are configured.  i have run gpupdate /force multiple times on master dc and shutdown at least 10 times over last 2/3 days and on my wsus server showing completed for computer & user, but still same issue...!!

gpupdate /force & shutdown at least 10 times  - completed on all machines, but isa, file & wsus gpo proxy issue still persists!!!!!!!!!!

checks:

rsop.msc - does not show internet proxy details on isa, wsus or file server
rsop.msc - master dc & win 7 laptop - ok

note: isa 2006, file & wsus gpo proxy details only (not taken effect)..!!
note: if gpo proxy details added manually on isa, file & wsus then internet access successful

previously wsus could sync and download updates, so assumed gpo proxy settings would sync over time as normal then later the below all occurred..!!!!!!!!!

due to above gpo proxy issue i did the following:

i have just installed manually on (all machines) gpo policy preference client side extns kb943729 - will shutdown and reboot clean after..!!...and will wait and see if gpo proxy is syn'd later today....!

note:

manually checked all machines 'add/remove programs' but kb943729 not showing although installed successfully....not sure about that unless a hidden attribute..!!

note:

isa in separate gpo container
file & wsus in (same gpo container)
gpo issue only on: isa, file & wsus server

yesturday during day while downloading updates i kept receiving eventviewer intermitant 'file cert verification failed'.... but i ignored then later my wsus was not able to do a manual sync and failed...!!!!!!!!

resolution - i think:

about 2am i then installed kb2722913

i have now checked this morning and my wsus can now sync again successfully

wsus update status now shows:

wsus updates selected: security, critical, updates - only
all updates appear to have downloaded and installed as wsus show download status as: 0

-------------------------------------------------------------------

currently situation:

confirmed that gpo containers for all machines have successful gpo proxy settings set!!
isa, file & wsus - still do not show automatically gpo proxy settings - still
master dc & win 7 laptop - gpo settings all appear ok

- my isa 2006 still not received anymore updates...!! ?
- regedit - windows update manually deleted and system shutdown and rebooted twice
- regedit

note:

xp desktop os installed with no updates or service packs
downloaded xp updates including sp3 and (approved) but still nothing has installed on xp

possible xp desktop resolution:

but not sure if will cause error due to already downloading/approving updates..!

not sure if i can download some specific update to allow wsus to sync with wsus

going to now install sp2
attempted to install manually kb943729 but prompted that need the following:

http://www.microsoft.com/en-us/download/details.aspx?id=18069

the above url for kb914783 appears to be for win 2003 not xp sp2 32bit - so i am not sure

question 1. can anyone assist ?

so far all machines are now showing 99% for:
master dc 2003
wsus server
file server
laptop win 7 (local)


but isa shows 32% which on screenshot attached shows more!! so something is working although time/date still not yet reported..

and xp still not yet reported & 0% installed showing

uuuuuummmm
WSUS-GPO-SCREENSHOT.docx
wsus-file-cert-verification-fail.docx
wsus-most-updated-screen.docx
0
 
mikey250Author Commented:
morning virastar,

i seem to have resolved most problems except for 2 which if you can advise anything maybe!! ?

yesturday the isa 2006 updated itself via my wsus and it also received some downloads which i installed and as a result of that my isa is now showing 98% updated.

it appears that it does not updated and change time/date on wsus as often as the others..!

uuuuuummm - not sure why this is or if there is a way to speed this up.. !?

all other machines are showing so far for the last couple of days now 99% updated and frequently update the time/date via wsus which is good...

as for my last xp desktop although installed basic (os and then installed the sp2) and joined to the domain, it has still not detected via my wsus.  there was an old entry before where it was detected but it never did show a time/date.  as a result i uninstalled and removed all traces everywhere and completed a complete domain clean os install and xp/sp2 and still not detected via wsus at all although im hoping over time this will be detected via wsus just like my isa 2006..1

also ive noticed as my xp has joined the domain, it has not selected the windows update instruction ie to download or notify etc and like it has not picked up my gpo, but i have run rsop.msc and can access the internet..!!!!!!!!!uuummm

ive also accessed windows update site which prompts me to install windows update to presumably view and download whatever updates are available but i did not select this and closed browser.  i did this because im sure i read somewhere that sometime i have to connect to the internet for my wsus to start communicating or something..

questions 1.

any suggestions ?
0
 
mikey250Author Commented:
hi radhakrishnan2007,

after just allowing my wsus to continue downloading and approving updates that i had set for all machines.  my wsus show (reported) for all machines and i am now seeing 100% updated.

i did however carryout the usual troubleshooting methods also, but continuing with installing updates, appears to have obviously resolved some of my issues, which would make sence if a machine is not fully upto date or the wsus is not also updates as they all go both hand in hand.

so all appears ok now

my isa 2006 domain member server is the only machine that has not returned as shown via wsus yet not sure about the below, as isa 2006 in passed was seen via wsus without the below:

regarding isa, the most likely cause for this scenario is that the isa server does not have a rule in place granting access to allow the "local host" to access the wsus server.

open the wsus port, source-local host, destination-Internal and see whether they are talking each other?


appreciated
0
 
mikey250Author Commented:
the below update attempted to be installed manually did not work.

wsus kb2720211 : common issues encountered and how to fix them
http://blogs.technet.com/b/sus/archive/2012/06/20/wsus-kb272011-common-issues-encountered-and-how-to-fix-them.aspx

i continued to download and update my wsus which auto located via updates which also automatically located and installe kb2720211.

so all is ok now!
0
 
mikey250Author Commented:
good advice even though my wsus downloaded auto and installed the kb2720211 anway.

i have allocated points accordingly anyway

im assuming the kb2720211 update may work on win 2008 and may not 2003 but not sure as it did not work on my win 2003 in this case.

so appreciated
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now