Solved

Excel changes dd/mm/yyyy to mm/dd/yyyy

Posted on 2013-06-16
5
299 Views
Last Modified: 2013-06-17
Dear Experts,
One user in our company has strange problem with excel. He send file in excel via email to xyz sender. When XYZ make any changes in the file where dd/mm/yyyy is written, the date format changes to mm/dd/yyyy.For example 31/12/2013 is there in the original file, when xyz insert a character like rh or any other character it becomes mm/dd/yyyy rh. As I have no knowledge in excel, if somebody help me in this regard, I will be so thankful.
Regards.
0
Comment
Question by:ibu1
5 Comments
 
LVL 17

Accepted Solution

by:
Kent Dyer earned 425 total points
ID: 39250994
What are your Regional Settings in Control Panel?

I believe that you can change those there..

Also, see the graphic for this as well from Excel.

Control Panel:
Control Panel settings
Excel:
Excel Regional settings
HTH,

Kent
0
 
LVL 19

Assisted Solution

by:helpfinder
helpfinder earned 75 total points
ID: 39250998
If this is happening to that user "automatically" then seems like pc/user profile related issue. Try to check regional settings (date format) in Control panel for that affected user.
Also user should be able to change date format right clicking on desired cell - format cell and date or custom. But first check that Regional settings.
0
 
LVL 12

Author Comment

by:ibu1
ID: 39251011
In the regional and language setting, the user has kuwait instead of United States. The user is busy right now so cannot log off and log in. Will post a comment soon.
thanks all for your quick reply.
0
 
LVL 14

Expert Comment

by:frankhelk
ID: 39252481
I agree that this seems to be a language setting issue.

When the user opens the spreadheet, he gets the sheet displayed as the last calculation event rendered it - in that case on the sender's PC. When he enters something, Excel recalulates the sheet and - due to different language settings - the format changes. Would be the same effect if the user hits F9 (=Recalc) w/o changing anything.

The most convenient way to revent the format from changing is to use a custom format instead of the built in ... in that way you have any desired control over the format and Excel would give a carp on language settings. Besides of that, it would'nt infer on other spreadsheets of the user.

Try (right click) -> Format cell -> Numer format - Custom Format, enter dd/mm/yyyy into the format field. (Due to my non-english Excel, I have created this as rough guideline - options may be named slightly different and the format string might have error in case of letters ... if it doesn'f work, RTFM)
0
 
LVL 12

Author Closing Comment

by:ibu1
ID: 39253862
Consolation prize for Helpfinder.
Thanks all experts.
0

Featured Post

3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will show you how to use shortcut menus in the Access run-time environment.
Outlook Free & Paid Tools
This Micro Tutorial will demonstrate in Google Sheets how to use the HYPERLINK function to create live links inside your spreadsheet.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question