Solved

VLAN VRF and HSRP configuration: Unable to ping gateway from a laptop

Posted on 2013-06-16
8
2,040 Views
Last Modified: 2013-06-18
Hello, I built a int vlan with a vrf domain and a HSRP with a virtual gateway. The core switch is configured with DHCP server. Once the lap top gets its ip from the  server. I'm unable to ping the HSRP gateway. Can anyone assist with this on.

ex.
ip dhcp-excluded 1.1.1.1 - 1.1.1.2

ip dhcp pool_200
network 1.1.1.0 255.255.255.0
default-gateway 1.1.1.1

int vlan 200
description test1
ip vrf forwarding webaccess
ip address 1.1.1.2 255.255.255.0
 standby 1 ip 1.1.1.1
 standby 1 timers 1 3
 standby 1 priority 110
 standby 1 preempt


Laptop grabs 1.1.1.5, but I'm unable to ping the gateway?
0
Comment
Question by:aldavis26
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 17

Expert Comment

by:pergr
ID: 39252783
According to the RFC for VRRP a router should not respond to ping to the VIP.
Perhaps you have the same here?

Can you ping .2?
0
 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 39253189
try this

ping vrf webaccess 1.1.1.1
0
 
LVL 17

Expert Comment

by:surbabu140977
ID: 39253364
Please paste the full config. What is the use of vrf here? where is the vrf config? What are you trying to achieve by putting vrf in a single switch?
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:aldavis26
ID: 39253684
The use of the VRF on this vlan is to isolate it's traffic. The workstations receives it's ip from the DHCP server from the switch.

Once the workstation receives it's ip. I'm unable to ping vlan(HSRP) gateway from the workstation. I believe the DHCP needs to be in the vrf for me to ping it...Please advise


Here's the initial config.



ex: initial config:

ip dhcp pool_200
network 1.1.1.0 255.255.255.0
default-gateway 1.1.1.1

int vlan 200
description test1
ip vrf forwarding webaccess
ip address 1.1.1.2 255.255.255.0
 standby 1 ip 1.1.1.1
 standby 1 timers 1 3
 standby 1 priority 110
 standby 1 preempt



Workaround config:

ip dhcp use vrf connected

ip dhcp pool_200
vrf  webacces
network 1.1.1.0 255.255.255.0
default-gateway 1.1.1.1

int vlan 200
description test1
ip vrf forwarding webaccess
ip address 1.1.1.2 255.255.255.0
 standby 1 ip 1.1.1.1
 standby 1 timers 1 3
 standby 1 priority 110
 standby 1 preempt
0
 
LVL 17

Expert Comment

by:surbabu140977
ID: 39254269
ip vrf webaccess

interface FastEthernet0
ip vrf forwarding webaccess
ip address 1.1.1.2 255.255.255.0

no ip dhcp use vrf connected

ip dhcp excluded-address 1.1.1.1 - 1.1.1.2


ip dhcp pool pool_200
   network 1.1.1.0 255.255.255.0

   default-router 1.1.1.2
##############################
The above one works. However it's not what you are looking for with respect to dhcp. I will try use the vlan and hsrp shortly.

Best,
0
 
LVL 17

Accepted Solution

by:
surbabu140977 earned 500 total points
ID: 39254455
Ok, I did not have any switch in my possession. So here is what I did trying to replicate the closest possible scenario. I took a router-->configured it as dhcp server/VRF/HSRP. Took another router as a DHCP client(instead of laptop) and was pinging the HSRP IP of 1.1.1.100 in the dhcp server. Attaching the 2 configuration files.
Client router (consider laptop) can successfully ping the HSRP IP.
Hopefully the author can replicate the solution now.
server.txt
client.txt
0
 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 39255154
aldavis26

did u see my comment
0
 
LVL 17

Expert Comment

by:surbabu140977
ID: 39255240
just curious,  how ping vrf <vrfname> <ip> is possible from laptop or pc?
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Public IP Address - Subnet 4 57
snmp v2 configuration on a switch 3 63
SBS2011 VPN users no longer connecting 4 80
DHCP for a new, 2nd subnet 12 66
Managing 24/7 IT Operations is a hands-on job and indeed a difficult one. Over the years I have found some simple tips and techniques to increase the efficiency of the overall operations. The core concept has always been on continuous improvement; a…
AWS has developed and created its highly available global infrastructure allowing users to deploy and manage their estates all across the world through the use of the following geographical components   RegionsAvailability ZonesEdge Locations  Wh…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question