Exchange 2010 Change Public Folder Type From IPM.POST to IPM.NOTE

Hi all,

I have a new deployment of public folders within an existing Exchange 2010 environment. I've created the first folder, mail enabled it and set an inbound mail address. Now, when I email that address, it appears in that public folder but as a post. I've tried to change the type from post to message, but it will not let me (errors as unable to set content to that type for that folder). I understand that a post and a message are to all practical senses the same, but I would like to know how to modify it to be a IPM.NOTE for normal emails. I think it may be caused by having started with a 2003 server and then migrating to the new 2010 box, but there must be a way of changing it over.

Thanks

Bob
LVL 2
Bob SampsonHead Of ITAsked:
Who is Participating?
 
SreRajConnect With a Mentor Commented:
Hi,

It is not possible to change the content type of a public folder. It is set when it's created. Did you create the public folder from Outlook? If you create it from Exchange Management Console or Shell and then mail enable it, it should be able to host all type of contents.
0
 
Simon Butler (Sembee)ConsultantCommented:
Do you still have the Exchange 2003 server? On Exchange 2010 it should be IPM.NOTE by default.

Simon.
0
 
Bob SampsonHead Of ITAuthor Commented:
No, the old servers have all gone. I had a 2003 briefly whilst the 2010 was in place, both in the domain, then I migrated the mailboxes from 2003 to 2010 and decommissioned the 2003 box. The 2003 box is long gone.

Do you think it is some hangover from then?

Is there still a way to change it?

Bob
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Bob SampsonHead Of ITAuthor Commented:
I've it both from within the Public Folder Management Console and within Outlook. Within the Management Console, it does not give the option that I can see for what type of information is going in there. It creates it as a default as IPM.POST as far as I can see.

When I create it within Outlook, it asks what will go in there, and the option is 'Mail and Post Items', but when I select it, it creates it as IPM.POST again, and if I go into the properties of the folder, I can see it set as that, yet if I hit the drop down and go to forms, then select 'Message' (with a message class of IPM.NOTE), it errors and tells me I can't create an item of this type in this folder.

So I can create folders to my hearts contents, but they all end up as IPM.POST and never as IPM.NOTE.

Surely there must be a reg edit that will change the type of folder that I can do before I post any information to it??? Otherwise I can't see how to get around this issue.

Bob
0
 
Simon Butler (Sembee)ConsultantCommented:
This is a strange one because it shouldn't be set like that.

"Exchange Server 2007
On a server that is running Microsoft Exchange Server 2007, e-mail messages from the Internet to a public folder come in as IPM.Note. This behavior occurs even when you do not use the "Incoming defaults to IPM.Note" registry value.

This behavior is expected in Exchange 2007. When a message passes through transport, Exchange 2007 assigns a message class of IPM.Note if a message class is not already present. Therefore, when the message reaches the store, it already has a message class. The store's default message class is not used.

Note You cannot require the IPM.Post message class instead of the IPM.Note message class in Exchange Server 2007."

http://support.microsoft.com/kb/817809

That would tend to suggest something is wrong with transport.
Is the server fully up to date? Anything third party touching the transport stream?

Simon.
0
 
Bob SampsonHead Of ITAuthor Commented:
No third party apps at all and the server is fully patched. I agree it seems odd, but it's a near vanilla build, very simple deployment. I'm stumped!
0
 
SreRajCommented:
Could you please enable public folder diagnostic logging and see for any errors logged in Application Log in Event Viewer?
0
 
SreRajCommented:
Also, could you please try creating the following registry key mentioned in the article suggested by Simon and set its value to 1.


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\<ServerName>\Public-<GUID>
 Value name: Incoming defaults to IPM.Note
Value type: DWORD
Value data: 0 or 1 0 (zero) is default (0=false).

The default behavior without the registry key is that incoming messages appear as IPM.Post. If you set the registry key to have a value of 0 (zero), the result behavior is the same as the default behavior, and incoming messages appear as IPM.Post. If you set the registry key to have a value of 1 (one), the behavior changes, and new SMTP mail messages from a non-MAPI source appear as IPM.Note.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.