Solved

SBS 2008 Exchange wont save the password for Smarthos

Posted on 2013-06-17
16
232 Views
Last Modified: 2013-10-17
I have a very annoying problem on a customers SBS2008 box. For some reason last week exchnage "forgot" the password for the smarthost (its blank when you open it) If I re-enter it then close and open it it never saves it, the box is empty. Outgoing mail wont go because authentication fails evertime obviously. I can send it via DNS but its not as reliable as the smarthost.

Can anyone help?
0
Comment
Question by:plug1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
16 Comments
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39252681
0
 
LVL 14

Author Comment

by:plug1
ID: 39252758
I dont see that update listed in the programs and updates no..
0
 
LVL 9

Expert Comment

by:VirastaR
ID: 39252822
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 14

Author Comment

by:plug1
ID: 39252889
Sorry but the problem is exactly as I said, it wont save the smarthost details and this fails the mail flow. If it would save it then all would be well.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39252986
Delete the connector, then run the wizard in the SBS management console which will recreate the connector. You don't have to keep that connector.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39253010
Hi sembee, I've deleted it and recreated it several times but it just won't keep a password in the basic authentication settings.. It's doing my head in now!
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39253026
How did you recreate the connector? Manually or using the wizard?

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39253054
Ive done it manually and then had to rename it correctly later to run the smarthost configure wizard. Ive just deleted it and tried to run the fix my network and connect to the internet wizard both error out.. bugger
0
 
LVL 14

Author Comment

by:plug1
ID: 39253074
Do you know the command to set the password via the shell.. Ive not managed to get it right.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39253679
Fix My Network doesn't recreate the connector.
You need to run the smart host wizard to recreate it.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39253733
In that case yes I've ran it and it is still the same
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39256095
The wizard recreated the connector correctly? When you ran the wizard did you enter the password there?

This isn't a problem I have seen before so I am wondering if it is outside of Exchange, possibly a credential manager corruption issue.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39256105
Yes the Wizard cretaes it and accepts the password ect, 2 green ticks at the end and then you open it in exchange manager and the password section is blank!

Never ever seen anything like it myself, hence Im on here hoping someone like you had :)
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39259220
This isn't something I have seen.
The only other suggestion is to remove the connector, restart the transport service, then recreate it. That should force a refresh of the settings.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39580957
Never ever got it working but resolved it via external DNS SPF and reverse dns to avoid having to use the smarthost.. Sembee can have the points for being a god
0
 
LVL 14

Author Closing Comment

by:plug1
ID: 39580960
The problem is still there but I worked around it instead. Cheers anyway Sembee
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question