Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

SBS 2008 Exchange wont save the password for Smarthos

Posted on 2013-06-17
16
226 Views
Last Modified: 2013-10-17
I have a very annoying problem on a customers SBS2008 box. For some reason last week exchnage "forgot" the password for the smarthost (its blank when you open it) If I re-enter it then close and open it it never saves it, the box is empty. Outgoing mail wont go because authentication fails evertime obviously. I can send it via DNS but its not as reliable as the smarthost.

Can anyone help?
0
Comment
Question by:plug1
16 Comments
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39252681
0
 
LVL 14

Author Comment

by:plug1
ID: 39252758
I dont see that update listed in the programs and updates no..
0
 
LVL 9

Expert Comment

by:VirastaR
ID: 39252822
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 14

Author Comment

by:plug1
ID: 39252889
Sorry but the problem is exactly as I said, it wont save the smarthost details and this fails the mail flow. If it would save it then all would be well.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39252986
Delete the connector, then run the wizard in the SBS management console which will recreate the connector. You don't have to keep that connector.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39253010
Hi sembee, I've deleted it and recreated it several times but it just won't keep a password in the basic authentication settings.. It's doing my head in now!
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39253026
How did you recreate the connector? Manually or using the wizard?

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39253054
Ive done it manually and then had to rename it correctly later to run the smarthost configure wizard. Ive just deleted it and tried to run the fix my network and connect to the internet wizard both error out.. bugger
0
 
LVL 14

Author Comment

by:plug1
ID: 39253074
Do you know the command to set the password via the shell.. Ive not managed to get it right.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39253679
Fix My Network doesn't recreate the connector.
You need to run the smart host wizard to recreate it.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39253733
In that case yes I've ran it and it is still the same
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 39256095
The wizard recreated the connector correctly? When you ran the wizard did you enter the password there?

This isn't a problem I have seen before so I am wondering if it is outside of Exchange, possibly a credential manager corruption issue.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39256105
Yes the Wizard cretaes it and accepts the password ect, 2 green ticks at the end and then you open it in exchange manager and the password section is blank!

Never ever seen anything like it myself, hence Im on here hoping someone like you had :)
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 39259220
This isn't something I have seen.
The only other suggestion is to remove the connector, restart the transport service, then recreate it. That should force a refresh of the settings.

Simon.
0
 
LVL 14

Author Comment

by:plug1
ID: 39580957
Never ever got it working but resolved it via external DNS SPF and reverse dns to avoid having to use the smarthost.. Sembee can have the points for being a god
0
 
LVL 14

Author Closing Comment

by:plug1
ID: 39580960
The problem is still there but I worked around it instead. Cheers anyway Sembee
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question