• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

SBS 2008 Exchange wont save the password for Smarthos

I have a very annoying problem on a customers SBS2008 box. For some reason last week exchnage "forgot" the password for the smarthost (its blank when you open it) If I re-enter it then close and open it it never saves it, the box is empty. Outgoing mail wont go because authentication fails evertime obviously. I can send it via DNS but its not as reliable as the smarthost.

Can anyone help?
0
plug1
Asked:
plug1
1 Solution
 
Haresh NikumbhSr. Tech leadCommented:
0
 
plug1Author Commented:
I dont see that update listed in the programs and updates no..
0
 
VirastaRUC Tech Consultant Commented:
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
plug1Author Commented:
Sorry but the problem is exactly as I said, it wont save the smarthost details and this fails the mail flow. If it would save it then all would be well.
0
 
Simon Butler (Sembee)ConsultantCommented:
Delete the connector, then run the wizard in the SBS management console which will recreate the connector. You don't have to keep that connector.

Simon.
0
 
plug1Author Commented:
Hi sembee, I've deleted it and recreated it several times but it just won't keep a password in the basic authentication settings.. It's doing my head in now!
0
 
Simon Butler (Sembee)ConsultantCommented:
How did you recreate the connector? Manually or using the wizard?

Simon.
0
 
plug1Author Commented:
Ive done it manually and then had to rename it correctly later to run the smarthost configure wizard. Ive just deleted it and tried to run the fix my network and connect to the internet wizard both error out.. bugger
0
 
plug1Author Commented:
Do you know the command to set the password via the shell.. Ive not managed to get it right.
0
 
Simon Butler (Sembee)ConsultantCommented:
Fix My Network doesn't recreate the connector.
You need to run the smart host wizard to recreate it.

Simon.
0
 
plug1Author Commented:
In that case yes I've ran it and it is still the same
0
 
Simon Butler (Sembee)ConsultantCommented:
The wizard recreated the connector correctly? When you ran the wizard did you enter the password there?

This isn't a problem I have seen before so I am wondering if it is outside of Exchange, possibly a credential manager corruption issue.

Simon.
0
 
plug1Author Commented:
Yes the Wizard cretaes it and accepts the password ect, 2 green ticks at the end and then you open it in exchange manager and the password section is blank!

Never ever seen anything like it myself, hence Im on here hoping someone like you had :)
0
 
Simon Butler (Sembee)ConsultantCommented:
This isn't something I have seen.
The only other suggestion is to remove the connector, restart the transport service, then recreate it. That should force a refresh of the settings.

Simon.
0
 
plug1Author Commented:
Never ever got it working but resolved it via external DNS SPF and reverse dns to avoid having to use the smarthost.. Sembee can have the points for being a god
0
 
plug1Author Commented:
The problem is still there but I worked around it instead. Cheers anyway Sembee
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now