TCP Settings on Windows 2008 Server

For some reason, after configuring a static IP on Windows 2008 server, the address is showing as 0.0.0.0 and 0.0.0.0 subnet. Ipconfig, however, shows the correct address as "
Preferred". Moreover, the advanced property of IP shows both 0.0.0.0 and the actual address at the bottom.

Any idea?
exhuserAsked:
Who is Participating?
 
exhuserAuthor Commented:
Updated the driver, removed the NICs from device manager and restarted. That fixed it.
0
 
Randy DownsOWNERCommented:
Try this

http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/cafe29bb-d5f2-449c-9bd2-18014d278b3d/

How many NICs do you install in Windows server 2008 R2?

Did you install 3rd-party tool in Windows server 2008 R2? If so, please uninstall them and try again.

Windows 7 use 0.0.0.0 as the default gateway problem.
http://msmvps.com/blogs/richardwu/archive/2009/12/18/windows-7-use-0-0-0-0-as-the-default-gateway-problem.aspx

The Default Gateway may have been set to 0.0.0.0 on a Windows Vista-based or later OS running Apple’s Bonjour service
http://support.microsoft.com/kb/970313

If the issue persists, please try to reset TCP/IP or recreate a new NIC for WIndows server 2008R2.

How to reset Internet Protocol (TCP/IP)
http://support.microsoft.com/kb/299357
0
 
exhuserAuthor Commented:
This is different:

Looks like it adds another address 0.0.0.0 and subnet 0.0.0.0 However, the correct static address is listed at the bottom (in advanced settings) and is showing in ipconfig.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Randy DownsOWNERCommented:
Do you have a Health policy Server restricting this server? Maybe it doesn't meet requirements like virus signature.
0
 
Randy DownsOWNERCommented:
Something like this?
http://www.trainsignal.com/blog/nap-network-access-control-server-2008

Dynamic Host Configuration Protocol (DHCP) is one of the easiest NAP enforcements to deploy because all DHCP client computers must lease an IP address. Therefore if the client computer does not meet the health policy requirements the DHCP server will either assign an invalid IP address, such as 0.0.0.0., to the client or route the client to the remediation server for updates. This way the client can only access the IP address of the network if all health requirements are met.
0
 
exhuserAuthor Commented:
I don't think ther is a helth policy restricting this. After all DHCP works -- it is just the static IP settings
0
 
Randy DownsOWNERCommented:
Have you tried rebooting?

I would say release/renew ip but it should be a static ip. I would issue the command just to see what it tells you.

Only 1 NIC involved?

ipconfig /release
ipconfig /renew
0
 
exhuserAuthor Commented:
Yes only one NIC
0
 
Randy DownsOWNERCommented:
Is this a physical machine or a virtual?
0
 
Randy DownsOWNERCommented:
This might help. You can run it manually with netsh or use their Fix it link. Either way you need a reboot which might fix the problem all by itself.

How to reset Internet Protocol (TCP/IP)
http://support.microsoft.com/kb/299357
0
 
exhuserAuthor Commented:
Physical machine, 2 adaptors, one disabled.
0
 
exhuserAuthor Commented:
Looks like it has something to do with IP v 6: when I try to ping the localhost, IP v 6 responds...
0
 
Randy DownsOWNERCommented:
Maybe something here but most require a reboot. Again it refers to DHCP which you are not using but it seems like your machine is in limbo between DHCP and static ip.

http://support.microsoft.com/kb/822123

Method 1: Turn Off Firewalls

Method 2: Verify That Your Network Card Is Installed Correctly

Method 3: Verify That the Dynamic Host Configuration Protocol (DHCP) Client Service Is Started

Method 4: Modify the Registry
0
 
exhuserAuthor Commented:
My Iconfig reports the correct address, it is when I go to TCP/IP settings I see 0.0.0.0 as the first address.
0
 
Randy DownsOWNERCommented:
Try disabling IPv6
0
 
exhuserAuthor Commented:
Disabling IPv6 did not help...
0
 
Randy DownsOWNERCommented:
OK so it's not an IPv6 problem. It's just that IPv4 is not working so IPv6 responds. Can you reboot?
0
 
Randy DownsOWNERCommented:
Glad you got it. It was a very strange symptom
0
 
exhuserAuthor Commented:
Found solution by re-installing the driver
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.