Solved

Can't get MS SQL 2005 to connect to my local server

Posted on 2013-06-17
7
323 Views
Last Modified: 2013-06-18
My hard drive died, so I had it replaced.  The tech company reinstalled Windows 7 Professional, and I installed SQL 2005, 64 bit.  It connects to other servers, but it won't connect to my local server.  The typical, non-descript error: 18456.  I searched forums for answers.  I made sure IIS was started, I added port 1433.  I even uninstalled and reinstalled it to make sure I set it up to just use Windows Authentication.  Nothing changed.  

Various instructions talk about SQL Server Express, but I'm using Microsoft SQL Server Management Studio, so I don't know if that's a different program or what.  

There are many links to Microsoft or other forums...some times I don't understand what they're saying, other times, I can't figure out how to get to what they recommend.

Can anyone help?
0
Comment
Question by:StellaBob
  • 4
  • 3
7 Comments
 

Author Comment

by:StellaBob
ID: 39254758
One other thing...I'm not sure if I need other service packs or hot fixes.  I tried downloading one hotfix I found on another post, but it wouldn't install...talked about SQL Server Express Studio again and bombed out.
0
 
LVL 16

Expert Comment

by:Surendra Nath
ID: 39254783
I suggest you follow the below steps

1) Check if the instance of the SQL Server is the default instance or named instance.
      How to check SQL Server you installed is default instance or named instance
          Open Services by running the command Services.msc in the run window, Locate for SQL Server Service and see if it has (MSSQLSERVER) in parenthesis or something else... if it just has MSSQLSERVER then it is local instance or else it is named instance.

2) Now if you have local instance and if you are unable to login into the sql server... Then the problem might be with the windows authentication, ensure that you are using the same windows login that you are using when you are installing the sql server
      One point here, I even suggest you create mixed mode authentication, in the authentication tab, and add a SQL Server user while installing and ensure that this SQL Server user is added SQLADMIN role.

3) if the instance is a named instance, then most probably you might be giving the wrong server name, you have to give .\<instanceName>

Hope this helps
0
 

Author Comment

by:StellaBob
ID: 39254828
I just looked at the Services and it does read: SQL Server (MSSQLSERVER).  As for #2, when I installed, I didn't use any kind of login...I just selected Windows Authentication, so I'm not sure how to change that.

One thing to note...I was going through some other instructions I found.  it had me go back to the SQL Servicer Configuration Manager to make sure the built-in account of the local system is being used, but when I opened the Configuration Mgr, two items in the list read 32 bit.  SQL Server 2004 Network Configuration and SQL Native Client Configuration.  I believe I first installed the 32 bit version, then as I went through the disks, realized there was one for 64 bit and Itanium.  So I uninstalled it and reinstalled the 64 bit version.  Could this be the problem?
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 16

Accepted Solution

by:
Surendra Nath earned 500 total points
ID: 39254868
it could be.
did the re-installing resolve the issue...
0
 
LVL 16

Assisted Solution

by:Surendra Nath
Surendra Nath earned 500 total points
ID: 39254875
if you are ok to re-install again then I suggest you to follow the below instructions in the website and re-install it again... he has given on how to set up the mixed mode authentication for sql server...

http://www.sqlserverclub.com/essentialguides/how-to-install-sql-server-quick-guide.aspx
0
 

Author Comment

by:StellaBob
ID: 39254991
Thanks...I'll try this and let you know.
0
 

Author Closing Comment

by:StellaBob
ID: 39257491
YOU'RE AWESOME!!!  The instructions were very helpful as I had just checked Windows Authentication versus the Mixed Mode.  Thank you, thank you, thank you!!!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

INTRODUCTION: While tying your database objects into builds and your enterprise source control system takes a third-party product (like Visual Studio Database Edition or Red-Gate's SQL Source Control), you can achieve some protection using a sing…
In this article I will describe the Copy Database Wizard method as one possible migration process and I will add the extra tasks needed for an upgrade when and where is applied so it will cover all.
The purpose of this video is to demonstrate how to set up the WordPress backend so that each page automatically generates a Mailchimp signup form in the sidebar. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question