• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 822
  • Last Modified:

Batch file on logon script in windows 8 nto working

Hello guys,

I'm on a windows server 2003 dc and have user connecting to this dc (win xp, win7, win 8).

I have created a batch file on my server and have put it using group policy under Logon script (user configuration, windows settings, logon etc etc).

All my win xp and win7 client received their map drive but my win 8 client doesn't...

Can you please help?
Thanks
0
techlabtest
Asked:
techlabtest
  • 6
  • 3
  • 3
  • +3
1 Solution
 
xeroxzeroxCommented:
Disable securtity signature

Open shell with elevated privileges and type in:

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

and try again....
0
 
techlabtestAuthor Commented:
on my dc?
0
 
xeroxzeroxCommented:
right
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
techlabtestAuthor Commented:
i need to install .netframework and restart the dc and install power shell..can i use it through regedit?
0
 
xeroxzeroxCommented:
yes it works on power shell and you should make entry in login scripts....
0
 
Steve KnightIT ConsultancyCommented:
I think what they are saying is that from a Windows 8 client to a Windows 2003 server there can be problems mapping drives etc. due to this secure signing requirement for SMB3.  There is an MS knowledgebase on that I'll see if I can find in a mo.

No need to put powershell or anything else on your server.

You can use that powershell script, manually make the same change using regedit against the Window 8 machine or I presume there should be a policy in group policy for it which you could push down to the machines if needed.

Not looked yet as no-one wants to use Windows 8 machines in corporates I deal with, Windows 7 is a bit new fangled, and for the smaller companies XP is still new for some of them, moved one business from one 18 year old DOS machine to Windows 7 and internet the other day!

Had a quick search and this is MS document on the subject: http://support.microsoft.com/kb/2686098 and some more info:  http://www.adamfowlerit.com/2013/05/26/unable-to-map-drives-from-windows-8/
0
 
techlabtestAuthor Commented:
HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" RequireSecureNegotiate -Value 0 -Force

i cant see: RequireSecureNegotiate !!!

Thanks
0
 
rhinocerosCommented:
To change the default behavior, you need to define the registry key. If not present, its default value is “Required” in Windows 8 clients.

If not, add the registry key...
HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\RequireSecureNegotiate = 0


More info:
http://www.symantec.com/connect/forums/cant-map-network-storage-after-booting-ssr2013-recovery-disk
http://blogs.msdn.com/b/openspecification/archive/2012/06/28/smb3-secure-dialect-negotiation.aspx
0
 
SandeshdubeySenior Server EngineerCommented:
Have a look at below hotfix too.

Windows 8 and Windows Server 2012 update rollup: February 2013
http://support.microsoft.com/kb/2795944
0
 
McKnifeCommented:
Quote the part of the batch file that does the mapping, please.  I never had to adjust anything on several win8 workstations in order to get "net use x: ..." running in a logon script.
Simply let the script echo to a file and quote the contents... or should we go on guessing?

Also read http://technet.microsoft.com/en-us/library/ee844140(v=ws.10).aspx if your test user is local admin.
Quote: When network shares are mapped, they are linked to the current logon session for the current process access token. This means that if a user uses the command prompt (cmd.exe) together with the filtered access token to map a network share, the network share is not mapped for processes that run with the full administrator access token.
0
 
techlabtestAuthor Commented:
thanks for your comments...

i have added the registry key and still not working...

Any idea...i got a lot users on windows 8..

Thanks
0
 
McKnifeCommented:
You set the registry key... which one? Many suggestions contained one, which did you set? And if applicable, did you restart afterwards?
Then: I asked you to quote the part of the batch file that does the mapping, please - can you do it? And finally, you did not bother to follow my suggestion to have the script log to a file, did you? That way we could see what is going on. Like this for example:
net use x: \\server\share >\\logserver\share\%computername%.log
0
 
techlabtestAuthor Commented:
Sorry Mcknife...i was in a hurry yesterday and had not seen your comment....thanks for responding...

HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\RequireSecureNegotiate = 0  (hav create RequireSecureNegociate and set the key to zero)

Batch file:
@echo off
net use x: \\serverone\FinanceDept /persistent:yes

Please eleborate for the example you gave..

Thanks
0
 
McKnifeCommented:
Set the regkey I linked and restart.
The example: Add >\\logserver\share\%computername%.log to that line of yours. It will log the result of your command to the textfile \\logserver\share\%computername%.log
Of course, you will have to supply a writable share \\logserver\share\, first.
0
 
techlabtestAuthor Commented:
Thanks it works now...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 6
  • 3
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now