Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 316
  • Last Modified:

Having to manually specify DNS server on each PC - WinSvr 2008 domain

In our LAN, unless I manually specify the following settings on each workstation, users cannot login/access share drives.

Primary DNS: 192.168.0.49 (W2K8 Domain Controller)
Alternative DNS: 8.8.8.8

If I only specify the primary DNS to point to 192.168.0.49, then share drives are accessible however no internet access is available. So I point the alternative to Google's DNS.

Of-course the above practice is not recommended and causes issues with users taking their laptops home.

Why does this happen? Why cant the workstations talk to the DNS server on the W2K8 DC?

Please help
0
cgruber
Asked:
cgruber
  • 3
  • 3
  • 2
  • +2
1 Solution
 
Mike RoeCommented:
setup dhcp and add dns as the 2008 server

Or push them out with group policy
Computer Configuration | Administrative Templates | Network | DNS Client

Setup a forwarder to point to the 8.8.8.8 in the server dns
0
 
cgruberAuthor Commented:
DHCP and DNS are setup in 2008 server already.

but not all client computers are joined to the domain. some are visitors who come in with laptops, connect to the office wi-fi and then try to browse the internet/access specific files on a share folder.

i believe gpo will not work unless the pc is joined to the domain.
0
 
Mike RoeCommented:
add dhcp to the wireless and add the dns there
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
MisterTwelveCommented:
-Setup your Scope in DHCP to provide internal DNS server in Scope Options. (Option 006)
-In your DNS Server select proprieties, then in forwarders, point to external dns.
-restart DNS Server Service on dns service
-restart Workstations to update new Scope options or IPconfig /Release and ipconfig /renew
0
 
cgruberAuthor Commented:
006 DNS Servers points to 127.0.0.1
0
 
MisterTwelveCommented:
this is your problem
006 dns server need to be 192.168.0.49
and your dns server forwarder to external dns
0
 
cgruberAuthor Commented:
done and done

will test in the morning and advise.

thanks
0
 
MisterTwelveCommented:
I think is solve
right now with 006 option pointing to 127.0.0.1, you have all workstations query themselves for all DNS Request.
Regards
0
 
Michael MachieFull-time technical multi-taskerCommented:
Nevermind this post, I got distracted and did not finish my post before others added their comments and I have no immediate delete option.
0
 
vivigattCommented:
You need to:
- Enable DNS forwarders in your local DNS
http://technet.microsoft.com/en-us/library/cc754941.aspx
- Specify the DNS list to use in DHCP configuration (DHCP option 6 "DNS servers", not DHCP option 5 "name servers")
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now