Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2086
  • Last Modified:

Hyper-V Mager

Having a problem with my Hyper-V Manager and Server Manager on Server 2012 Datacenter Edition.  When opening my Hyper-V Manager I'm getting the message:

 "Connection to Virtual Machine Management service..."

but it seems to just hang.  I've tried restarting the process but no luck.  My VM are currently running and I can access them via my Failover Cluster Manager but I can't create new VM or import any.  Also which makes me believe it's just not my Hyper-V manager, when I open the server manager and I try to add a role I get the message:

"Server Manager is collecting inventory data.  The wizard will be available after data collection finishes"

And it doesn't show any Roles or Features installed.  Any suggestions are appreciated.

Ronnie
0
nbccit
Asked:
nbccit
  • 3
1 Solution
 
Rob StoneCommented:
If you look at PowerShell can you see the Roles & Services installed?
get-windowsfeature

For me, I would look to schedule a reboot first as it could be something as simple as that to clear the issue.

Can you access VM Manager/Server Manager on this server remotely (i.e, from another server or client pc)?
0
 
nbccitAuthor Commented:
Yes the features are showing installed through powershell, no I get the same response from both the console and RDP session.  I haven't tried restarting the server yet as I have productions VMs running on them.  I was planning on doing a live migration to my failover host which is experiencing the same issues then restarting each server after the migrations as a last resort.
0
 
AbhishekJhaCommented:
Install Hyper-v manager on other machine & try connecting the hyper-v server from there & see whether you are facing same issue or not.

For server manager Try connecting the server manager from another server

refer below link for the same

http://technet.microsoft.com/en-us/library/dd759202.aspx
0
 
nbccitAuthor Commented:
All set did a live migration of my VM's to my failover host restarted the server and everything is back to normal.
0
 
nbccitAuthor Commented:
I solved the problem on my own.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now