Solved

RDP to Windows 7 Ultimate machine

Posted on 2013-06-18
5
426 Views
Last Modified: 2013-06-18
I have a Windows 7 Ultimate client machine that I have assigned a static IP address to.  

I have also changed the listening port in regedit on the machine from default 3389 to 3392.

I have also configured in the firewall a port forward TCP 3392 routed to the static IP address assigned to the machine.

I have turned on to allow remote connections to this computer in Computer Properties.

All of the above, and I still get "Can't connect to the remote computer for one of these reasons..."  when attempting to RDP to <public IP>:3392.  Yes, the computer is confirmed on.

Am I missing something here?
0
Comment
Question by:David Roberts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 4

Accepted Solution

by:
MrC63 earned 450 total points
ID: 39256870
Since you've changed the port number, you're going to have to add an exception in the Windows firewall for this port.  Windows will create this exception automatically if you're using the standard port number, however if you're using a custom port, you have to create this exception yourself.

The quick and easy way to test this is to stop the firewall service momentarily, then try to RDP into the system.  If it works, then you can re-start the service and add the exception to the Windows firewall.

MrC
0
 
LVL 70

Expert Comment

by:Qlemo
ID: 39256899
Do NOT switch off the Windows Firewall service, this can have strange effects on Vista and above. Instead, switch the firewall off in your network profile for testing.
Else the above said is correct - any custom port needs to be set up in Windows Firewall manually.
0
 
LVL 12

Expert Comment

by:Imtiaz Hasham
ID: 39256921
Although you've run this correctly, check the AV / Third-party FW software.

Also, on your router, you could say:

ANY WAN External Port 3392 -> Internal Port 3389 <IP Address of the Win7 Ultimate PC>
0
 

Author Closing Comment

by:David Roberts
ID: 39256952
Turned off Windows firewall as a test and was able to access RDP to IP:3392 from the outside.  Turned Windows firewall back on and added exception rule for TCP 3392 and able to access from the outside.  Thanks for your help!
0
 
LVL 4

Expert Comment

by:MrC63
ID: 39257652
My pleasure.  Like you, we also typically change RDP to a non-standard port, so I've been down this road a few times.  Glad I was able to get you pointed in the right direction.

MrC
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

So many times I have seen the words written in a question "if only I could show you" or " I know how hard it is for you since you can't see it" in any zone. That has inspired me to write about this tool in windows 7 called "Problem Steps Recorder…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.

631 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question