Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Crystal Reports reading field with multiple values separated with |

Posted on 2013-06-18
3
Medium Priority
?
409 Views
Last Modified: 2013-06-19
I have a Crystal Report that is reading a field with multiple data values separated by | and Crystal Reports is returning only one value of the multiple values in the field.  For example, the values are 90001|90006|90008|90119.  Crystal Reports is returning only 90119.  Is there a formula or a method to return all four values?
0
Comment
Question by:garyjgs
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 39257535
SO you have a field with data like A | B |C |D

Crystal won't select data like that from a field.  There must be something else going on.

DO you have the field set to GROW on the report?

mlmcc
0
 
LVL 35

Accepted Solution

by:
James0628 earned 2000 total points
ID: 39258878
To add a little to what mlmcc said, if you have a field that contains a string like "90001|90006|90008|90119", that's what you'll see in CR.  It doesn't know that that's supposed to be a list of values.  It's just a single string to CR.

 If you're not seeing the entire value that's in the field, it's probably just being cut off on the report (eg. too narrow).

 If you're trying to use the individual values in the string, what are you trying to do with them?

 If the field is supposed to contain a string like "90001|90006|90008|90119", but, no matter how wide you make the field, all that you see is "90119", then the problem is that your data is not what you think, and the field only contains "90119", not "90001|90006|90008|90119".  Or you're simply looking at the wrong field.

 James
0
 

Author Closing Comment

by:garyjgs
ID: 39260181
The writer of the report was trying to group on the values and it was returning the last value in the field.  When reviewing the detail line (unsupressed), the values were displayed correctly.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question