Solved

Change ulimit to allow file transfer

Posted on 2013-06-18
16
2,143 Views
Last Modified: 2013-06-19
Hello,

I'm trying to transfer a 23GB file back to my AIX box.  AIX Version 5.3.  I receive an error message which terminates the transfer.  "A file cannot be larger than the value set by ulimit".
I am logged in as root.  Can I change the value to allow the transfer?

Thank you.
0
Comment
Question by:cbones
  • 8
  • 7
16 Comments
 
LVL 23

Expert Comment

by:nemws1
Comment Utility
What are your current limits?  Run as root:

ulimit -a

Open in new window

0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
Hi,

first, run

lssec -f /etc/security/limits -s root -a fsize_hard

If you see "root fsize_hard=-1" then you can set your file size limit to "unlimited" by just issuing

ulimit -f unlimited

If the above "lssec" command returns no value or a value other than -1 issue

chsec -f /etc/security/limits -s root -a fsize_hard=-1

then use "ulimit -f unlimited" to set the limit to "unlimited".

Please be aware that if the target filesystem is "jfs" (as opposed to "jfs2") it must be enabled for large files, otherwise there is a hard 2 GB limit.

Check with

lsfs -q /mount/point

if "VFS" is "jfs" then "bf: true" must be displayed.

Please note that "bf" is a creation time option which cannot be set afterwards.
0
 

Author Comment

by:cbones
Comment Utility
# ulimit -a
time(seconds)        unlimited
file(blocks)         unlimited
data(kbytes)         131072
stack(kbytes)        32768
memory(kbytes)       unlimited
coredump(blocks)     2097151
nofiles(descriptors) 2000
#

file errors out around 1GB with the error.

What can I check?

Thank you.
0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
Did you check the jfs type and "bf" (see my comment)?

What do you see with

quota

?
0
 

Author Comment

by:cbones
Comment Utility
VFS          Size               Options
  jfs2         348127232    rw


 (lv size: 348127232, fs size: 348127232, block size: 4096, sparse files: yes, inline log: no, inli
ne log size: 0, EAformat: v1, Quota: no, DMAPI: no, VIX: no)
#
0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
Are you sure that it's "root" who performs the transfer?

Which transfer tool are you using? Which is the exact command?
0
 

Author Comment

by:cbones
Comment Utility
I am using ftp to do the transfer.  

When I type whoami it returns root.
0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
So you're doing this on AIX as root:

cd target_dir
ftp sourcehost
cd source_dir
get filename

right? If so, and if ulimit -f returns "unlimited" as you wrote, I can only assume a filesystem issue (corruption?), because everything should work just fine.

Is there something suspicious in

errpt | more

?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:cbones
Comment Utility
I am trying to ftp a file to the server.  I am doing an ftp to the aix box.  Changing to the directory I want to place the file.  Then doing a put to transfer the file to the box.

Nothing in the errpt that's  unusual.
0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
So you're doing this on the source machine

cd source_dir
ftp aix_server
(log in as root) <-- This is important!
cd target_dir
put filename

Right?
0
 

Author Comment

by:cbones
Comment Utility
That's correct.
0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
Please make sure that the ulimit on AIX is indeed permanently set to unlimited by issuing

lssec -f /etc/security/limits -s root -a fsize

right after login and before issuing any ulimit command.

If it's still "-1" I must admit that I'm out of ideas.
0
 

Author Comment

by:cbones
Comment Utility
Here is the output

# lssec -f /etc/security/limits -s root -a fsize
root fsize=
#
0
 
LVL 68

Expert Comment

by:woolmilkporc
Comment Utility
Then:

lssec -f /etc/security/limits -s default -a fsize

If this gives an empty (or low) value too  - are you setting root's fsize limit in the .profile?

Please remember that profiles are not executed under FTP!
0
 

Author Comment

by:cbones
Comment Utility
It did return an empty value.   I am setting this from the command line.  What do you mean in the profile?

# lssec -f /etc/security/limits -s default -a fsize
default fsize=
#
0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 500 total points
Comment Utility
Changing ulimit from the command line doesn't make the setting permanent - it will last just for your current shell session.
So if you were trying to get the file from the source sever this would be alright, but since you're tring to put it won't work.

Make the setting permanent:

chsec -f /etc/security/limits -s root -a fsize=-1

Now you can retry putting the file.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now