Solved

Exchange 2013 forwarding to external smtp address not working

Posted on 2013-06-18
4
3,868 Views
Last Modified: 2013-06-27
Hi all,

Firstly - grrrr at MS for making this so difficult!!

I am trying to forward email from a user to her external email address. I have used the following cmd

Set-Mailbox -Identity "FirstName Surname" -DeliverToMailboxAndForward $true -ForwardingSMTPAddress name@hotmail.com

I do not receive any erros but for it just is not working.

I have tried forwarding to an email address of mine also but this does not work.

1. is there a cmd to see if the forwarding has been set?
2. may I be missing something totally obvious which is causing it not to work?

Thanks
gareth
0
Comment
Question by:gareth629
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 

Author Comment

by:gareth629
ID: 39257977
Furhter info

I have tested through the GUI to forward to mailbox, this worked.

I then rerun the cmd and received the following error

Warning: Before your forwarding settings can take effect, yu need to contct your helpdesk and ask them to turn off the forwarding your administrator previoulsy set.

I then ran it again, I received the same error plus being told that the command ran successfully but no changes were made.

ty
g
0
 
LVL 23

Accepted Solution

by:
Stelian Stan earned 500 total points
ID: 39258128
Try this steps: http://www.techieshelp.com/exchange-2013-forward-email-to-external-contact/#
Also the steps are:
- Create a contact in the Exchange 2013 "Admin Center".
- Then if you want keep a copy of that email, then run:
Set-Mailbox -Identity "User1" -DeliverToMailboxandforward $True -ForwardingSMTPAddress "user@externaldomain.com" -ForwardingAddress "user@externaldomain.com"

Open in new window

- If you don't want to keep a copy of forwarded email then:
Set-Mailbox -Identity "User1" -DeliverToMailboxandforward $False -ForwardingSMTPAddress "user@externaldomain.com" -ForwardingAddress "user@externaldomain.com"

Open in new window

0
 

Author Comment

by:gareth629
ID: 39260010
thanks Clonyxlro.

out of curiosity, why is it required to tell the system the external address twice??

thanks
g
0
 

Expert Comment

by:dtisoft
ID: 39283459
The "accepted solution" is wrong and the referred web page is seriously incomplete.

Both parameters (ForwardingAddress and ForwardingSmtpAddress), should NOT be used in the same command;

- The use of the parameter ForwardingSmtpAddress is used along with Remote Domain Configuration settings.  In fact, it will only work if AutoForwardEnabled is true in the Remote Domain Configuration settings. (see "Set-Remotedomain -AutoForwardEnabled")

- The use of the parameter ForwardingAddress needs to be used along with a Contact to send to an external address.  (usual MS-Exchange method of creating a contact with an external SMTP address, and forwarding to that contact) --  Please note that since only Mailboxes (no Contacts) are visible in the Mailbox/Delivery Options in the EAC, the use of the Powershell becomes mandatory.


As an example, with the following commands, ForwardingSmtpAddress will work:
set-remotedomain Default -AutoForwardEnabled $true
set-mailbox {targetmailbox} -delivertomailboxandforward $false -ForwardingSmtpAddress {destination@externaldomain.com}

Open in new window


PS: The following link is particularly interesting:  http://hasslauer.com/blog/?p=156

__

Best regards,

M.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video discusses moving either the default database or any database to a new volume.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question