Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

The name of the site is not http://localhost

Posted on 2013-06-18
18
Medium Priority
?
504 Views
Last Modified: 2013-06-19
Hello:

I created a web site in SharePoint Foundation 2010 and gave it a name for the URL.

But, the site only comes up on the IIS box successfully if I type the URL showing either (a) the name of the IIS box or (b) localhost.  For example, if I type http://localhost, the site appears.  I want it to appear with my site name that I gave it.

Not only that, even when I get the web site up, if I go to "Site Actions...Site Settings", I get a SharePoint error page.

I don't get it.  I gave my site a specific name.  That's what I want to use.  

How do I change that?  And, if I change it, can I get rid of the Site Actions...Site Settings" error that appears?

Thanks!  Much appreciated!

TBSupport
0
Comment
Question by:TBSupport
  • 9
  • 8
18 Comments
 
LVL 29

Expert Comment

by:QPR
ID: 39258321
You need to setup alternate access mapping to give your SP a friendly name (alias)
http://technet.microsoft.com/en-us/video/dn153778
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39258367
Along with your AAM, you should ensure that your DNS entry is pointing at your external IP, and that you have proper routing to your SharePoint WFE.
To update your AAM, you need to goto the Central Administration link, goto the Application Management section, and then you will see Alternate Access Mappings.  From the upper right corner of the AA Mappings screen, select the web application that your site resides, and add the public facing URL.
Typically I recommend extending your web application to a new zone and customizing the authentication provider for said zone.  It is also important to ensure the proper ports are forwarded externally, and finally, there is additionally licensing considerations if you wish to serve SharePoint to the internet
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39259132
Thanks, for the good and quick responses.  I'm afraid that I got neither to work.

I want to use 80.  But, it's not letting me because it says that it's in use.

Also, the video did not seem to "land" on which specific method I should use.

Any other ideas or alternatives or what am I doing wrong?

I pointed it to port 82, though I want to use 80.  But, the "new" site for which I extended did not come up.

Can I reverse what I did and start again with exact step by step instructions on how to fix this?

TBSupport
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 9

Expert Comment

by:vaderj
ID: 39259578
Can you and a screen shot of your iis manager sites?
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39259618
Actually, I went ahead and deleted the web application.  I'm going to start over.  I don't what stepped, originally, from the instructions.  But, obviously, I missed something.

Although I'd like to use the Default Web Site port 80, evidently there is something wrong with it.  So, I have two options:  (a) Delete and recreate the default web site and still use Port 80 or (b) use another port when I use SharePoint Foundation to create a new web app and therefore a new web site.

Can I do (a) or would it be better to do (b)?

Also, when creating a web site, do I have to use the machine name?  SharePoint seemed bent on using the machine name.  Why can I not give it any name on this planet that I want?

TBSupport
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39259630
The default web site is just a blank container - SharePoint creates its own website when you create new web application. Easiest thing to do would be to right click on the default web site, and then, I believe under actions, select Stop. This will free up port 80
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39259636
If you want to be able to access your site from the server it resides on, you will probably need to disable the loopback check by following this: http://support.microsoft.com/kb/896861
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39259726
Hello:

The default web site was already stopped.  How can I tell if port 80 is free for use?  And, again, do I have to use the machine name for the URL?

TBSupport
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39259791
You can give your site whatever URL you like, so long as the machine that you access that site from has the ability to resolve that name into an IP - this can be via DNS or via the hosts file if its just an individual computer.
From your first post it appears that the website is living on p80, you just need to ensure that both your alternate access mappings are setup correctly and that your DNS / Hosts file entry is setup.  Is your server a part of an Active Directory domain?
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39259879
Hello:

Well, I'm just about ready to give up.  I created a new site called "bizsalus" on port 83.  I did nothing wrong.

But, when I type in that address in Internet Explorer, it tells me that it cannot connect to the page.

I have followed manuals and instructions to the letter.  Attached is the IIS server, as a screenshot.  It still really seems bent on not liking any URL unless that URL has the machine name on it.

Please help!

TBSupport
Capture.PNG
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39260035
So you are saying that when you type in
http://bizsalus:83
into internet explorer, it tells you it cannot find the page?
When you ping "bizsalus", do you get a responce, and is that responce the same IP as the IP of your SharePoint server?
Is your SharePoint server a member of an Active Directory domain?
Is your Windows Firewall running?
Did you implelment the DisableLoopbackCheck I had linked to earlier?

Unfortunatly, SharePoint is not a simple website application like Drupal or Wordpress, it is kind of a big complex monster and can be quite challenging at times
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39260061
I agree.  Let me write down my responses to your questions, below:

So you are saying that when you type in
http://bizsalus:83
into internet explorer, it tells you it cannot find the page?  Yes.
When you ping "bizsalus", do you get a responce, and is that responce the same IP as the IP of your SharePoint server?  No response is given.
Is your SharePoint server a member of an Active Directory domain?  Yes
Is your Windows Firewall running?  No
Did you implelment the DisableLoopbackCheck I had linked to earlier?  I don't know how to do that and, in all of the years that I have been installing Dynamics GP Business Portal in SharePoint, I have never had to do that.
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39260082
ok - on your DC it sounds like you need to enter in a DNS record for your SharePoint server that has Bizsalus pointing to your SharePoint servers' IP.
the DisableLoopbackCheck is only neccesary if you are trying to access your server from itself.
Once you  have the DNS record and you can successfully ping bizsalus, you should then be able to access http://bizsalus:83
Also, from  your prior screen shot, it does not appear that your Default website is stopped...
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39260161
No, my friend, the default web site is stopped.  What are the next steps?  Understand that I'm a newbie.  Any steps would be appreciated.

TBSupport
0
 
LVL 9

Expert Comment

by:vaderj
ID: 39260177
well you need to be able to convert bizsalus into an ip address.  You can do this via the DNS screen on your domain controller, until you do that, nobody on your network knows who 'bizsalus' is.

Please see the following two articles (second one builds on the first)
http://technet.microsoft.com/en-us/library/cc759550(v=ws.10).aspx
http://technet.microsoft.com/en-us/library/bb727018.aspx
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39260184
I didn't have  to do any of this the last time I did this.  You see, this was all the result of an uninstall and reinstall of the web app.

This hasn't been a good case, just to be honest.  In fact, I just took a look and now we're back to where it's only pulling up the site if localhost is used.

This is impossible.
0
 
LVL 9

Accepted Solution

by:
vaderj earned 2000 total points
ID: 39260214
Oh this is far from impossible, its done every single day.  Please create a DNS entry on your domain controller pointing to your SharePoint server - once you have this you should then be able to access your server via the URL you have specified.
0
 
LVL 1

Author Comment

by:TBSupport
ID: 39260240
I don't know how to do that.  So, I have turned this project over to someone else at my firm with more SharePoint experience.

Thanks, for your help.

TBSupport
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft SharePoint Foundation 2010 and Microsoft SharePoint Server 2010 do not offer the option to configure the location of the SharePoint diagnostic trace log files during installation.  This can, however, be configured through Central Administr…
A recent project that involved parsing Tableau Desktop and Server log files to extract reusable user queries for use in other systems. I chose to use PowerShell to gather the data, and SharePoint to present it...
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …

782 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question