Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

rdweb/terminalserver use only port 443

Posted on 2013-06-19
8
Medium Priority
?
1,426 Views
Last Modified: 2013-06-25
Hi, how could i set rdweb (Terminalserver in 2008R2) to only use port 443 / SSL ? If i have a firewall with port 443 open thru to the rdweb everything works ok, but if i in the same firewall open port 3389 to another internal server things stops working. It looks like the rdweb first try port 3389 and then 443, if 3389 answer then that is used and things stops working, but how could i make the rdweb to only use port 443 from outside clients?
0
Comment
Question by:per-w
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39259070
0
 

Author Comment

by:per-w
ID: 39261623
Thanx for the link, but i didnt find anything that help me. I need to know how to disable rd gateway to use port 3389, i have tried to set rdgateway to use only port 443 but it still try to use 3389 first, strange.
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39261806
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39261810
0
 

Author Comment

by:per-w
ID: 39261834
TS gateway/RD Gateway is working. Everything works ok from lan, wan etc. I connect to it with https://rdweb.domainname.no/rdweb and starting programs from the website is ok and working 100%. If I only have port 443 open in my router/firewall and everyting is working ok.
My problem is that if i open port 3389 in my router/firewall and forward that to a another server then things stops working. When i then starts the programs that i have published on the rdweb website it cant connect and tells me that the SSL sertificate on the other server that 3389 points to isnt correct, that is correct since that server dont have any SSL sertificate but that server dont have anything with the rdweb/terminalserver to do. I want to stop the programs to try to use 3389 and only use 443. There must be some place to tell that use only 443 and dont try to use 3389 at all ?? Its strange.
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39261844
0
 

Accepted Solution

by:
per-w earned 0 total points
ID: 39265121
I got this solutions from someone at technet.
I had to uncheck bypass rd gateway local adresses. It works :-) I dont know why it works since its not local adresses, but it works.
0
 

Author Closing Comment

by:per-w
ID: 39274221
it works
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question