Mstsc not connecting using IP, but works fine when using the name of the server

Ok, I have 6 servers for a customer platform. When I use the IP to connect using mstsc (microsoft terminal server client), it asks me user and password and after that says that credentials are not valid.

Attemping the connection using servername.domain, works fine. The nslookup translation works fine and the IP is correct. I'm not using IPv6. I experience the problem using the mstsc even between the servers.

Using windows xp attemping the connection using the IP works, but with w2008 server r2 or windows 7, it doesn't.

The problem is that the DNS is private and for the servers only. For external users the access is restricted using a dedicated IP for the client to connect.

Any ideas?
Vitaliano GiannangeliCEOAsked:
Who is Participating?
 
Vitaliano GiannangeliConnect With a Mentor CEOAuthor Commented:
I just made a new test. Downloaded the 2x client and configured a session using an ip and other with the name. First result: The same.

Then I checked the advanced options in the 2x connection manager and disabled the Network Level Autentication and it worked.

Two questions here,

How Network Level Authentication can be disabled:
* Server Side
* Client Side

I checked in the 2008 R2 mstsc, and didn't find anything. Also my server is configured to allow connections from computers running any version of Remote Desktop.
0
 
cpadmCommented:
On the first RDP connection to a Windows 2008 server, it usually prompts for the following format:

UN: <MyDomain\MyUsername>
PW: ******

If you don't place the domain before the username, it will attempt to use the domain prefix of the machine that you are currently logged on with. if you want to log in using a local user account use UN: <Servername\MyUsername>


To make sure that there aren't issues with DNS records, always try the following troubleshooting steps:

Ping <servername>
Ping <Server IP>
nslookup <servername>
nbtstat -a <Server IP>
0
 
Pradeep DubeyConsultantCommented:
use this command to find out who have this IP nbtstat -a 192.168.19.101 change IP as per server IP.

also
open MSTSC and click on option save the user name and password then connect.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Manjunath SulladTechnical ConsultantCommented:
Hi,

Try adding host entries  on client side.

Go to --> C:\Windows\System32\drivers\etc\ Open Hosts file with notepad.

Add IP address against hostname.

# For example:

102.54.94.97     rhino.acme.com    
38.25.63.10     x.acme.com
0
 
Vitaliano GiannangeliCEOAuthor Commented:
Tryed all of that, with the exception of the nbtstat -a, that of course checked after reading, and the names and ips match correctly.

I use DOMAIN\USERNAME ... ,

Well, I'll keep trying. Thanks
0
 
Vitaliano GiannangeliCEOAuthor Commented:
I reached an alternate solution to my problem. It is not the final answer. The community told me to try everything I tried and when asked for any other options, SILENCE.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.