Solved

Linux losing DNS with SBS 2008

Posted on 2013-06-19
6
471 Views
Last Modified: 2013-10-25
Probably a badly worded title, but here's what's happening ... I have 2 linux hosts in my SBS 2008 domain. The SBS 2008 host is the domain server, Exchange Server, Actrive Directory server, DNS server and DHCP server for the domain. The linux host are not part of the domain in the 'Active Directory' sense, but they do use the SBS 2008 host as the DNS server and linux host2 uses the SBS server for DHCP.

Here's the problem: linux host2 get's a DHCP address from the SBS server. On the SBS Server > Start > Administrative Tools > DNS >  {hostname} > Forward Lookup Zones > hprs.local, linux host2 is listed with its assigned IP address. Linux host1 can reference host2 by hostname and find it. It uses that lookup by hostname to NFS mount drives from host2. All is well.

After some period of time, typically a few days, linux host1 can no longer find host2 by name. Pinging by name, etc. returns host not found. When I look at the same DNS listing as above on the SBS server the linux host2 is no longer listed. Linux host2 *is* still listed under Start > Administrative Tools > DHCP > mail.hprs.local > IPv4 > Scope > Address Leases.

All Windows workstations can still map drives on linux host2

Existing NFS connections from linux host1 to host2 are not lost (the connection stays), but no new connections can be done by name. I can do new connections by IP.

I believe the problem is that the SBS 2008 DNS server is losing the DNS entry for linux host2 after some period of time. If I do /etc/rc.d/rc.inet1 eth0_restart on linux host2 to re-request DHCP, the IP does show up again in the SBS server DNS list (but doesn't stay).

Is this just a bug in SBS 2008 DNS or is there some setting I need to make on the SBS server to retain the IP in the DNS list, or some setting I need to make on linux host2 to re-request the lease every so often?

This is a big issue since linux host1 wants to connect to linux host2 daily for backup purposes. My only other safe alterntive is to give linux host2 a static IP and configure that explicitly in SBS server DNS, which I'd rather not do to keep the setup simpler.
0
Comment
Question by:jmarkfoley
  • 4
  • 2
6 Comments
 
LVL 38

Expert Comment

by:Philip Elder
ID: 39260658
Does an NSLookup on either Linux host show SBS as the source DNS when the problem is happening?

Create a manual DNS A record in domain.local with the name pointing to the IP of the Linux box.

Use DHCP reservation to "static" Linux2 to the IP assigned in DNS above.

Make sure DHCP under the Advanced Tab has Admin Credentials set.
Make sure DHCP under DNS tab has all check marks to allow DNS to be updated with IPs assigned.

Philip
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 39260925
Philip:  >Does an NSLookup on either Linux host show SBS as the source DNS when the problem is happening?

Yes:

$ nslookup yahoo.com
Server:         192.168.0.2
Address:        192.168.0.2#53

Non-authoritative answer:
Name:   yahoo.com
Address: 98.139.183.24
Name:   yahoo.com
Address: 206.190.36.45
Name:   yahoo.com
Address: 98.138.253.109

The Server: 192.168.0.2 is the IP of the SBS 2008 server. Same nslookup results on both Linux hosts.

> Create a manual DNS A record in domain.local with the name pointing to the IP of the Linux box.

Well, that extra bit is what I was trying to avoid. I'd like it to work like any 'ole dynamic IP without caring about whether it is static or not. I don't have any of the Windows workstations in the domain set as static (DHCP reserved).

> Make sure DHCP under DNS tab has all check marks to allow DNS to be updated with IPs assigned.

I believe I do have this set correctly. See image below. I have a feeling that the last setting on that form is not working correctly: "Dynamically update DNS A PTR recrods for DHCP clients that do not request update". Possibly, linux host2 is not requesting updates, so its DNS A PTR record eventually goes away. Just a guess, I'm no expert on either DNS or DHCP.

Any ideas on what I could do to fix this short of creating a DHCP reservation for this host? Do any Linux folks know of something I can do on the host2 side to "refresh"  or otherwise cause the DNS entry to be updated on the SBS Server?

DNS update for DHCP
0
 
LVL 38

Accepted Solution

by:
Philip Elder earned 500 total points
ID: 39261397
On Windows there is a setting on the NIC "Register this connection in DNS". Is there an equivalent in the OS NIC properties for the Linux box?

Short of that, there is nothing wrong with dropping a static DNS A record and DHCP Reservation for the problematic machine. We did this quite a bit with early Linux based NAS boxes that refused to do the same as you are experiencing.

Philip
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 1

Author Comment

by:jmarkfoley
ID: 39262332
Philip: Thanks I'll do the static thing if needed. Meanwhile, are there any Linux gurus out there that can answer Philip's (and my) question?

> On Windows there is a setting on the NIC "Register this connection in DNS". Is there an equivalent in the OS NIC properties for the Linux box?
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 39263571
More information ...

I think this is a Linux problem. I have a newly configured Linux router (completely different location than the SBS 2008 issue) that gets a dynamic IP address from the ISP cable modem. The linux system was rebooted at about 11:00PM yesterday and sometime around 1:00PM today I lost connection to the Internet. The cable modem seemed to be fine, but no Internet connection. When I restarted eth0 it re-acquired the lease and connection resumed.

I don't know if this connection loss is due to a DHCP lease issue or inactivity. I don't think it is inactivity because the Internet connection stayed up overnight with no activity. This is the first time this has happened with the Linux-router and I do not have a lot of time using Linux as a router. Maybe it's an anomaly.

I think there must be something in the linux DHCP client setup to tell the DHCP server to stay connected.

Need help
0
 
LVL 1

Author Comment

by:jmarkfoley
ID: 39601148
Here's the fix: I added an A record for webserver.ohprs.org = 192.168.0.3 to the SBS Domain server. Then I added the following to webserver:/etc/mail/access.dbL

ohprsstorage.hprs.local RELAY
ohprsstorage RELAY

And, added the following line to /etc/mail/mailertable:

ohprsstorage.hprs.local         smtp:ohprsstorage.hprs.local

That seems to have done the trick!
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now