Solved

How to see .php in browser?

Posted on 2013-06-20
15
488 Views
Last Modified: 2013-06-20
Hello all.

Once i could right click and run in chrome with all my .php files. That was how i tested my website.

Now i cant :S I just cant anymore. It only shows me text.


What should i do? I just wanna see my .php file being executed as a webpage and not text.
0
Comment
Question by:Mike Kristensen
15 Comments
 
LVL 108

Expert Comment

by:Ray Paseur
ID: 39262368
Please post a link to the URL that illustrates the problem, thanks.
0
 
LVL 58

Assisted Solution

by:Gary
Gary earned 355 total points
ID: 39262371
PHP has to be parsed through a server, you cannot just load it directly in a browser. So maybe you had some plugin installed that loaded it through localhost instead of directly.
0
 

Author Comment

by:Mike Kristensen
ID: 39262380
Plugin? Where should that plugin be?

So how to parsed it through a server? Do i have to install anything?
0
 

Author Comment

by:Mike Kristensen
ID: 39262395
I used to just write all my code in notepad++ and then upload it. Its hard to understand that i suddenly have to install something, when this simple solution have served me for 8 years or 3 homepages.
0
 
LVL 58

Assisted Solution

by:Gary
Gary earned 355 total points
ID: 39262397
I don't know - I've never come across anything like that.
You need either IIS (Windows) with the php extension or something like XAMPP (Apache)
Then you can execute php through http://localhost/page.php

HTML can be displayed directly in a browser because it has no server side scripting.
You're changing the question now, you said you loaded the file directly in a browser, now you are talking about uploading the file somewhere...?
0
 
LVL 22

Assisted Solution

by:plusone3055
plusone3055 earned 60 total points
ID: 39262427
0
 

Author Comment

by:Mike Kristensen
ID: 39262442
I loaded file into browser, in test's... After that i uploaded my website.


I installed XAMPP, and trying to launch Apache now. But it is shutting down, telling me some port is blocked.. SIGH.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 58

Accepted Solution

by:
Gary earned 355 total points
ID: 39262449
Are you sure you don't already have IIS installed? If you are using Skype that will also take over port 80 - which you have to change.
0
 

Author Comment

by:Mike Kristensen
ID: 39262476
I dont know. IIS? Can IIS execute .php correctly?

How to change port 80 in skype?
0
 
LVL 15

Assisted Solution

by:Jagadishwor Dulal
Jagadishwor Dulal earned 85 total points
ID: 39262485
There is xampp-portcheck.exe you can see which servic is using the port 80 or you can configure port in php.ini file.
0
 
LVL 58

Assisted Solution

by:Gary
Gary earned 355 total points
ID: 39262500
0
 

Author Comment

by:Mike Kristensen
ID: 39262505
"Advanced in skype" uncheck "use port 80" close skype.

Start Apache and now it works. Skype aswell using some port 40427.



Thx you all, you made my day, very fast....
I will help all i know, with this problem....


For you to know, my project right now is to make my website into a theme in wordpress. :)
0
 

Author Comment

by:Mike Kristensen
ID: 39262612
I've requested that this question be closed as follows:

Accepted answer: 50 points for GaryC123's comment #a39262449
Assisted answer: 80 points for Ray_Paseur's comment #a39262368
Assisted answer: 90 points for GaryC123's comment #a39262371
Assisted answer: 0 points for Mikethk's comment #a39262380
Assisted answer: 80 points for GaryC123's comment #a39262397
Assisted answer: 50 points for plusone3055's comment #a39262427
Assisted answer: 70 points for jagadishdulal's comment #a39262485
Assisted answer: 80 points for GaryC123's comment #a39262500

for the following reason:

HTML files can be executed directly with a browser, but .php cant.

You have to install XAMPP and run Apache which would work as some local host for the .php files.
If Apache wont start, its prop... due to port 80 being used by Skype. You can change that port in skype.

All .php files needs to be stored in the htdocs folder, inside of the XAMPP folder, prop... found on main HDD.

You can now launch the .php files by simple telling it to run in a specific browser or by entering http://localhost/index.php (index.php being your .php file), in the URL bar.
0
 
LVL 58

Expert Comment

by:Gary
ID: 39262613
You don't accept your own answer when someone else gave you the answer, just accept the correct answer, being about Skype taking over port 80
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Popularity Can Be Measured Sometimes we deal with questions of popularity, and we need a way to collect opinions from our clients.  This article shows a simple teaching example of how we might elect a favorite color by letting our clients vote for …
Author Note: Since this E-E article was originally written, years ago, formal testing has come into common use in the world of PHP.  PHPUnit (http://en.wikipedia.org/wiki/PHPUnit) and similar technologies have enjoyed wide adoption, making it possib…
The viewer will learn how to count occurrences of each item in an array.
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now