• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 347
  • Last Modified:

Windows 2008 r2 scheduled jobs not running

Hello all -

I have a scheduled job that runs when I'm logged onto the machine, doesn't run when I'm not.  

I exported the job so you can see it below.  Any ideas?

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Date>2013-05-13T14:55:26.0712243</Date>
    <Author>SBB14\njama</Author>
  </RegistrationInfo>
  <Triggers>
    <CalendarTrigger>
      <StartBoundary>2013-05-13T05:00:00</StartBoundary>
      <Enabled>true</Enabled>
      <ScheduleByDay>
        <DaysInterval>1</DaysInterval>
      </ScheduleByDay>
    </CalendarTrigger>
  </Triggers>
  <Principals>
    <Principal id="Author">
      <UserId>SBB14\larry</UserId>
      <LogonType>Password</LogonType>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>false</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <WakeToRun>true</WakeToRun>
    <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
    <Priority>7</Priority>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>D:\Prod\LogAnalysis\cmd\AnalyzeLogs.cmd</Command>
      <WorkingDirectory>D:\Prod\LogAnalysis\cmd\</WorkingDirectory>
    </Exec>
  </Actions>
</Task>
0
enjama
Asked:
enjama
  • 4
  • 2
1 Solution
 
Haresh NikumbhCommented:
check on synchronize across time zones task scheduler
tasks
0
 
SidFishesCommented:
I had this problem recently with server 2003 and I expect the answer may the same

run as admin >secpol.msc
Security Settings > Local Policies > user Rights assignment > Log on as a batch Job
 and then make sure the user the task runs under is added

(or maybe not)
0
 
enjamaAuthor Commented:
@SIDFISHES - I have the user as "SYSTEM".  Isn't system an admin?  That would take care of the batch job issue??

@takecoffe - Why?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
SidFishesCommented:
I would think so however I'm no guru on this stuff.  

On my server 08 r2 instance, there is no entry in log on as batch for system - you need to add it....

Probably worth a try
0
 
enjamaAuthor Commented:
Added - waiting till 5am tomorrow.
0
 
enjamaAuthor Commented:
Worked Thank you!  I added system to run as batch job.
0
 
enjamaAuthor Commented:
I still can't find any documentation about this.  Any one know?
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now