Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Restore user permissions

Posted on 2013-06-20
9
Medium Priority
?
304 Views
Last Modified: 2013-06-20
I accidentally deleted all users/permissions from Volume M:  through the Properties\Sharing tab.  Now, all access is denied.  I tried to restore them with icacls, but it fails, even from safe mode.  Is there a way to restore access to the volume?  Thanks.
0
Comment
Question by:sjw601
  • 4
  • 3
  • 2
9 Comments
 
LVL 24

Expert Comment

by:aadih
ID: 39263074
Try a system restore if you have a restore point for the volume.
0
 
LVL 22

Accepted Solution

by:
David Atkin earned 1600 total points
ID: 39263080
Take ownership of the drive and then re-add your account into the permissions.  You will need to be a local administrator though.
0
 

Author Comment

by:sjw601
ID: 39263083
There is no system restore, but I do have an disk image backup of the system.  Would moving the drive to a different system help?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:sjw601
ID: 39263100
I can't seem to take ownership, as I can't access the drive's properties.  Is there a way to take ownership through another approach?
0
 
LVL 24

Expert Comment

by:aadih
ID: 39263102
Having not directly experienced this problem, I can only say that no harm trying.
0
 

Author Closing Comment

by:sjw601
ID: 39263148
Well, this worker after all.  I can access everything in the volume.  However, each folder appears with a lock on its icon.  Can I get rid of the locks?
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39263157
The locks are there because you don't have permissions again.  

In security under advanced, click change permissions.., add yourself and give yourself full control.  Then tick the box for 'replace all child object permissions with inheritable permissions from this object'.

The permissions will be pushed down to all the sub folders

Do that on the drive btw.
0
 

Author Comment

by:sjw601
ID: 39263234
Thanks. Scorpeo, but it doesn't work.  I already was in the users with full control.  There are two users: Administrators and "me."  I highlighted "me," clicked change permissions, ticked the box, and clicked Apply.  The locks still remain.
0
 
LVL 22

Expert Comment

by:David Atkin
ID: 39263245
Have a look here:
http://www.howtogeek.com/howto/17117/remove-the-lock-icon-from-a-folder-in-windows-7/

You may need to exit the folder and go back onto it again for the view to take affect.  I suggest you add the users group will full access as well.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Compliance and data security require steps be taken to prevent unauthorized users from copying data.  Here's one method to prevent data theft via USB drives (and writable optical media).
Windows Server 2003 introduced persistent Volume Shadow Copies and made 2003 a must-do upgrade.  Since then, it's been a must-implement feature for all servers doing any kind of file sharing.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question