Solved

Slow client internet access

Posted on 2013-06-20
12
1,414 Views
Last Modified: 2013-07-01
I have recently set up my network at my new office using a new Windows Server 2008 r2. Everything is working well, apart from the clients internet access is slow. Some website display a page cannot be found message and then when the page is refreshed the website is loaded. The clients web access is generally slow.

I have a Windows Server 2008 which has 2 NICS (one LAN and one WAN). The WAN NIC is connected to my Draytek router which is connected to the internet. All client computer use the server as a DC, DNS and gateway. To service the clients with internet the server is running Routing and Remote Access.

The internet access on the server itself is very fast.

Any help would be greatly appreciated.

Thanks,

John
0
Comment
Question by:clictime
12 Comments
 
LVL 7

Expert Comment

by:JardaCZ
ID: 39263164
Hello clictime,
what is your DNS server config? Do you use DNS forwarders or root servers?

Regards,
Jarda
0
 
LVL 10

Expert Comment

by:tmoore1962
ID: 39263413
Don't use your router as destination for a DNS helper, try and use your ISP's DNS servers if you are using forwarders.
0
 

Author Comment

by:clictime
ID: 39263640
Would it be easier to just change the default gateway of the clients computers to be the IP address of my draytek router? Would that be the easiest way to solve this issue?
0
 

Author Comment

by:clictime
ID: 39263645
Ps - the DNS setup is just the default one after adding the DNS role. I have not added any DNS entries.
0
 

Author Comment

by:clictime
ID: 39264538
I have setup a DNS forwarder on the server to googles DNS of 8.8.8.8.

I'll see if that works.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 30

Assisted Solution

by:pgm554
pgm554 earned 166 total points
ID: 39268294
Why two NIC's.
Unless you running a firewall on the server,just use one.
0
 
LVL 21

Accepted Solution

by:
Larry Struckmeyer MVP earned 167 total points
ID: 39268324
Just got EE alert to this thread.  

I agree with pgm554.  Reduce the server to one nic, change all the DNS settings on every system, including the server, to point to the server for DNS and all the gateway settings to point to the router for gateway.

In the DNS app on your server add either the ISP DNS servers as forwarders or use root hints.
0
 
LVL 38

Assisted Solution

by:Aaron Tomosky
Aaron Tomosky earned 167 total points
ID: 39268326
Normally you set the gateway to the router, DNS to server, dhcp on server.
Root hints, no forwarders.

There are reasons to stray from this setup, but that is the standard. Start with this and if you think you need differently, let us know why you think so.
0
 
LVL 18

Expert Comment

by:Akinsd
ID: 39288735
Check your DNS forwarder.

DNS related Slow Internet depends on the timeout duration, how many forwarder address you have and the sequence on the list.
If DNS fails to contact or resolve an address using the first forwarder on the list, it waits for the timeout to elapse and checks with the next forwarder address and so on until there is no more forwarder address.
DNS will now resolve to the root hint (if the check box "use root hints if no forwarder address is available" is checked).

So if your Internet speed is DNS related, that is the first thing you want to check. It is also best practice to enable automatic scavenging of stale records to make sure the table is not overfilled or contains stale records.

If you have issues with forwarder address, you may as well eliminate them. There are advantages and disadvantages, but it all depends on what is suitable for your network.

Forwarders are usually faster as they technically would handle less queries compared to the root hints. Root hints are almost always available and may be faster if your forwarders are not readily available.
0
 

Author Comment

by:clictime
ID: 39289570
Thanks for all of your help.

I ended up just disabling RRAS on the server and I just used my DrayTek router as the default gateway.

I then changed the DHCP settings appropriately.

Everything is now working perfectly.....

Thanks again.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now