Windows server 2008 R2 NIC Routing

I'm trying to share the internet connection that my windows 2008 R2 server has on one NIC with computers on the second NIC.

Unfortunately, when I use the "internet sharing" (ICS) posts elsewhere on the site, I find that  it wants to change my ip address automatically during setup without any choice.  Since I'm forced to used to use a specific ip address on the internet-accessible network, I can't use the ip address that it is giving me.

So, my end goal is to be able to share the internet connection the server enjoys on NIC#1 with computers on NIC#2.  ICS might not be the route I can go due to the fact that I need to have a specific ip address.  Is there a way to route the packets between the two networks?

So, here's my basic setup.
Windows 2008 R2 Server with two NIC's
NIC #1 connected to network with internet connection. This NIC is forced to have an ip address of 192.168.200.19 by the managers of the network. This computer can currently browse the web

NIC#2 is connected to a 10.2.x.x network that I would like to have internet connectivity.

How should I attack this problem?
wterrillAsked:
Who is Participating?
 
Matthew EnglandConnect With a Mentor Technology ConsultantCommented:
If I read this correctly, you basically want your Windows 2008 R2 server, to act as a router, in order to provide internet access from an issolated network subnet (such as a lab environment) to your production network.

To accomplish this, you're going to want to use Routing & Remote Access Services.

Once you have the RRAS Role installed, enable LAN routing in Routing and Remote Access.
Launch Routing and Remote Access from the Start Menu.
Right click on the server and click Properties. Then on the General tab, ensure the Router checkbox is checked for LAN Routing.
Add the desired Routing Interfaces
Expand the server to IP Routing > General, then right click and select New Interface. Add the desired interface and click OK.

Above is the basic configuration needed. You'll likly also want to add specific static routes, and Enable NAT, since you're 192.168.x.x network likly dosn't know about the 10.2.x.x network.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.