Set cabled LAN to take priority over wireless?

I have a user who has a Win7 laptop that both has wireless on, and its plugged into the network via a cable.

The user usually leaves it docked and its both plugged into the network cable and wireless on at the same time. We want it to ALWAYS default to the wired connection over the wireless whenever they are both on. Any ideas on how to set this in Win7?
LVL 8
TymetwisterAsked:
Who is Participating?
 
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Tymetwister,
In theory, Windows is supposed to pick the fastest connection available. Here's an interesting thread that talks about it:
http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/wired-and-wireless-connections-on-the-same-windows/ee40d9a6-297b-46d4-b5c8-db57d927b62e

The article states that you may force Windows to use a specific network connection by assigning a metric value to all of the connections, giving the lowest (best) value to the desired connection. My personal experience (and that's all it is!) is that Windows doesn't always get it right, and I sometimes found it using the wireless connection even when it had a (faster) wired connection. So I've taken to disabling the wireless connection when I'm wired. A simple way to do that is to put a shortcut to the wireless adapter on your Start menu and/or the desktop as follows:

Control Panel
Network and Sharing Center
Change adapter settings
Right-click on the wireless adapter and select Create Shortcut

It will say that it can't create the shortcut there and ask if you want it on the desktop instead...click Yes. You may then copy/paste the shortcut onto your Start menu (or cut/paste if you don't want to leave it on the desktop).

This shortcut will act as a toggle for the wireless adapter. When the wireless adapter is enabled, this shortcut will bring up a dialog box with a disable button...simply click it to disable the wireless. When the wireless adapter is disabled, this shortcut will automatically enable it. Regards, Joe
0
 
aadihCommented:
Try:

(1) Open the Network and Sharing Center.
(2) Click Change adapter settings.
(3) Press Alt to make the menus visible, select Advanced Settings... from the Advanced menu.
(4) Reorder the items in Connections so that your Local Area Connection is on top.

If you need a picture:

http://levynewsnetwork.wordpress.com/2011/12/01/windows-7-default-internet-connection-choice/ >
0
 
Fred MarshallPrincipalCommented:
I'm not sure what sort of preference behavior you're seeking.
You might set the wireless settings manually and delete the gateway address there.
But that doesn't lend for mobile laptop situations.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
tailoreddigitalCommented:
I second joewinograd's first idea about setting the Metric.   I have many systems with multiple network cards and the Metric has worked well for me.
0
 
TymetwisterAuthor Commented:
Well the thing is we dont want to have to manually turn it off each time, or run a command, etc. We just want it to always choose the wired network if its plugged in and the wireless adapter is also on.

Now, setting the priority seems to work, except when you go into the properties of the wireless network you use and check "automatically connect to this network when in range." then if its on the docking station, it will stay on the wireless network. If you uncheck that box, it will go to the wired network, but then it won't connect to wireless networks unless you manually do it. is there a happy medium?
0
 
Joe Winograd, Fellow&MVEDeveloperCommented:
> Now, setting the priority seems to work, except when...

This is the general problem I ran into. The metric should work all of the time...in theory, if there are a wired and a wireless connection available and the wired connection has a better metric, then Windows should connect to the wired. But, in practice, I found the "except when" kicking in. :)   So I took to disabling the wireless when I'm wired...a 3-click, relatively painless operation (Start>WiFi>Disable)...and then enabling the wireless when I'm not wired...an even more painless, 2-click operation (Start>WiFi). By pinning the WiFi shortcut to the taskbar (which I don't like to do), you could make those 2-click and 1-click operations, respectively. I'm not aware of an easier way. Regards, Joe
0
 
LeeTutorretiredCommented:
I've requested that this question be closed as follows:

Accepted answer: 500 points for joewinograd's comment #a39284887

for the following reason:

This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.