Solved

Time delayed by 5 minutes on 2008 DC Server impacting all domain comoputers.

Posted on 2013-06-20
16
358 Views
Last Modified: 2013-06-20
Time on 2008 DC is delayed by 5 minutes. Even after correcting the time several times, it goes back 5 minutes. This has been happening for weeks.

Any solutions please.
0
Comment
Question by:S T
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 8
16 Comments
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263417
Its likely syncing with another server using NTP (network time protocol).

Is it a virtual machine or physical?

Open command prompt (run as administrator).

run the following command:

w32tm /query /status

it should say "Synced by (S)NTP)" meaning its using the time sync
then further down it will say.

"Reference ID: ......... "(source IP: x.x.x.x)"

the source IP is where it is syncing from.

Ned
0
 

Author Comment

by:S T
ID: 39263465
To nedramsay

It's a virtual machine running on VMWare.
0
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263531
Ok did you run the command I said above? That will tell us where it is syncing with.

Within VMWare Vsphere there is an option to synchronize the time with the VMware host rather than using windows timing.

In previous versions of vmware (up to 5) you right click on the VMware tools icon in the system tray. Go to properties. Then options. There is a tick box that says "time synchronisation between the esx host and the virtual server" if it is ticked it will sync with the host machine.

With ESXi 5.1 you can enable time synchronization with the host in the VM's settings (Edit Settings –> Options –> VMware Tools)
0
Backup Solution for AWS

Read about how CloudBerry Backup fully integrates your backups with Amazon S3 and Amazon Glacier to provide military-grade encryption and dramatically cut storage costs on any platform.

 

Author Comment

by:S T
ID: 39263555
To nedramsay:

After running the following command as Admin in DC 2008:
w32tm /query /status

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\administrator.HASA>w32tm /query /status
Leap Indicator: 0(no warning)
Stratum: 1 (primary reference - syncd by radio clock)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0000000s
Root Dispersion: 10.0000000s
ReferenceId: 0x4C4F434C (source name:  "LOCL")
Last Successful Sync Time: 6/20/2013 10:32:08 AM
Source: Free-running System Clock
Poll Interval: 6 (64s)
0
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263562
Ok local means its running off its own clock not NTP so I would guess that the VMware host it is running on has the wrong time. Do you have access to the hosts?
0
 

Author Comment

by:S T
ID: 39263568
Yes. I have access to the hosts. It is running on vSphere Client Version 5.1.0
0
 
LVL 7

Accepted Solution

by:
Ned Ramsay earned 500 total points
ID: 39263585
1) right click on the VM
2) edit settings
3) in the options tab select VMware tools
4) down at the bottom right there is a tickbox "Synchronize guest time with host"

If this is enabled it means that the VM will use whatever time is set on the ESX host.

You can either untick this and manually set the time on the windows server, or better would be to make your hosts synchronize with a public time server. So make sure this is ticked.

1) click a host
2) on the configuration tab click "Time Configuration"
3) Click properties (top right)
4) tick the NTP Client Enabled button then click Options
5) Make sure its set to Start and Stop with host.
6) Select NTP settings on the left and add the following servers into the list.
0.pool.ntp.org
1.pool.ntp.org
2.pool.ntp.org

These are public NTP servers, if you run an NTP server on your network you may want to point it to that instead.

Tick the "restart ntp service to apply changes" button and hit OK.
You should see the time on the host and guest VM update to the correct times.
If the time on the host "Time Configuration" page doesnt update, hit the refresh button (top right).

Make sure you have the same settings across all your hosts.
0
 

Author Comment

by:S T
ID: 39263668
Please verify what you wrote here:

"You can either untick this and manually set the time on the windows server, or better would be to make your hosts synchronize with a public time server. So make sure this is ticked."
0
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263687
Ok, if the box is ticked it means that it will synchronize from the host time down to the VM.

If its unticked then whatever time you set in windows will stay.

The recommendation is to synchronize your entire network via NTP. An easy way of doing this is making sure the box is ticked then following the rest of the steps so your hosts update from the public pool.

This will have the following effect:
Public NTP pool will filter down to ESX host machine which will pass down to Windows VM
Otherwise you will be managing every windows machine on your hosts individually.

Does that make sense? Sorry, im doing like a million things at once today haha!
0
 

Author Comment

by:S T
ID: 39263713
Thank you Guru nedramsay.

Got it.
0
 

Author Comment

by:S T
ID: 39263755
nedramsay

Sorry to bug you but all domain computers are not syncing to the DC which now has the correct time.
0
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263817
The computers should automatically be syncing to the DC if they are on the domain. They may need a reboot to pick up the time as its now changed. If you want to add "belt and braces" to your setup you can do the following on your DHCP server.

Open the DHCP management snap in.
Select your DHCP server from the list.
Expand the scope
Right click Scope Options
Configure Options
look for option 004 Time Server and tick it.
add the IP of your domain controller into the options.

Clients may need a restart to get the correct time.
0
 

Author Comment

by:S T
ID: 39263845
We dont use DHCP. All domain computers have static IPs.

I ran this tool on my domain computer and time is not syncing with DC.
http://technet.microsoft.com/en-us/library/cc758905(WS.10).aspx
0
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263858
try this on a client pc (run as admin).

w32tm /config /manualpeerlist: X.X.X.X /syncfromflags:manual /update

but put your DC ip address instead of the Xs
0
 
LVL 7

Expert Comment

by:Ned Ramsay
ID: 39263905
If you want to do it by group policy then there is a good guide here: http://www.altaro.com/hyper-v/configuring-time-synchronization-for-all-computers-in-windows-domain/
0
 

Author Comment

by:S T
ID: 39263911
Thx for all your help "Guru nedramsay".
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Best practices power settings GPO Win 10 4 121
Permanently disable Server 2012 hiberfil.sys file 3 148
Server HP DL380 G7 13 48
You Must Change password - RDS 2012 R2 5 48
Some time ago I faced the need to use a uniform folder structure that spanned across numerous sites of an enterprise to be used as a common repository for the Software packages of the Configuration Manager 2007 infrastructure. Because the procedu…
INTRODUCTION The purpose of this document is to demonstrate the Installation and configuration of the Data Protection Manager product. Note that this demonstration was prepared on the basis of Windows OS is 2008 R2 and DPM 2010. DATA PROTECTI…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question