Solved

iPrint Error 0x406

Posted on 2013-06-20
12
1,278 Views
Last Modified: 2013-07-14
Two days ago my iPrint server stopped printing. The print manager was no longer running.

When I started it with:

rcnovell-ipsmd start

I would see:

WARNING A child process has gone or the iPrint Manager has just experienced a fatal error. It will be restarted by its monitor process.

That was repeated several times over a few minutes in /var/opt/novell/log/iprint/ipsmd.log until I got:

FATAL A child process has gone or the iPrint Manager has had a fatal error and has been auto-restarted 5 times within the last hour. There appears to be a repetitive problem occurring. The iPrint Manager is exiting.

We are running Equitrac for print accounting, it uses the
eqacctg
accounting load string, when I removed this from all printers the print manager will stay up. However there are several printers which do not show in /ipp but still exist in eDir. When I try to open them in iManager I get this error:
 
Error       Request (CLIENT_ERROR) - bad status code (0x406)
IPP Error: 0x406

The remaining printers work fine unless I put in the accounting load string. I am able to create a new printer and it works as long as I do not add the account load string. Some other errors along the way indicated LUM/namcd/LDAP errors due to an expired certificate, I believe I have that resolved but this issue with the printers remains.

I have been unable to determine why some printers work and others don't. Any ideas would be greatly appreciated.

James.
Screen-shot-2013-06-20-at-2.29.5.jpg
0
Comment
Question by:jamesjweg
  • 9
  • 3
12 Comments
 

Author Comment

by:jamesjweg
ID: 39263797
Also I found this in root's mail:

X-Original-To: root                                                                                                                                                            
Delivered-To: root@iPrint.localdomain                                                                                                                                          
Date: Tue, 18 Jun 2013 12:04:31 -0400                                                                                                                                          
To: root@iPrint.localdomain                                                                                                                                                    
Subject: Error during registration                                                                                                                                              
User-Agent: nail 11.25 7/29/05                                                                                                                                                  
From: root <root@iPrint.localdomain>                                                                                                                                            
                                                                                                                                                                               
Execute curl command failed with '60':                                                                                                                                          
curl: (60) SSL certificate problem, verify that the CA cert is OK. Details:                                                                                                    
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed                                                                                              
More details here: http://curl.haxx.se/docs/sslcerts.html                                                                                                                       
                                                                                                                                                                               
curl performs SSL certificate verification by default, using a "bundle"                                                                                                        
 of Certificate Authority (CA) public keys (CA certs). The default                                                                                                              
 bundle is named curl-ca-bundle.crt; you can specify an alternate file                                                                                                          
 using the --cacert option.                                                                                                                                                    
If this HTTPS server uses a certificate signed by a CA represented in                                                                                                          
 the bundle, the certificate verification probably failed due to a                                                                                                              
 problem with the certificate (it might be expired, or the name might                                                                                                          
 not match the domain name in the URL).                                                                                                                                        
If you'd like to turn off curl's verification of the certificate, use                                                                                                          
 the -k (or --insecure) option.

But I think I have the expired cert issues resolved.

James.
0
 
LVL 18

Assisted Solution

by:ZENandEmailguy
ZENandEmailguy earned 500 total points
ID: 39265495
Once you fixed the certs did you either restart ldap or the ndsd?
Restart of ldap is
/opt/novell/eDirectory/sbin/nldap -u followed by a -l
Restarting eDirectory is rcndsd restart

What rev of iPrint is installed?
Type rpm -qa |grep iprint
To discover this.
Your problem is a known one from a post in 2010 but isn't specific to equitrac. I've only worked with it and iPrint on OES2sp3 with some iPrint patch updates.

Scott
0
 

Author Comment

by:jamesjweg
ID: 39267290
I rebooted server after fixing the certs.

rpm -qa |grep iprint
novell-iprint-client-6.2.20090929-0.5
yast2-novell-iprint-2.14.8-61
novell-iprint-migration-6.2.20091001-0.5
novell-iprint-iprntman-6.2.20090908-0.5
novell-iprint-server-6.2.20091005-0.5
novell-iprint-management-6.2.20090924-0.6

James.
0
 
LVL 18

Assisted Solution

by:ZENandEmailguy
ZENandEmailguy earned 500 total points
ID: 39268290
With my post here I assume you're using OES2sp3.  That is what the following iPrint patches are for:

December 2012 iPrint server update for x86 and x86)_64:
http://download.novell.com/Download?buildid=lhbqIjhkk4E~

iPrint client update:
http://download.novell.com/Download?buildid=k6yH0sy992E~

If you're using OES2sp2 there are different server downloads.

It appears you're using a 2009 release of iPrint.  I know many things have been fixed and updated and I'll bet the equitrac fix will be in there as well.

If you can't get to these patches let me know.  There are located at http://download.novell.com/patch/finder and then search Open Enterprise Server

Scott
0
 

Author Comment

by:jamesjweg
ID: 39272029
I am running OES2sp2, honestly iPrint has just worked so it's been neglected on updates. I am trying to work trough the update path but am getting a expired SSL cert from update.novell.com. When I get that figured out I'll get this machine up-to-date.

James.
0
 

Author Comment

by:jamesjweg
ID: 39275049
The box is now patched up to date and the problem is still there and has not changed. Any more ideas?

James.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:jamesjweg
ID: 39275063
FYI, current info is:

iPrint:~ # cat /etc/SuSE-release
SUSE Linux Enterprise Server 10 (i586)
VERSION = 10
PATCHLEVEL = 4
iPrint:~ # cat /etc/novell-release
Novell Open Enterprise Server 2.0.3 (i586)
VERSION = 2.0.3
PATCHLEVEL = 3
BUILD
iPrint:~ # rpm -qa | grep iprint
novell-iprint-iprntman-6.3.20110909-0.7
yast2-novell-iprint-2.14.8-66
novell-iprint-migration-6.3.20121204-0.7
novell-iprint-server-6.3.20130430-0.7
novell-iprint-management-6.3.20121218-0.7
novell-iprint-client-6.3.20130430-0.7
0
 

Author Comment

by:jamesjweg
ID: 39276021
Ok, I got desperate and was going to delete and recreate all the affected printers. I had tried this once with one of the affected printers and it worked. Now that I have updated I get this:

Error: Delete Print Objects Failure
You have insufficient rights for this task.

When I try to delete the old printer. Right now I am removing my hair one handful at a time.

James.
0
 
LVL 18

Expert Comment

by:ZENandEmailguy
ID: 39276669
James
Confirm that your login is listed as an operator as well as a manager of any printer object you wish to delete.

Since the updates were put in will the ipsmd start properly?  Is it possible the iPrint database is corrupt and needs to be rebuilt?

Do you have the ability to open a service request with Novell?  I can for you if not but I'm not sure how you'll contact me. EE won't let me post contact info as doing so defeats the purpose of the forums.

Scott

If you can see my profile you may find my contact info but I'm not sure if you can see it.
0
 

Author Comment

by:jamesjweg
ID: 39276892
That user is a operator and a manager, it is the user which created the object in the first place. ipsmd is running. How would I determine if it is the iPrint db? I am starting wonder if I need to start over with a fresh install?

James.
0
 

Accepted Solution

by:
jamesjweg earned 0 total points
ID: 39310630
As a follow up in case anyone else hits this;

The inability to delete objects was due to a LUM problem. I fixed the LUM issue and still could not print or access the affected printers. I ended up deleting and recreating all printers with the problem. All I can do is hope that it does not return as I never was able to determine the cause.

James.
0
 

Author Closing Comment

by:jamesjweg
ID: 39324389
ZENandEmailguy's input as helpful, but there was ultimately no solution found.

James.
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Save Excel documents to PDF and RETAIN color 16 129
Can not print with Windows 7 11 37
Issue to mail 11 72
Running cost per page (excluding the cost of the paper) 3 38
This seems to be a very common error related to the Samsung printer driver. First, this is the error we're talking about: Log: System Type: Error Event: 7000 Agent Time: 3:37:24 am 22-Apr-09 Event Time: 6:07:24 pm 21-Apr-09 UTC Source: Se…
When I recently replaced my image transfer kit on my office HP color laserjet 5550dn printer, I had a slight problem.  The left bracket that holds the transfer kit got stuck in the upright locked position instead of being at a 45 degree angle facing…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now