Problem with RDP Client connection to Windows 7 system from WinXP

I have an issue that when connecting to a Windows 7 system (workstation) with an RDP client from a WinXP system (laptop) it will not connect and displays the following message.

Remote Desktop Connection Message
“Your computer can’t connect to the remote computer because an error occurred on the remote computer that you want to connect to.  Contact your network administrator for assistance”

This error is intermittent, sometimes the RDP client on the laptop connects and sometime it doesn’t.  I can connect consistently to the server or other workstations on the network with the same user and the same laptop.  I can also connect consistently to the workstation in question with other systems outside the network.

The problem is I need to use the laptop to connect to the workstation but this particular workstation errors the connection sometime not allowing the laptop to connect at all.

• I have upgraded the RDP client on the laptop to v7.0.
• I have tried several other systems RDP client connection to the workstation.
• I can connect to the workstation consistently from the laptop when using the Remote  
Web Workplace in SBS2008
•      Removed Nortons 360

The system that is housing the Terminal Server Gateway is SBS2008
TechAKAsked:
Who is Participating?
 
SandeshdubeySenior Server EngineerCommented:
Your computer can't connect to the remote computer because an error occurred on the remote computer that you want to connect to.  Contact your network administrator for assistance:http://clintboessen.blogspot.in/2013/02/your-computer-cant-connect-to-remote.html
0
 
hlapradeCommented:
Hi TechAK, check where the service is listening

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

you should have a dword "PortNumber"=dword:00000d3d"

00000d3d = 3389 that it is the default port.

After that make sure that where you open the Remote Desktop connection, go to Options/Advanced and where it say "If Server authentication fails" select "Connect and don't warm me".

Another thing is the firewall, check for RDP being Allow for either Domain/Work/Public and that the port that is defined on your registry is the same on the rule on the RDP.

Luke
0
 
Tony BarkdullCommented:
Make sure to disable IPv6 in the Windows 7 machine and the remote XP machine if it is installed. We have had the same issue at our business and after disabling IPv6 on one or both, reliable connectivity is restored.
0
 
LeeTutorretiredCommented:
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
0
 
TechAKAuthor Commented:
Sandeshdubey post on 2013-06-13 did the trick.

Go To: http://clintboessen.blogspot.in/2013/02/your-computer-cant-connect-to-remote.html


After researching the issue it turned out that the RD Session Hosts needed to be configured to use RDP Security as the Security Layer.  After installing a custom trusted certificate to the RDP-Tcp connection to ensure users connecting to the session hosts do not receive RDP Certificate not trusted warnings the issue started occuring.
 
These configuration options can be found under "Remote Desktop Session Host Configuration"
 
By default the Security layer was set to Negotiate.
 
Set all servers to RDP Security Layer in your farm to ensure both XP and Windows 7 clients can connect.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.