?
Solved

How do I get the “ping” command line in windows 7 to work..

Posted on 2013-06-20
9
Medium Priority
?
408 Views
Last Modified: 2013-06-20
I am getting the message that the “ping” is not a recognized program.
C:\>ping -a irvaruba
'ping' is not recognized as an internal or external command,
operable program or batch file.
0
Comment
Question by:frankbustos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 39264593
i.e    at a command prompt,    

ping google.com      

ping 192.168.1.1
0
 
LVL 24

Expert Comment

by:aadih
ID: 39264596
Try: Navigate to Winows\System32 directory (CD command). Then type ping ?

It looks like your PATH variable is messed up.
0
 
LVL 23

Expert Comment

by:tailoreddigital
ID: 39264600
You can ping right from the root,    cd\    takes you to root
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:frankbustos
ID: 39264603
aadih, ok that worked. How can I set it to that when I go to the command prompt it goes to that instead of just the root of c?
0
 
LVL 24

Accepted Solution

by:
aadih earned 2000 total points
ID: 39264604
To correct the Path variable, try:

Select Start, right click My Computer, select Properties. Next select the Advance tab, and Environment Variables button, and select the Path variable listed under System Variables.

 When editing it should include:

 %SystemRoot%\system32

 Which translates to something like:

 C:\WINDOWS\system32.
0
 

Author Comment

by:frankbustos
ID: 39264606
no i can't ping right from the root...
0
 

Author Closing Comment

by:frankbustos
ID: 39264608
awesome, that worked! thanks!
0
 
LVL 24

Expert Comment

by:aadih
ID: 39264612
Check your Path variable.

 Look here with pictures:

http://www.computerhope.com/issues/ch000549.htm >
0
 
LVL 14

Expert Comment

by:brendanmeyer
ID: 39264613
from cmd run

echo %path%

Open in new window


make sure 'C:\Windows\system32' is in the output

if not
go to control panel->system
advanced system settings (left side bar)
environment variables
find 'path' under system variables
add to the end ";%SystemRoot%\system32" (without quotes)
0

Featured Post

Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
Suggested Courses

741 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question