Solved

iMac won't install from CD

Posted on 2013-06-22
31
680 Views
Last Modified: 2013-07-26
I have an iMac that has some serious problems with the file system.  So I want to reinstall the OS.  However, every time I put in the OS X 10.6 Snow Leopard CD (the one with the picture of the snow leopard on the box) it spits it out.  
I slide the disk in and turn on the iMac holding down the C key.  It won't take it right away and the white light comes on.  I keep gently pushing in the CD but it doesn't take it right away.  After a couple taps it does take it, the white light goes away, and it sounds like it wants to start up from the CD....but doesn't.  It just spits it out.   The same is happening with my Disk Warrior CD.

Any ideas would be helpful.  Thanks
0
Comment
Question by:Rizznut
  • 17
  • 9
  • 5
31 Comments
 

Author Comment

by:Rizznut
ID: 39268263
Also, after it spits it out the fans turn on high and the screen stays black.
0
 
LVL 53

Expert Comment

by:strung
ID: 39268266
Macs won't boot from an OED DVD that came with a different model Mac, or a full retail DVD with a system that is older than the one the Mac shipped with.

Is your DVD black or grey? If it is grey, it is an OED DVD from a Mac. Is it the one that came with your Mac? If not, it won't work.

If it is a black full retail DVD, you still need to know if it is older or newer than the system your Mac shipped with. What is your exact model and do you know what system it shipped with?
0
 

Expert Comment

by:Kepgnar
ID: 39272424
You can boot the machine holding the option key, then insert the disc to find out if the machine sees it as a bootable volume at all. That might narrow down your problem a little bit.
0
 

Author Comment

by:Rizznut
ID: 39294497
So I got the Tiger CD (Black with the big X on it) and it still won't boot to it.  
White light with black screen for 2-3 minutes and then the fans run high.

I've tried a bunch of different key function upon boot up to try and get some response from this thing (ie:  Command-Option-Shift-Delete, Command + Option + O + F, Command, Option, P, and R)  it just spits out the CD.

:(
0
 

Author Comment

by:Rizznut
ID: 39294559
i got it to boot, but not to the CD.  I got this message on the screen.  I hear the chime too.
Any help is appreciated.
20130702-124403.jpg
0
 

Expert Comment

by:Kepgnar
ID: 39294917
Rizznut, what year is your iMac? I don't see it listed in the question anywhere.

If you're not sure or can't figure it out, post the first 5 of the serial number, should be on the bottom of the base. Sometimes I can tell from that. If you can't get the serial, is the machine case aluminum with aluminum or black back, or all white plastic?

An iMac that shipped with an OS newer than Tiger won't be able to boot to that disc.
0
 
LVL 53

Expert Comment

by:strung
ID: 39295082
You have to hold down the C key to boot from the CD.

The error message you got was a kernel panic.

See:  http://www.thexlab.com/faqs/kernelpanics.html
0
 

Author Comment

by:Rizznut
ID: 39295125
it's a A1145 built between Oct 12, 2005 - Jan 10, 2006.  It's the white 20".
I have tested the HD which came back fine.  I then removed the RAM and now I'm getting
this error.  This thing is all over the place.  I sometimes get the chime and the apple logo with no white light.  Other times the white light is on and it's a black screen.
I thought the Black X Tiger CD would work :/
20130702-150102.jpg
0
 
LVL 53

Expert Comment

by:strung
ID: 39295147
That Mac shipped with 10.4.2, so it is possible that it will not boot with 10.4.0 which I presume is on the CD.

Should boot with a black 10.5 CD.

I am not sure I understand what you mean when you say you removed the RAM. Are you trying to boot a computer that has no RAM?
0
 

Author Comment

by:Rizznut
ID: 39295414
The CD is the black 10.4.  And http://www.powerbookmedic.com/identify-mac-serial.php says it came with 10.4.2.  So I would think that would work.
But I can't get it to book to Tech Tool or Disk Warrior.  I read some where that it could be the battery??  It comes with 512MB installed and then another slot for an additional 512.  That's the stick I pulled.
0
 

Expert Comment

by:Kepgnar
ID: 39296883
A machine that shipped with 10.4.2 will not boot from a 10.4.0 disk.

Sometimes on those older machines, booting even to a perfectly-good disk can be troublesome.

If you have access to another mac with FireWire you can connect the two, boot the failing machine in Target Disk Mode (holding down the T key while booting.) This will mount the drive on the other Mac and at this point you can run Disk Utility, reformat the drive, etc.

In my experience using Target Disk Mode has worked more often than booting to a CD when dealing with troublesome hard drives.
0
 

Author Comment

by:Rizznut
ID: 39302757
I was able to format the HD via Target Mode.  But it still won't boot to the CD.
Is there a way to install it via Target Disk Mode?
0
 
LVL 53

Expert Comment

by:strung
ID: 39302895
Insert the CD in the other computer and tell it to install on the target disk
0
 
LVL 53

Expert Comment

by:strung
ID: 39302898
0
 

Author Comment

by:Rizznut
ID: 39302987
It says 10.4 can not be installed on this machine.  Yet it came with 10.4.  
Not sure what to do now?
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Expert Comment

by:Kepgnar
ID: 39303140
You need a newer OS disk. The statement that it wouldn't boot with a disk older than it shipped with should've been appended to say you can't install an older version than it shipped with. You can purchase snow leopard discs from apple.com still I believe. That or find a leopard disk as strunq said.
0
 

Author Comment

by:Rizznut
ID: 39303189
I tried Snow Leopard 10.6.3 but it gets spit out too.  Should I find a 10.5 disk?
0
 

Expert Comment

by:Kepgnar
ID: 39303287
You may be able to boot the other Mac to the snow leopard installer disk while your problem Mac is connected to it also via target disk mode and install it that way?
0
 

Author Comment

by:Rizznut
ID: 39316185
got the OS X Leopard 10.5 and held down the C key and it spit it out.  put it back in and rebooted and held down command, option, shift delete - i can hear it spinning and then I get a little folder and a flashing ? and the old smily face. And then it spits the disk out.

how do i push the leopard install in target disk mode to the broken Mac when it's in the good Mac??
0
 

Expert Comment

by:Kepgnar
ID: 39316202
Been awhile since I've done it but see if you can do this:

good machine, booted normally, insert disk and open up-double-click to run the installer.

then you should get to a point where you can choose the blank drive.

however you would need to format the blank drive first as Mac OS Extended (Journaled) in disk utility.

will that work?
0
 

Author Comment

by:Rizznut
ID: 39316547
kepgnar, that worked except that I got a error msg after it started the install.  I'm not sure how far along but it was definitely installing when I left.

Install Failed.  Mac OS X could not be installed on this machine.
The installer could not install some files in "/volume/untitled"
Contact the software manufacture.

going to reformat the drive and run it again.
0
 

Expert Comment

by:Kepgnar
ID: 39317823
if it keeps failing after you reformat I would say the drive is probably bad.
Getting into that machine may not be too difficult.
If it's the one that opens from the back it should just be some screws along the bottom.
0
 

Author Comment

by:Rizznut
ID: 39319683
did the reformat and same issue.  Will try a new drive tomorrow.
0
 

Author Comment

by:Rizznut
ID: 39327553
same problem with a brand new hard drive.  It won't boot to cd and fails during the installation when I run it via Target Disk.
0
 

Expert Comment

by:Kepgnar
ID: 39327585
man. I think I'm stumped. It's possible that machine requires a machine-specific OS disk but not likely.

You did format the new drive accordingly correct?

Is all this happening with your 10.6 retail dvd also?

If you have a drive sled you could always try imaging the drive with an OS then installing the drive in the iMac?

Maybe there's just an easy step that was missed along the way, doesn't make much sense that it wouldn't work with a new drive.
0
 

Author Comment

by:Rizznut
ID: 39328324
i too am stumped.  It won't load 10.4 10.5 or 10.4.  It won't load Disk Warrior either.
I connected the new HD via USB to my good mac and formatted it.  No issues there.  I just don't get it.
0
 

Author Comment

by:Rizznut
ID: 39334054
could it be as simple as a faulted DVD player?
0
 

Expert Comment

by:Kepgnar
ID: 39334114
it could be that but haven't you used 2 different optical drives at this point?
0
 

Author Comment

by:Rizznut
ID: 39337534
yes I guess I have. :(
0
 

Accepted Solution

by:
Rizznut earned 0 total points
ID: 39343540
Giving up on this one.
0
 

Author Closing Comment

by:Rizznut
ID: 39357277
can't get it to install.  Tried multiple installation CD's, Target Disk install and a new HD.  Giving up.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Information security is a multi-billion dollar industry. Just as lucrative is the black market industry which trades stolen identities, credit card numbers and software exploits all over the world. Nothing is hack-proof. The best one can do is make …
A common question or need, when setting-up a new Mac for someone would be to make all of the applications, installed, available from the dock. Many people often do not realize an application is installed unless it is in the dock. Creating a custo…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now