• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 921
  • Last Modified:

PHPMYADMIN Exporting DB and page goes blank after 40 seconds

Hiya All

I have MAMP PRO running on my local machine and I am stuck trying to export a DB.

The DB does have one large table which i think could be the cause of the issue/ timeout.

When i try to export a database via PHPMYADMIN I get a blank page after about 40 seconds.

Any Ideas

Ww
0
willa666
Asked:
willa666
  • 4
  • 3
  • 2
  • +1
1 Solution
 
Ray PaseurCommented:
Can you please tell us a little more?  Maybe post the CREATE TABLE scripts and show us the counts of rows in the tables?  You may be able to control the "timeout values" with configuration settings.
0
 
willa666Author Commented:
The table has 45 columns and there are 45,000 rows. the table is a raw import from a CSV file.
0
 
Ray PaseurCommented:
OK, that's 2,025,000 data points.  How big is the table in bytes?
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
sscottiCommented:
Do you get an error message or see an error message in the logs.  If you are running MAMP you can view the MySQL logs and PHP logs from the main menu.

Also, you might be exceeding the memory resource limit that you have configured for PHP.  The PHP.ini file by default I think has:

max_execution_time = 30     ; Maximum execution time of each script, in seconds
max_input_time = 60      ; Maximum amount of time each script may spend parsing request data
memory_limit = 32M      ; Maximum amount of memory a script may consume (8MB)

You might try increasing that and checking the other configuration parameters for memory in the my.cnf file, also configurable from within MAMP.  With a file that large you are probably exceeding some of the default limits.
0
 
Robert SaylorSenior DeveloperCommented:
have you tried from SSH? mysqldump
0
 
willa666Author Commented:
Ray_Paseur
Space usage
Data      46.6      MiB
Index      1.5      MiB
Total      48.1      MiB

sscotti
I dont see any error in the console logs :(

here is the PHP.ini setting i tried with the same issue.
;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 120     ; Maximum execution time of each script, in seconds
max_input_time = 120      ; Maximum amount of time each script may spend parsing request data
memory_limit = 64M      ; Maximum amount of memory a script may consume (8MB)


rsaylor
I have not tried that yet and only really want to do this as a last resort :)
0
 
Ray PaseurCommented:
You might raise the memory limit to 512MB and try again.  It's probably not the time settings -- those would not cause a failure at 45 seconds.

Make sure you have error_reporting(E_ALL), and an error log file set up (or display the errors to the browser).
0
 
willa666Author Commented:
Ray_Paseur - raisign teh memory_limit seems to have worked!

Cheers All!
0
 
Ray PaseurCommented:
Great!  Thanks for the points, ~Ray
0
 
sscottiCommented:
Thanks for the assist.  :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now