?
Solved

Exchange 2010 DAG Netbackup Backup fails with error code 2

Posted on 2013-06-24
4
Medium Priority
?
3,974 Views
Last Modified: 2013-07-04
Dear All,

We have following env :-
Netbackup 7.5 on Win2k8 Server
Exchange 2010 DAG on Win2k8 Server.

Problem :-
We have 2 nodes in DAG - MBX01 & MBX02.

If Netbackup Bpresolver resolves MBX01 server backup gets failed with following error ( In Both Active & Passive selections)
"You cannot use the backup directive for Database Availability Groups for an Exchange Standalone backup"

If Netbackup Bpresolver resolves MBX02 server backup gets completed Both Active & Passive selections)

How Bpresolver service decides which Server to resolve for Backup.
Backups are failing due to this.
Exchange-Error23Jun.txt
BPrsolver23Jun.log
0
Comment
Question by:amit_bhabal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 6

Expert Comment

by:Vijay Pratap Singh
ID: 39270520
Actually Firewall is enabled on both windows 2008 nodes and I only enable the ports use for Netbackup with the default open ports of Win2008 Server R2. See the Netbackup ports below which I opened.

 

Note:

Open the below ports in case to keep the OS Firewall ON. or your Exchange 2010 Nodes are behind Network/etc Firewall.  

13724(vnetd)

13782(bpcd)

1556(pbx)

13720(bprd)
0
 
LVL 22

Assisted Solution

by:Haresh Nikumbh
Haresh Nikumbh earned 600 total points
ID: 39270796
0
 
LVL 2

Accepted Solution

by:
amit_bhabal earned 0 total points
ID: 39270994
Hi All,

Firewall is off & Netbackup ports are already open.

We have resolved the problem.

The issue is :-
Exchange Management Shell is not properly working on MBX01 Server.

We have executed 3 commands on Exchange Management Shell on both Server

get-databaseavailabilitygroup

get-mailboxdatabase

get-mailboxdatabasecopystatus

We have found the issue when we executed the " get-mailboxdatabasecopystatus" command.
The command is working in MBX02, But on MBX01 it is showing error.

Exchange Administrator has resolved the issue in IIS 7 Application

Now backup is started.

Thanks & Regards
Amit Bhabal
0
 
LVL 2

Author Closing Comment

by:amit_bhabal
ID: 39299391
I have already tried above solutions.
From the given commands i came to know that problem is with Exchange Management Shell.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
In-place Upgrading Dirsync to Azure AD Connect
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question