Solved

Outlook 2010 disconnected from exchange 2010 on random users

Posted on 2013-06-24
13
1,881 Views
Last Modified: 2013-07-26
Hi,

This morning alot of my users cant get connected to the exchange server, outlook starts in disconnected mode, just like it´s not even trying to connect.

I have rebooted the server, the clients, added the accounts again without any sucess.

I have checked all windows logs and no errors i can relate.

Anyone got some tips?
0
Comment
Question by:mattemattsson
  • 6
  • 5
  • 2
13 Comments
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39271073
When you say a lot of users do you mean all or just the odd one or two? Can those same users get to Outlook Web App?

Have you checked all the Exchange Services are running?
0
 

Author Comment

by:mattemattsson
ID: 39271085
Hi,

All exchange services is running, i would say about 80users connected via MAPI without problem and 20users can´t connect att all. OWA works and activesync works.

I can´t find any diferanses between users working and not :(
0
 
LVL 22

Expert Comment

by:Haresh Nikumbh
ID: 39271086
check microsoft exchange rpc client access status
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:mattemattsson
ID: 39271091
More info, if i delete the useraccount and re add it in E-mail settings on the client, it finds the users and adds the account correctly but when i try to start outlook it says "cant find standardfolder for email, you must connect to Microsoft Exchange...."
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39271096
Can you provide some more information about your setup?

So, just to confirm, the 20 users that cannot connect using MAPI also cannot connect using OWA?

Are all users in a single database?
Are all users on the same site?
Same Exchange Server?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39271100
That sounds as if the database those users are on is not mounted?
0
 

Author Comment

by:mattemattsson
ID: 39271102
How do u mean "check microsoft exchange rpc client access status ", are you refering to the connection status for microsoft exchange" in outlook?
0
 

Author Comment

by:mattemattsson
ID: 39271107
The databases are mounted, i can connect the user via OWA and they also got a terminal server and the same user can access their mailbox trough Outlook there.

Very strange
0
 
LVL 22

Accepted Solution

by:
Haresh Nikumbh earned 500 total points
ID: 39271108
check if this works for you

You need to set authenticationmethod to basic, Ntlm, Negotiate on the outlook anywhere.

Set-OutlookAnywhere "<Client Access server name>\RPC (Default Web Site)" -IISAuthenticationMethods Basic, Ntlm, Negotiate

Set-OutlookProvider EXPR -CertPrincipalName none

Then restart the MSExchangeServiceHost

Configure Outlook to use rpc over http and remove the selection for Connect only to Proxy...

http://social.technet.microsoft.com/Forums/exchange/en-US/8e45e992-a5ff-41f8-9868-0e02fd800b80/cannot-open-your-default-email-folders-you-must-connect-to-microsoft-exchange-with-the-current
0
 

Author Comment

by:mattemattsson
ID: 39271116
Hi, answers below

So, just to confirm, the 20 users that cannot connect using MAPI also cannot connect using OWA? Yes, also trough outlook on the terminal server (on different site)

Are all users in a single database? Yes
Are all users on the same site? No, the users that is getting disconnected errors are on different sites (4 sites, the site where the exchange server is located have no errors, but VPN between the offices works fine and i have users in all sites that works)
Same Exchange Server? Yes
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39271130
There is a number of issues that could cause this, DNS, being one of them.

Do the users at the remote site using Outlook anywhere?

When you setup the Exchange profile in outlook, enter the servername and the user mailbox details but don't click check name.  Click More Settings.  under connections tab click the button.

In the first box enter the OWA URL without the /OWA on the end.  Change the authentication settings to basic.  Click OK then click check names.

Can you now connect?
0
 

Author Comment

by:mattemattsson
ID: 39271172
Hi,

No they are not using HTTP, connecting over MAPI.

If i set the account to connect over HTTP it works, so no problems with that.

I can resolve the exchange server over DNS
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 39271181
You should be using Outlook Anwhere from remote sites.  If you are not you should have a local client access server.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This video discusses moving either the default database or any database to a new volume.

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question